Cannot install or unistall applications (i beat you to solve this problem is impossible)

hi guys i’m having a big problem every time i try to install or uninstall applications it gives me this error, i’ve already tried with apt update but nothing i can’t even uninstall codeblocks from the software storesudo apt-get install sl Reading package list ... Done Dependency tree generation Read status information ... Done E: The codeblocks-common package needs to be reinstalled, but an archive of it cannot be found.
P.S i translate it from italian to english so i think there could be something wrong
P.S(2) codeblocks is an IDE for programming in c++

First, check your updater settings. Next, try Synaptic.

In addition to Carmars suggestion, in terminal please run:

sudo dpkg --configure -a

You can then try either

sudo apt --fix-broken install

Or use Synaptic Package manager, which is known to successfully install codeblocks including dependencies.

Generally, when I come across an error that such and such is needed, but is not going to be installed, I bypass the runarounds and just get it directly:
https://pkgs.org/download/codeblocks-common

i tried to install Synaptic but it gives me the same error that codeblocks-common package needs to be reinstalled…

tried both commands and it gaves me same error that codeblocks-common package need to be reinstalled

sudo dpkg --configure -a

dpkg: dependency problems prevent codeblocks from being configured:
codeblocks depends on codeblocks-common (= 17.12-1); however:
The codeblocks-common package is not installed.

dpkg: Error processing codeblocks package (–configure):
problems with dependencies - left unconfigured
Trigger processing for desktop-file-utils (0.23-1ubuntu3.18.04.2 + zorin1) …
Trigger processing for bamfdaemon (0.5.3 + 18.04.20180207.2-0ubuntu1) …
Rebuilding /usr/share/applications/bamf-2.index …
Trigger processing for man-db (2.8.3-2ubuntu0.1) …
Trigger processing for gnome-menus (3.13.3-11ubuntu1.1) …
Trigger processing for hicolor-icon-theme (0.17-2) …
Trigger processing for mime-support (3.60ubuntu1) …
There were errors in processing:
codeblocks

It is holding broken packages.
It is true that the apt lock can get annoying when that happens.

In terminal, please run the following one after the other:

sudo apt autoclean

sudo apt autoremove

At this point, that may get rid of the broken pacakge. But if not, the terminal should tell you the full package name that is clogging everything up.
Use the package name to fill in the blank _____ below and run that command in terminal

sudo dpkg --remove --force-remove-reinstreq _____

Then,

sudo apt clean

From there, you should be able to install Synaptic normally without the broken package causing issues.

i tried sudo apt autoclean it works but then when tried apt autoremo it gives me the same error codeblocks-common

Can you please paste the full terminal output? From there maybe we can figure out which package is desperately trying to spare itself from death.

at first try i do sudo apt autoclean and it gaves me something that i don’t remember but i closed the terminal and if i try now it gaves me sudo apt autoclean [sudo] singhy05 password: Reading package list ... Done Dependency tree generation Read status information ... Done singhy05 @ HP: ~ $ sudo apt autoremove Reading package list ... Done Dependency tree generation Read status information ... Done E: The codeblocks-common package needs to be reinstalled, but an archive of it cannot be found.

What does

sudo apt remove --purge codeblocks-common

give you?

it gaves me sudo apt remove --purge codeblocks-common Reading package list ... Done Dependency tree generation Read status information ... Done E: The codeblocks-common package needs to be reinstalled, but an archive of it cannot be found.

i also tried an another guide that tolds me to go in some folders and open a file and remove codeblocks-common in every line where i found it but i can’t save the file bcs i can’t enter as root so i tried to install nautilus but nothing it gaves me the same error

You cannot install anything until dpkg clears out that clogged package sadly. Yes, I have been in this same situation before, too.
But- first, you do not need to install Nautilus. You can elevate to root with “pkexec”.
But let’s not go that complicated route just yet.
Really: this should have resolved your issue, but I do not remember now if you tried it or not- try this:

sudo apt --fix-broken install

If that is not working, it may be that simply removing what you initially tried to install would unjam dpkg

sudo apt remove --purge codeblocks

it won’t work it gaves in both case Reading package list ... Done Dependency tree generation Read status information ... Done E: The codeblocks-common package needs to be reinstalled, but an archive of it cannot be found.

What does

sudo apt --fix-broken install

yield?

same thing that i wrote first “codeblocks-common need to be reinstalled blah blah blah” that’s frustating that you can’t do nothing

sooo i don’t know if it can help you but i tried see status of codeblocks common and it gaves me this sudo dpkg -s codeblocks-common Package: codeblocks-common Status: install reinstreq half-installed Priority: optional Section: x11 Installed-Size: 7201 Maintainer: Jens Lody <jens@codeblocks.org> Architecture: all Source: codeblocks Version: 17.12-1 Config-Version: 17.12-1 Replaces: codeblocks (<< 17.12-1) Breaks: codeblocks (<< 17.12-1) Description: common files for Code::Blocks IDE Code::Blocks is the open-source, cross-platform Integrated Development Environment (IDE). It is based on a self-developed plugin framework allowing unlimited extensibility. Most of its functionality is already provided by plugins. . This package contains the architecture-independent files of Code::Blocks. Homepage: http://www.codeblocks.org

1 Like

That really should not be happening. OK… Well, here is where we are stuck for the moment…
In terminal run this and paste the output here. Let’s see if we can ID the jam up;

dpkg --get-selections | grep hold

sooo i tried ur command it doesn’t gave me any output so i tried onli dpkg --get-selections and it gaves me a very long list so i paste u only codeblocks section codeblocks install codeblocks-common install codeblocks-dev install codeblocks-headers install codeblocks-libwxcontrib0 install codeblocks-wxcontrib-dev install codeblocks-wxcontrib-headers install