Change 60 seconds Shutdown Restart Timeout

Where can I change the 60 seconds timeout when I click the shutdown or restart option?

1 Like

Copy this

gsettings set org.gnome.SessionManager logout-prompt false

, paste it on terminal and hit Enter if you want to remove it. These :point_down: are where I found it (I just searched for shutdown countdown :mag:).

Thank you Luca. I have searched the forum but I think I overlooked this option, because I was searching for a way to change the time. This option removes the dialogs completely and I think it's certainly better and faster than having to click another button.

1 Like

Yes, I understand, but in this case I don't know how to help :expressionless:, I think that you have to find the file that contain the shutdown countdown value, if I knew it I'd have told it but this goes over my knowledge. Surely would contain the number 60 (seconds) that you can change into whatever you want.


Just to check, I searched shutdown on Nautilus but the results list is quite long (but filtering the results type would be fine, just to exclude pictures and other irrelevant files for this case), I tried to open shutdown and systemd-shutdown (both TXT files) and despite they're respectively 996,6 kB and 55,5 kB large Zorin stuck on executing them.

Incredible, here it's explained how to cancel the shutdown operation but not how to change the delay :face_exhaling:.


Interesting, maybe there's a chance to achieve it.

I'd concentrate on 6, probably others can be ignored.


By the way, I'm always worried if I have to change such technical things, you can do serious damage or even make the system unusable.

True, I'd rather not mess with complex system settings. Removing the shutdown dialog seems a little radical, but it works. I'm not sure what the consequences are though. Maybe I'll reverse it. Just to be sure. Thanks for your effort!

1 Like