Compiz not working

i changed some animations from compiz setting manager but not effect take place, why?
how can i solve this

also i rebooted my pc many times
but still minimizing effect is not changing

Do you have all the plugins?

sudo apt-get install compiz-plugins-extra

no i think ...
going to install right now
but still it's not working
i installed what u said above

Are you using Zorin OS 15.3 Lite?

Or are you using Core /Ultimate? If you are using Zorin Core or Ultimate with Gnome Desktop, Compiz will not properly work as Gnome locks mutter down and gnome shell is not compatible with Compiz.
I used to be able to use Compiz on Zorin OS 12.4 by hitting alt+F2 and typing compiz --replace but that was a long time ago...

yes i m using zorin 15.3 educational version with gnome

Well, you are not without options.
You can install the Gnome_Flashback Desktop environment;
You can install XFCE4 Desktop or the Mate Desktop Environments. Any of these three will work with compiz.

yes i know
already i m using unity desktop
and it messed up too much with zorin ,
u can see -

I have regularly installed XFCE4, Mate, Cinnamon, Enlightenment and even more rarely installed KDE Desktop Environments. Of all of the above, only Mate has given me any trouble - only when I tried to remove it. And that was Minor.

I installed Unity once - and vowed to never do that again. I had no trouble removing it (And did so with enthusiasm); it was operating it that was the trouble.

...So... Compiz should work on Unity. But given your comments in the other thread and your comments here: I would surmise that your Unity D.E. installation is broken.
You have a couple of options; Remove Unity and try a different Desktop or try to repair Unity.


Open Software & Updates and on the first tab, Zorin Software, click the drop down menu for Download from: and select Main Server. Then close it.
In terminal please run:

sudo apt-get update --fix-missing

sudo apt install --reinstall zorin-os-desktop

sudo apt install --reinstall ubuntu-unity-desktop

sudo dpkg --configure -a


If you want to just remove Unity and try a different D.E. (Included terminal commands for Repair of Zorin OS Desktop, just in case);

sudo apt remove --purge ubuntu-unity-desktop

sudo apt-get update --fix-missing

sudo apt install --reinstall zorin-os-desktop

sudo dpkg --configure -a

Once complete, restart your computer and you can choose a different D.E. to install if you like.

sudo apt install xfce4


sudo apt install cinnamon-common

sudo apt install cinnamon-desktop-environment


sudo apt install ubuntu-mate-desktop

and so on.

Did u read

i want to remove unity but after this reply (on given link) i m afraid to do
so ow i m going to try fixing it ....

help me on how i can remove unity DE in this situation ?

I did read it but offered a second opinion...

1 Like

i reinstalled both DE but it didn't worked for me ?

what should i do ...
still unity DE functions are here in zorin DE

You mentioned wanting to remove Unity D.E. but that you were hesitant to do so. Have you removed Unity D.E.?

Noo, i didn't

Ok, well that would be why Unity functions are still there.

I am not The Linux Guru, but I have been here offering help throughout this thread. Be fearless; I'm not gonna let you toast your system.
Let's go ahead and remove Unity and if anything goes wrong, we'll be here to get it to go back to right.

sorry for this delay !!
seriously.... ?
ok i can ....
should i take a backup of files?
and i dual booted this zorin (for information)
should i remove unity now ?
abit scared
what will happen to my pc if u were offline for 2-3 days ....
so i want to confirm tht you're online
so i can proceed to removing unity
after your (@Aravisian ) reply i will start removing unity

i reinstalled zorin and uity as u told ..but after that i got a new DE "budgie ":confused:
its functions are not mixed but i didn't installed it

Can you post the terminal in/output? It will be a great help to crunch problems :wink:

What command you typed to get the the DE(s) and then its output.

no command....
i logged out ..
and there we can find a setting option to choose DE

You said you installed unity by the command which are shown earlier in this thread, but you said it installed Budgie. So it might be a good idea to look at the in/output of what happen.