Default audio

Good day folks
If you can help great, i am having an issue with the audio settings version 16. I have a USB audio adapter which works fine provided the settings are adjusted on each reboot. Please see the screen shots of working and not working.
Have a good Christmas in any event.
Default sound

@Buff Settings not retained over a boot is real frustrating. There may be some hints here:-


I am not saying any of those will work. I have learned that sound issues can be illogical and difficult to diagnose.

1 Like

Good day
Thanks for the attempt but in my case would not solve the issue

HDMI will grab the audio channel unless you blacklist it. See the guide I copied from a web page before it disappeared.

I had to do this to get my Sound Blaster Audigy Rx to work. :wink:

[The post would not let me use the one I posted in Blacklist Audio in error instead of posting here!]

1 Like

Link to tutorial:

Thanks swarfendor
Makes good sense tried a couple of times rebooting after no luck, I get four options only three show up in Terminal tried deleting first one still comes up with the four on reboot. It defaults on each reboot to the bold Italic option, the only choice which works Ok is that of :-
HDMI / DisplayPort2 -GK206 HDMI

Digital Output (S/PDIF) – USB Audio

Speakers – USB Audio Device

Digital Output (S/PDIF) – Built in Audio

I have the same issue with my audio; every reboot I have to reset the device back to my default output device as the system keeps changing it to another device [every time].

I did install pavucontrol -- to no avail

I also installed the Sound Input & Output Device Chooser - GNOME Shell Extensions but unfortunately all it seems to do is make it slightly faster to let me choose my default sound device after rebooting (it still needs to be reset ever reboot).

One more thing to try in attempt to get default audio to stick.
In terminal open alsamixer
Hit [F6] to see audio device chooser dropdown. (for some it may be [Fn]+[F6] to do that)
Select the device you want for default.
Save alsamixer settings using:

sudo alsactl store

That in theory should save your alsamixer settings changes over a reboot.

I guess the only other option would be to craft a startup script to force the audio device default on each startup. I have seen others do something similar when all else fails. I am not able to help you with that, as I do not have the skills.

Thanks zabba
I tried a few times it comes up with "Cannot open mixer device "
I guess it is not a mixer device.
Happy new year to you all

Do you have an internal audio card/device or an alternative USB audio device available?

EDIT: Have you tried booting Zorin without the USB sound card. Then plugged in the USB sound card after Zorin is up running?

Try my tip here:

Hi Zabado
Yes I do have an internal Audio card, the issue is that this will not work with Hackintosh hence the USB adapter - same machine is also used as a mac (Dual boot).
Worked Ok with Zorin 15.3
Thanks for the interest

Hi Swafendor
I must take some time to follow your suggestion, get back when I can make something of what you propose.

But that is when you boot Hackintosh mac.
Will that internal sound card work when you boot ZorinOS.

Good day Zabada
The issue with the is internal sound card has a driver issue with the Hackintosh (More or less impossible for me) to resolve this issue I used the USB sound device over the ii lama display speakers. This worked OK with 15.3 still is ok with 16 however I must adjust the audio option on each boot. The cables are completely concealed not easy to get at.

Happy New Year to you too.

I am sure some command line wizard on this forum must be able to help you craft a start-up script to save you typing sound setting every boot. @Aravisian ?

Adjust what settings in what application? Yes, a Bash script might work, added to start up.

@Buff Can you give full details of what setting/s you are needing to change after boot for sound to work?
I assume it may be blacklisting an adapter, as suggested by Swarf in posr #4, but it is no good us guessing.

1 Like

Good day Zabadab
Each time I boot the audio is zero the OS defaults to the following
If I then open "Settings" select sound I have four options as listed below:-

HDMI / DisplayPort2 -GK206 HDMI

Digital Output (S/PDIF) – USB Audio

Speakers – USB Audio Device

Digital Output (S/PDIF) – Built in Audio

Changing the selection to HDMI/ DisplayPort2-GK206 HDMI
This resolves the problem works perfect, the monitor with speakers I use is an iiyama prolite E2407HDS. I may have had this issue in the early days with 15.3, if I dis it resolved by its own accord.
Thank you for the response

So that needs to be the default on startup.

Lets see if someone comes along with a neat way of automating that startup setting for you.