Delete a FAT32 partion on the bootdrive of ZorinOS

I deleted 500 MB partition. I thought it was a leftover swap. It wasn't.
I deleted it with Windows 10 Disk Management.
I could not boot pass the ZorinOS logo.
I tried to fix it by making the unallocated partition into 500MB Fat32 with Windows 10 again but it won't work.
I tried recovery mode in Grub with timeshift which included the grubloader recovery as well. It did not help me either.

What else can I try?

You haven't deleted your EFI partition by any chance?
I think they are usually set about that size.

Are you able to post a screenshot of your partitions from Windows Disk Management or Gparted? That may help us understand what partitions you now have left.

That might be it. How do I restore it or rebuild it? With a flash drive?

Others may help once they can see what partitions you have and what is missing.

In the meantime, you could have a look at this thread:

1 Like

Yes, you deleted your EFI partition. Since you created a new partition, you may try using os-prober to identify the Operating Systems on the machine and add them to grub or try Boot Repair...

Which method do you want me to try first?


in recovery mode with root?


Boot Repair

How do I do this? Any guide?

I am rushing out the door, back in about an hour or so...

1 Like

I have never tried os-prober, but can say Boot Repair has got me out of trouble once.

1 Like

It is undoubtedly the boot partition.
Being FAT32 file system, that is the only Linux partition Windows can access. See the partition mapping of my Zorin installation below:

1 Like

Yeah. I have a bad habit of doing stupid stuffs. But this is how I learn.

Lesson here: DO NOT TOUCH the 500 MB FAT32 that shows up randomly in Windows 10.


For sure. I just saved my butt. I'm back in Zorin OS.


How did you end up fixing it. Boot Repair or what?

In general, it is better not to meddle with the files in other OS unless you setup a shared data partition.

Boot Repair through Zorin OS Live boot on the flash drive. I saw it reinstall grub and linux-header-generic.


Thanks for confiring that. That info may help someone else one day. Good to hear you are back zorining again :smiley:

After I fixed it with boot-repair with live boot, I boot into ZorinOS safely. I checked with

sapphire@sapphire-X570-UD:~$ lsblk
sda           8:0    0 223.6G  0 disk 
├─sda1        8:1    0     1K  0 part 
└─sda5        8:5    0 223.1G  0 part /

It looks wrong. Where is the EFI partition now?

Extra photos

Can you post a Gparted screenshot.

1 Like

Nevermind. Wrong disk.

This is it.

Your FAT32 EFI partition is on the first disk you show, not the second. But is only 100Mb.
You are dual-booting Windows, Yes?

Absolutely NOT. I know dual-boot is horrible when Windows 10 is on the same drive. That's why I put ZorinOS on its own SSD. It used to looks like @FrenchPress
's picture.