Dell XPS Plus (9320) No Network - No Sound

I have a brand new Dell XPS 13 Plus (9320) delivered with Windows 11 preinstalled.

I have had no end of problems trying to install Zorin Os 16.2. The aim was to install Zorin alongside Windows Dual boot, 800GB Zorin, The remaining (200GB) Windows.

Right from the off, when booting Zorin form the USB drive, there was no access to WiFi an no Sound (Only sound device reported "Dummy Output"). Also, Fractional scaling for the display was presented as an option but would only work at 100% and 200%.

Many items I read point to the configuration of the BIOS (excuse my ignorance on matters Windows) But these are the options that I am now currently using (and I have tried cold booting)

Boot Configurtion

  • Secure Boot: Off
  • Enable Microsoft EFICA: On
  • Secure Boot Mode: Audit Mode

Integrated Devices

  • Enable Camera: On
  • Enable Audio: On
  • Enable Microphone: On
  • Enable Internal Speaker: On


  • ATA/NVMe operation: AHCI/NVMe


  • WLAN: On
  • Bluetooth: On
  • Enable UEFI Network Stack: Enabled

Pre-Boot Behavior

  • Fastboot: Thorough
  • Extend BIOS POST Time: 5 seconds

At one point I used the Storage RAID option and that resulted in an unbootable system and I had to call DELL to get me out of trouble!

The BIOS configuration above now at leasts will boot Zorin but - no Wifi, No Sound, Only 100%and 200% display scaling.

Booting from Windows 11 there is no problem with Sound, WiFi or fractional scaling.

When booted from Zorin, If I connect my phone via USB and enable USB tethering on the mobile 'phone I can also access the internet.

I am at a loss!!!

Can anyone suggest how I may get WiFi and Sound and hopefully fractional scaling to work?

Dell Computer Spec:

Dell XPS 13 Plus (9320)
System Service Tags: 8DF1TV3
Windows 11 Home, English, Dutch, French, German, Italian 1 SR
Intel(R) Iris(R) Xe Graphics 1 SR
32GB, LPDDR5, 6000 MHz, integrated, dual channel 1 SR
1TB M.2 PCIe NVMe Solid State Drive 1 SR
13.4 OLED 3.5K (3456x2160) InfinityEdge Touch Anti-Reflective 400-Nit Display

You probably (possible) need a more up-to-date kernel is my guess as your computer is brand new. Possible a kernel 6.x.x
Lets see if it can see the devices:

sudo apt install inxi
inxi -A
inxi -N
1 Like


michael@Slappy:~$ inxi -A
Audio: Device-1: Intel driver: intel-ipu6
Device-2: Intel driver: snd_hda_intel
Sound Server: ALSA v: k5.15.0-75-generic
michael@Slappy:~$ inxi -N
Network: Device-1: Intel driver: N/A

Hm... not good
Lets dig a little deeper on the net card

sudo lshw -C network

regarding audio, try experiment with alsamixer

1 Like

Firstly, many thanks for taking an interest and offering help.

michael@Slappy:~$ sudo lshw -C network
  *-network UNCLAIMED       
       description: Network controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 14.3
       bus info: pci@0000:00:14.3
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix cap_list
       configuration: latency=0
       resources: iomemory:600-5ff memory:603e1e4000-603e1e7fff
       description: Ethernet interface
       physical id: 3
       bus info: usb@3:3
       logical name: usb0
       serial: 92:2b:ce:4e:38:cd
       capabilities: ethernet physical
       configuration: autonegotiation=off broadcast=yes driver=rndis_host driverversion=5.15.0-75-generic duplex=half firmware=RNDIS device ip= link=yes multicast=yes port=twisted pair

The above was collected whilst networking was enabled over USB (tethering)

Regarding audio:
alsamixer reports:

Card: HDA Intel PCH  
with the message: This sound device does not have any controls.

Edited to add I paired a Bluetooth speaker with Zorin Dell XPS Plus laptop successfully but it was still not listed as a sound device.

The drivers/firmware need to be updated. The easiest way to do that is install a newer version of the kernel.

Storm is right. You can find a tutorial in the tutorial and guides category of this forum.

Ensure you backup any data you don't want to lose (i know it's a new pc, but that is something you normally do during installation, import what's important to you) and your home folder.

Update the kernel by the guide and reboot.

If you search this forum for, how to upgrade kernel, it should be the first link. The guide specifically mentions zorin 16.2 kernel.

Thanks - I will try that now and report back.

Using this guide: How to upgrade Zorin 16.2 to a newer kernel

At the step:

> sudo add-apt-repository --remove "deb jammy main"

> sudo apt install libssl3

I get lots of errors:

Get:1 Index of /ubuntu jammy/main amd64 locales all 2.35-0ubuntu3 [4,249 kB]
Err:2 jammy/main amd64 libc6 amd64 2.35-0ubuntu3
Cannot initiate the connection to (2001:67c:1562::18). - connect (101: Network is unreachable) Cannot initiate the connection to (2001:67c:1562::15). - connect (101: Network is unreachable) Could not connect to (, connection timed out Could not connect to (, connection timed out [IP: 80]

My network (tethered through USB to phone is working fine (posting this response through that connection).

Any advice?

I recommend using the TuxInvader LTS Mainline, instead.
The steps are:

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.02

That should install the 6.2 kernel. Reboot and test.
Check kernel after reboot with uname -r

1 Like

Many thanks. I found this solves the WiFi issue and now many more screen resolutions are listed (though fractional scaling does not work - that's no big issue for me). However, there is still no sound.

The only Sound Output Device listed is "Dummy Output"

Any suggestions?

What is the terminal output of

sudo lshw -C multimedia

michael@Slappy:~$ sudo lshw -C multimedia
[sudo] password for michael:       
  *-multimedia:0 UNCLAIMED  
       description: Multimedia controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 5
       bus info: pci@0000:00:05.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress pm cap_list
       configuration: latency=0
       resources: iomemory:600-5ff memory:603c000000-603cffffff
       description: Multimedia audio controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 1f.3
       bus info: pci@0000:00:1f.3
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list
       configuration: driver=sof-audio-pci-intel-tgl latency=64
       resources: iomemory:600-5ff iomemory:600-5ff irq:16 memory:603e1e0000-603e1e3fff memory:603e000000-603e0fffff


sudo apt full-upgrade

Reboot and test. If still no sound, in terminal run

echo "options snd-hda-intel probe_mask=1" | sudo tee -a /etc/modprobe.d/xps.conf

Source: HdaIntelSoundHowto - Community Help Wiki
Reboot - test...
If still now good, try:

echo "options snd-hda-intel probe_mask=254" | sudo tee -a /etc/modprobe.d/xps.conf
1 Like

Did a search on "dummy output" here on the forum and found this re Dell which may (or may not) help.

The issue of no sound with "dummy output" is a regular occurance on the forum, so a search is a good start point.

Also as previously mentioned, from terminal run alsamixer hit F6 to see detected sound cards. Post a screenshot.

1 Like

On reboot, I get to a completely black screen with a white text prompt to login in
I can log in under my username and password and I get a shell prompt.
I seem to have entirely lost the window manager.

I am now in a complete mess!

If I choose Zorin Advanced Options during the boot sequence it looks like I have a choice of several Zorin versions. None seem to complete booting into a window manager. I never get past a black screen, white text, login prompt.


With an installation Windows and Zorin
You first have to disable the Security Boot
In your BIOS Menu
Then start the USB stick

Security Boot was disabled (see original post) from the beginning.

Have you also stored this in the BIOS
If not, it is switched on again

Yes, just checked, Secure Boot remains disabled in BIOS

and Lecasy support in your BIOS
Has it been enabled?
Security Boot -Disable

lecasy support-enable