/dev/sda2 clean files blocks stuck

hi team ,
after flashing clean install , getting this error , and when i dual boot with windows ,, everything work fine , but when i remove windows , or flash clean i get this issue on restart or on first boot

thank in advance

Hi bombayfunk, welcome to the forum! Do you have nvidia graphics drivers installed by any chance?


See reply with 97 votes on second link above.

no nvida drivers installed , reflash clean zorin os , facing same problem , tried every method , when i dual boot with windows , i face no issue , but when i flash only zorin or other linus os , same issue on startup

  • Is it stuck after printing only /dev/sda2 clean files block or this line keeps repeating like a loop?

  • try press n hold ctrl+alt+del , if it takes to you the grub menu then select Zorin and check if you can boot into your installation or not.

I had a similar issue like this in the past. In my case the error line keeps printing and it was a key pressing that was causing the error.

Here is the thread:


thanks @littlekun , ctrl+alt+del method worked , any solution to skip these steps , and boot normally

In my case it was a keypressing, which starts printing a sequence like ^[[5~ during the initial boot process and then starts printing /dev/sda5: clean files block. I solved it by fixing the that sticky-key. If the same case is happening with you then you need to find that key in keyboard and fix it.

But if your problem is stuck after printing /dev/sda2 clean files block one line only then follow the guide that swarfendor437 shared with you previously.

You didn't answer to this:

If you can share how exactly that error appears, means staring from clicking the power button that turn on the device to error message what exact things happening, then It will be easier for us to troubleshoot the issue.

1 Like

please find the attach images

The first 2 errors can be solved in BIOS. While booting your device enter to bios using any of one of these key Del, F2 or F10 . It might be different keys in your case so here is a cheatsheet for BIOS keys:

When you got into your BIOS

  • First disable the Secure boot. It will fix the integrity: Problem loading x.509 certificate -65. (Some vendors might have installed extra secure boot certificates, if you see any option related to that, then clear them also.)

  • Now look for a option related to SGX in your BIOS (generally it's under the Security tab), enable it. It will fix your SGX disabled by BIOS.

  • After changing these two options, Save the Changes and exit the BIOS. Now restart or shutdown and then turn it on again and check if you are getting any errors or not.

  • About the sequence ^[[23~, I'm guessing it is caused by the previous 2 errors. I hope after changing above two options will fix it also. However if you still get this sequence now during the boot then my first suspicious will go to your F11 key which might be sticking down (it might be a different key in your case). The best solution for this, clean your keyboard.

  • Now I'm hoping after doing this, you will not end up in /dev/sda2 clean files block error anymore during the boot process.



i am using , mi laptop 14 horizon edition , i disabled the secure boot option , but i dont see any SGX option in my bios ,

also when i used to clean boot linux , i was not facing any issue like that , but after i dual boot win/linux and tried to delete windos with ubuntu delete tool , since then m getting this issue ,

SGX is Intel Secure Guard Extension. It is only available with (U)EFI booting systems, not Legacy MBR.
It may show in BIOS as Software Guard Extensions.

my system in uefi only ,and also secure boot is disabled

This looks like a simplified BIOS Settings screen. Some Manufacturers only provide a simplified version and a user must manually select the Advanced BIOS Settings. How to do so is manufacturer dependent and some manufacturers do not offer it, locking the user out.
What is your Make and Model of computer?

mi laptop 14 horizon edition

now m able to enable SGX via GitHub - intel/sgx-software-enable ,

now only issue with the sd2 clean file

Are you able to boot up normally after seeing that screen?
Do you use Nvidia Graphics card?

That message itself is harmless and shows that all files are clean without errors.
It is likely unrelated if you are having another issue.

nope i cant boot normally , i have to press control + alt + delete to get into boot menu and select zorin .

yes i hv nvidia graphic card and also removed the drivers for that , but facing same issue

Did you reinstall them after removing them?

sudo ubuntu-drivers install

Which Nvidia card do you have?

  1. not reinstalled ,
    2 . NVIDIA® GeForce® MX350

  2. installing now

1 Like

after reinstalling drivers , same issue

Have you tried adding the nomodeset parameter?

done trying this

solution to this to start normally

sudo nano /etc/default/grub

Arrow key down to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and remove quiet splash parameter within the quotation tags. For example
it would look like:

sudo update-grub

this will show multiple line of code , but boot normally

thanks everyone my problem is solved now

1 Like