Fictitious output

Hello:
Some time ago I had a problem concerning the sound seen.
The recommended solution was to install pavucontrol. Once installed I disabled the sound outputs leaving only one option: usb analog output. Everything seemed to work very well until now, since, after watching a video on youtube, the sound was muted and the famous dummy output appeared.
I have reviewed a lot of information about it, but, apart from the fact that the solutions presented are somewhat complicated for a novice like me, their results are quite uncertain.
Apparently they are driver problems, since, this all started after upgrading the computer, installing a new motherboard.
From what I have read, this problem is present in Ubuntu and distributions based on it, such as Linux Mint and Zorin Os.
Hardware:
CPU: Amd Ryzen 5 1600 (12) 3.200GH
GPU: NVIDIA Geforce GT 730
Memory: 15972Mib
Motherboard: Asus Prime B450M-AII
Thank you very much

For clarity:

Are you saying that sound was working fine, until you replaced the motherboard?

Hello:
Right. On my old motherboard, with Zorin Os 15, I had no problem in this regard.
When I changed the old motherboard for the current one, Zorin Os 15 gave me the same problem. I thought it would be solved with the new Zorin 16 kernel, but it has not happened.
In general the loss of sound occurs when I am watching Youtube videos.
Installing pavucontrol seemed to work for a while, as I blocked all output devices, leaving analog usb as the only option.
I checked alsamixer but everything looks fine.
I have checked several web pages that refer to this problem, but the solutions they propose, apart from being complicated for a novice like me, their results are inconclusive.
In general this problem is present in Ubuntu and distributions based on it, such as Zorin Os.
It is a mystery to me why the analog usb is disabled and replaced by the dummy output.
Regards

You installed Zorin OS 16 after installing the Motherboard?

Have you tried removing pulseaudio and pavucontrol completely and relying only on Alsamixer?

Hello:
Yes, I installed Zorin 16 after installing the new motherboard.
No, I have installed Alsamixer , Pulseaudio and Pavucontrol.
Alsamixer I find a bit complicated to handle, unlike Pulseaudio and Pavucontrol.
Regards

True... But Pulseuadio runs complicated, even if Pavucontrol makes the UI easy. What you set in it and what it does may not always be similar...

@alexandros For what it is worth, Alsamixer from terminal (not the optional Alsamixer GUI install from Software) is my favorite tool for diagnosing and fixing sound problems on Zorin.

Question is, are you able to run Alsamixer and post a screenshot of the display here?

Hello:
As I mentioned before, I am a user at a very basic level.
This is what I get in relation to Alsamixer.

I have just done a serach for that motherboard to see what audo device it has.
https://www.asus.com/uk/Motherboards-Components/Motherboards/PRIME/PRIME-B450M-A-II/techspec/
i.e.
Realtek ALC887/897 7.1-Channel High Definition Audio CODEC

Your Nvidia GPU is listed as sound card, not the Realtek device.
What does Asamixer display for sound cards when you hit [F6] key?

In addition, can you post results of:

aplay -l

(Note "l" is lowercase L not numeric 1)

Hello:
First of all I thank you for your patience and willingness.
This shows alsamixer when you press F6:

This is what comes out when you press aplay -l:

Thank you very much.

1 Like

Again run Alsamixer from terminal.
Again hit [F6] then select "2 HD - Audio Generic" from the drop-down list of sound cards.
What does that then give you on the Alsamixer screen?

Hello:
This is what it gives in "2 HD - Audio Generic":

Thank you very much

Good. That looks more normal to me.
In Alsamixer you can mute/unmute channels by scrolling accross then hit "M".
Does your sound now work as you wish, or do you still have a problem?
If this is fixed, please mark the post that helped you as :ballot_box_with_check: Solution from the ... post Replay toolbar.

Hello:
Thank you very much for the help.
Regards

Hello:
I have a question. Through Alsamixer I can mute HdNvidia, which, apparently, is the card that is giving sound problems. However, every time I turn on the computer I have to perform this action, again.
Is there any way to save these changes permanently?
Thank you very much.
Regards

What do you mean by that? Are you having to go in and select "HD - Audio Generic" as defaut sound card?
I think you can change default sound card under Zorin/Settings/Sound
but am not on ZorinOS to try that myself at the moment. Maybe someone else on here can confirm that? @Aravisian @FrenchPress


Are you referring to Output device?

After that, lets see what happens when you save that Alsamixer setting using:

sudo alsactl store

Does that store that choice of sound card after a re-boot?

@Aravisian Nah. I thought Settings/Sound had a way of selecting default sound card. Seems not.

Hello:
I have to report that the proposed solution was not effective. I still have the same problem, when trying to play videos on youtube the sound disappears. Sometimes after watching a few videos, sometimes when trying to play the first one.
When I look at the sound section in settings, only the dummy sound output is visible.
I tried to mute this output using alsamixer, (I had previously tried with pavucontrol), but to no avail.
I am convinced that the problem derives from the new motherboard, since the old one did not have this problem.
In situations like this, it makes me want, for a brief moment, to go back to Windows.
Anyway, I want to reiterate my thanks for taking care of my problem.
Regards.

Re dummy sound. There is a thread on here about that, which may give you some leads, but do not know if a "fix" was found. Dell Precision 5750 - No sound ( Dummy Output )

Dummy Sound is (or was) a common complaint at one time. I think there are many instances on different "Ubuntu" forums that discuss it. Maybe websearch "Dummy sound Ubuntu"

1 Like