Firefox doesn't display with links from Thunderbird

Greetings - I was able to successfully install Zorin 17.1 the second time I tried but Firefox no longer exhibits anything when I click on a link from Thunderbird Email. The window comes up but it doesn't display anything.

in the meantime, I've set Chromium as my default browser but I can't figure out what switch to throw in Firefox Settings to fix the linkage problem from Thunderbird. Opening Firefox on it's own works fine except one of my 2 step verification pages also fails to appear. Any ideas?

Hi, and welcome.

I don't have experience with Thunderbird but my guess is that Firefox cannot read the link properly due to it being installed as a Flatpak. I would recommend uninstalling it and replacing it with the native version by setting up the repository from Mozilla.

For reference, a Flatpak is a containerized package format used in Linux. It doesn't have permissions to read filesystem by default and tends to cause this type of incompatibilities with other programs.

To add something to @zenzen 's Comment:

Dod You use Thunderbird as Flatpak? And Firefox as Flatpak, too? I ask for the last one because Zorin has made a Change for Zorin 17.1. They changed to Firefox .deb in the ISO:

1 Like

Whatever you get from Zorin 17.1 Core is what I got. Could someone walk me through the Terminal commands to do what needs to be done? (I'm pretty green but apparently, delete Firefox and install it again with a different command?) Thanks in advance.

Could You please look at the ISO File and control if there is at the End of the Filename ''-r2''?

How do I do that?

It's probably best to verify it manually as this is a very recent change, so it's possible that you still have the Flatpak version. You can run the following command on the terminal (search for "Terminal" in the applications menu):

flatpak list

This outputs a list of all programs that you have currently installed using this package format. If you see Firefox (and/or Thunderbird, I didn't consider this could also be the issue as well) listed in there, it's a Flatpak.
In case both Thunderbird and Firefox are listed here, try to remove Firefox first and install it using the method described below. If that still doesn't work properly, do the same with Thunderbird (just to avoid unnecessary work).

To uninstall a Flatpak you can then run:

flatpak uninstall org.mozilla.firefox

Note that the name of the package needs to be in this long form, so make sure you type it exactly as it appears in the list from the previous command.

You can also uninstall Flatpak packages from the Software Store, simply search for this program and you should see already the uninstall option. The only "problem" with this is that it's not always obvious which format that program is installed as, so using the terminal is more effective (albeit more typing to do).

To install Firefox, is a matter of following the instructions from Mozilla. Type the following commands in order, one at the time:

sudo install -d -m 0755 /etc/apt/keyrings
wget -q https://packages.mozilla.org/apt/repo-signing-key.gpg -O- | sudo tee /etc/apt/keyrings/packages.mozilla.org.asc > /dev/null
gpg -n -q --import --import-options import-show /etc/apt/keyrings/packages.mozilla.org.asc | awk '/pub/{getline; gsub(/^ +| +$/,""); if($0 == "35BAA0B33E9EB396F59CA838C0BA5CE6DC6315A3") print "\nThe key fingerprint matches ("$0").\n"; else print "\nVerification failed: the fingerprint ("$0") does not match the expected one.\n"}'
echo "deb [signed-by=/etc/apt/keyrings/packages.mozilla.org.asc] https://packages.mozilla.org/apt mozilla main" | sudo tee -a /etc/apt/sources.list.d/mozilla.list > /dev/null
echo '
Package: *
Pin: origin packages.mozilla.org
Pin-Priority: 1000
' | sudo tee /etc/apt/preferences.d/mozilla 
sudo apt-get update && sudo apt-get install firefox

I know, it looks daunting, but all you have to do is copy and paste these. Notice there's a tiny little button when you hover over these code snippets that allows you to copy them with one click.

I don't have the commands for Thunderbird but give this a try and if it doesn't work we can work on that afterwards.

So when I typed ”flatpak list” in Terminal, I get something akin to oriental characてrs

That sounds bad :thinking: Can you take a screenshot of that?

OK. For some reason, Japanese was the top input language in Settings > Keyboard. I deleted that so English is the only language in the box now. So let me read through your previous post and in the meantime:

Before I delete Firefox, I'm going to lose all my bookmarks aren't I?

Probably :smiley: This would be a good time to make a backup of everything important. You can export them with Ctrl+Shift+O -> Import And Backup -> Export Bookmarks To HTML.

In Firefox you can Backup your bookmarks using Ctrl+Shift+o and look at top for "Import and Backup". I am assuming that works on the Flatpak version, but I am using apt version so cannot test.
EDIT: zenzen won that race to post. :grinning:

Before You delete the Flatpak Version You can install the .deb Version and then You can migrate the Data from the Flatpak Version. This Process is explained at the Link that @zenzen has posted:

There You scroll to the Point ''Data migration''.

OK Team, I think we got it. After following zenzen's instruction to the letter, I tried a few links from Thunderbird Email and they open Firefox and display. Still having trouble getting the two-step verification page to come up but my financial institution put a ticket in for it and said they were having trouble with Firefox recently. Also, all my bookmarks transferred over to the new Firefox so I think we're done here. Thanks everybody.

2 Likes