Firewall GUI missing from menu

With Z15 the firewall GUI was in Zorin menu->Settings->Privacy->Firewall Configuration.

I cannot find the GUI by searching or in the privacy section of the settings for Z16.

I can only find it in the software centre.

If you switch layout it will appear (gnome menu).

Otherwise, please check that GUFW is installed (not just UFW):

sudo apt install gufw

GUFW is installed but not showing in the menus.

1 Like

Shouldn't it be there whatever the layout?

If you open the app menu and type in gufw, does it show as "Firewall configuration?"

You may also navigate to /usr/share/applications and look to see if there is a .desktop file for it. (I think it is called firewall configuration there, too)... Why Canonical is insistent on changing package names lately... -sigh-

yup, but I found it in Gnome menu layouts. I guess it's a bug.

1 Like

Nope.

1 Like

That's what I was hoping and for this thread to be seen and a fix provided.

1 Like

try

ll gufw.destkop

ll *gwfu*
ls: cannot access '*gwfu*': No such file or directory

try

ll gufw.destkop

&^ .desktop

1 Like

Should have read what I typed, sorry.

ll *gufw*
-rw-r--r-- 1 root root 4927 May 3 13:48 gufw.desktop

1 Like
3 Likes

If u really want it to be in your menu I think you can use an application installed by default called 'Main Menu'

You can just Tick 'Firewall Configuration' in the System Settings tab

If you don't have or removed it by accident 'Firewall Configuration' you can add it
Screenshot from 2021-09-01 12-57-14

Name: Firewall Configuration
Command: gufw
Comment: An easy way to configure your firewall
Icon: /usr/share/icons/#ur-icon-theme/#choose-a-sutable-icon-for-it

Copy it into the window to add it
Im using the default Zorin Icon BTW
firewall-config
Icon found at /usr/share/icons/Zorin/48x48@2x/apps

Hope this helps :smile:

3 Likes