Games not working in Zorin

Hello all.
Zorin is good but I never understand the problems with packages.
After installation fresh installation and trying start games in Steam.
They are not working now what working before.
This is very sad what I must sayed I must back to operating system "Billy".
Zorin is good operating system but I cannot agree everything working perfect.
We taken choose in our life. I heard last time as linux is better for gaming.
Well not for me.
If I would like only some simple operating system then I also could using a raspberry pi with touchscreen.
If I cannot playing in games in Zorin then i can using live usb or virtual machine.

Did you forget to enable steam play, and force a proton version?

Right click the game you want to play, go to properties. Go to compatibility. Put a check in force proton version. Pick the latest version first. Try to launch.

If it fails to launch, the next version lower, and so on, and so on, until the game launches with one of them.

To be full respectfully. I was going after new refresh installation the same method topics from forum what we wrote before and working before.
I don't know maybe because kernel is diffrent what was before.
For me everything working with Kernel 34 but you sayed developers don't have any archives. That means if I have ISO from kernel 34 will automatic update to 37 kernel. The battle with installation and configuration drivers we do that like a team on this forum.

Maybe because I go with minimal installation that why not installed some things what need to be installed. I do that because I am not using all this stuff in Zorin when is full installation. Besides linux is a operating system when something missing we can use a terminal and installing something what is missing.

1 Like

I can always sometimes check if something change in distribution Zorin what I bought. I don't throw my ssd hard disk and don't format operating system.
Well this game in proton have a sign gold.

I don't have idea why this isn't don't worked.

I don't know either Bourne, I feel bad I don't have a solution for you. So sending you a digital hug. :hugs:

1 Like

I looked at the Steam page for Warframe to see if it has DRM attached, and it does not. But I did discover that it requires a 3rd party account, could this be why?
Screenshot from 2021-09-30 04-00-41

1 Like

@StarTreker I bet some people from you playing some games. Then maybe I missing something but what it could be if before working and now not working. I feeling like someone hit a knife to back my shoulders.
Apple have also some many types a computers what some "names" system can working only on this operating systems. Maybe when Zorin change something then broken old machines to support new generation a computers? I don't have any idea with this.

1 Like

Third Party it some Steam or Epic because this game you can installe on hard disk also without them from webside directly on hard disk.

I have an idea. Instead of launching Steam by the APP icon, launch Steam in terminal instead. The idea is to then launch the game, and when there are issues, terminal should show the errors.

Also, not sure which version of Steam you are running. There is the normal Steam version, then there is the FLATPACK version. And on my POP OS, the FLATPACK version is working for me.

Alright, load in terminal, lets see what the errors are once you launch the game. I sincerely hope we can figure this out. I want nothing more then to see you happy.

1 Like

Steam exist a game not start. Yes this is flatpack also.

after click start nothing happen. I reinstalled game today for fresh installation and the same. Proton is inside a steam then what for me is weird.

  • Warframe does not need WINEDLLOVERRIDES="xaudio2_7=n,b" — FAudio replaces xaudio2. Using this override WILL lead to game crashes
  • Warframe is problematic with VSync. Turn it off or on in game, do not set to Auto
  • Warframe needs a set a frame limit in game. Unlimited framerate can cause slowdowns
  • Warframe on Nvidia: you may need to disable GPU Particles in game otherwise the game can freeze randomly. On AMD they work fine
  • Injustice 2 and MK11 are missing cutscene audio
    Game Fixes #1: Warframe on Linux - Drauger OS
    Something talking on Zorin it works. :muscle:
    Still I don't understand this is from july and ZORIN 16 PRO was next month and everything working. Sorry I give up.

I tried some old windows games (such as Red Alert 1 & 2, Stronghold Crussader Extreme, Zoo Tycoon 2, Startcraft brood war) through Wine but it didn't work. previously in Zorin 15 worked successfully.

1 Like

Warframe is game from 2013 nothing special.
The point is if something working before and now not working then problem doesn't exist from a my computer.

Bourne, when you looked up the game on PROTON earlier and you said it had a GOLD rating? Did you by chance see which PROTON version was recommended on that site for that game? If you see a recommended version, I'd choose that and see if the game will launch.

Also, you have game installed on an external drive right? If so, make sure you have set permissions and ownership of that drive, otherwise the game will never launch too

1 Like

So Proton before working on experimental. My external hard disk is USB-C. Everything it doesn't sense what you writing because I taken installation the same way what working before.
For me ZorinGroup killing many users what I can sayed my graphic card radeon r9 390 from 2015 when I bought is the same graphic card xfx 580 the same parameters and this graphic card was selling in 2020. Everything working out from the box with kernel 34. Next updates I wrote about that it was for my PC unstable. the correct kernel 5.11.0-34 but next 5.13.0-xx not working properly. The many people using this graphic card if selling from 2015 to 2020 all time.
Zorin 16 Pro working good out from the box with this kernel 5.11.0-34
I don't want take this discussion something like a battle to be respectfull for users who using Zorin 16 Pro.
Maybe the problem not exist in Zorin linux operating system.
I can wait next month and check if will be working in future.
Maybe because with installation i going minimal not full installation.

1 Like

This may seem a naive question on my part, but rolling back to the -34 kernel doesn't work?

1 Like

It is possible? My fresh installation get kernel 5.11.0-27 after update go to and a couple days before to 5.11.037 I have topic here Fresh Installation Zorin 16 Pro
I cannot get menu and recovery because I go with full installation new what we speaking before about partitioning manual and automatic when my hard disk get a low space. Besides someone sayed I cannot install image iso with kernel 5.11.0-34 because not exist if I will installing some updates the kernel automatic will be updated to newest.

1 Like

Yes, you can install the kernel directly if it is not installed, then select it from the Recovery Menu.
If it works, then uninstall the non-working kernels.

1 Like

I don't have this after fresh installation when i can choose which version I want start. When created fresh installation i think i don't have many choice.

1 Like