Zorin Forum

Gnome Network Display shows error when I'm trying connect to TV

Input all:

sudo apt install xserver-xorg-input-all

I think. Going off of memory, here.

I'm thinking in gnome 41 these all issues will be fixed

There is no evidence to support such a belief.

Users said that about Gnome 3.30 and Gnome 3.38...

Wayland is not Ready for desktop use. Wayland sounds good in principle, but has spent over Ten years in development and has made little to no progress, yet.

1 Like

Thats what you think lol.

I hate to break it to ya, but Gnome since version 40 has broke more things that you can count, including theming. Gnome 41 is more then likely going to be even worse.

If there is one thing you can count on, is Gnome is gonna break it. If you want more freedom, its XFCE. I am doing OK on Gnome 3.38, but thats only because its not completely broken, and I can facilitate what features removed, by extensions.

But in Gnome 40, no more extensions, and no more theming for you, Gnome 41 will be more of the same. Say goodbye to the thought of Gnome fixing things, never gonna happen.

I have changed my Zorin Wayland to Zorin in lock screen. But the issue is in gnome network display

I understand, but please look at the error report in your terminal above.
The system had to fall back to X-11 (out of Wayland) just to prevent a crash.

Windowing System : X11

Yes, I am aware of that since:

Now that you are in X11, Please use the .deb package to install Network Displays, Not Flatpak.
Flatpack runs sandboxed:

Once done, please test if you are able to connect.

Where I can get, Please use the .deb package to install Network Displays

I apologize... Apparently there is not a .deb package for it... I just looked:
https://pkgs.org/download/gnome-network-displays

Very well...

We can do it the old fashioned way:
Install necessary packages and dependencies:

sudo apt install ubuntu-restricted-extras python3-pip gettext appstream-util cmake libgtk-3-dev libnm-dev libpulse-dev nasm git gstreamer1.0-plugins-bad libgstreamer-plugins-base1.0-dev libgstrtspserver-1.0-dev

sudo pip3 install meson ninja

Make a new folder to hold your download and install:

mkdir ~/src && cd $HOME/src

git clone https://github.com/cisco/openh264 && cd openh264

make

sudo make install

cd ..

git clone https://github.com/benzea/gnome-network-displays && cd gnome-network-displays

meson build

cd build

ninja

sudo meson install

Assign permissions:

pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY NETWORK_DISPLAYS_H264_ENC=openh264enc /usr/local/bin/gnome-network-displays &
1 Like

Same error bro

In that case, we have tried all I can think of Zorin OS side. I can only suggest you make a bug report with the Developer:

1 Like

Is there any alternative app for this bro

I do not know enough about alternatives to make a sound recommendation. You might do a net search and read the reviews on each application.

Bro I have searched in Internet but there are no proper results. :joy: No solution for this

Perhaps @StarTreker on here can help. The Treker has connected TV to Zorin OS successfully in the past.

Thank you, bro, excellent support from your side I'm happy about that.

1 Like
1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Marked Solution. 377

1 Like