GPU not registering

i have the correct drivers installed but my gpu still wont show up and i can't use it. Any help with this would be appreciated especially since i clicked the proper installation of OS

i tried logging in without secureboot and was met with this screen

What are the specs of your machine? Preferably the GPU of course.

ryzen 7 4800h gtx 1660ti

Do you have Secure Boot turned off? If not, try that first.
Some further suggestions here: GeForce GTX 1660 Ti not working in Ubuntu 20.04 - #5 by miguelaoxxx - Linux - NVIDIA Developer Forums

i turned it off and i couldnt even boot in just satic

maybe i need to uninstall the gpu software?

i mean driver

You could try install the latest driver. Do you have screen when the nvidia driver is not installed?

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update && sudo apt upgrade

You should now see driver v495 in "Additional Driver" application.

the driver is installed but the graphic card wont show in the info page cuz i am logged in with security boot i think

So you installed Zorin OS while the secure boot was enable? Have you tried install Zorin OS with Secureboot disabled (which is recommended).

actually i installed zorin without safeboot however when it updated again and then rebooted it just showed static unless i used safeboot

Okay, this may do to a newer kernel if I understand correct it worked before updating the system. Can you please try boot in a previous kernel (5.11.xx).
See how: [HOW TO] set an older kernel to default boot

so reinstall zorin from scratch?

Not at current time, the older kernel should still be there on your system, you just need to boot into it.

i am sorry but i cant seem to understand how to set the older kernel as default

@Aravisian can you explain it better than I do? (Maybe language barrier on my part).

@vitality just wait 'til Aravisian comes online.


Looks correctly set.