Help to get back to desktop environment

Hi there :slight_smile:

I just installed the 17.1 Pro version of Zorin OS some days ago and would be thankful for some support with something.

After I experienced some brower issues I wanted to try some different desktop environments and installed also the 16 Lite version to see if xfce would fit better.

When I could choose the desktops after restart I wasn't sure which description belonged to which desktop and I then decided to remove the 16 Lite installation.

After restart I could not get in a desktop environment. Login shows now a login possibility through terminal and then a welcome message.

I am just learning all this... And there might have been a mistake somewhere...

I would be happy to get back to a graphic environment, could someone maybe help with that?

Thank you so much!

Gday @Julie , Welcome to the community.

As you have purchased the pro Edition, you are able to download & use Zorin OS Lite,

The easiest way is to install Zorin OS 17.1 core,
Then i would run Zorin OS 17 Lite "Alongside the 1st OS.

Another good idea if your just trying the DE's etc.
Install a VM (virtual machine, I recommend "Boxes") & load other OS's into them.

Please remember to backup any data before installing again.

Hope this helps.

2 Likes

Thank you for your message Ocka!

Yes, I currently thought about to better work with a virtual machine for such things... And think a complete new installation would be needed to clear things.

That was a bit the reason for my post. I would be happy to save some documents and helpful links before that, I documented what I installed and how and some commands...

But I can not log in to a desktop environment like I described. It boots everytime in a terminal environment. Is there a command to get to a desktop again?

I think I deleted the 16 lite version. But the 17.1 pro should be still installed. After deleting the other desktop it just would not load and shows me a terminal environment. Is there a solution for this?

Have you tried grub repair (Boot repair) from the installation USB?

2 Likes

No, I just tried to install a desktop again. This worked but I could not load a graphic environment.

Could you tell me how the boot repair would work?

https://help.ubuntu.com/community/Boot-Repair
Backup or copy off your personal files first.
When I have had cause to use Boot Repair myself, I just run it with default settings.

I booted from the bootable usb stick I made for the installation of zorin 17.1 pro. And then I choosed Try Zorin.

I found this help instructions when looking for boot repair:

Repair the Boot Loader

  1. Boot from the Zorin OS USB Install Drive on your computer.
  2. Select the option to “Try Zorin OS”.
  3. When you reach the desktop, open the Zorin Menu → System Tools → Boot Repair.
  4. After Boot Repair completes a system scan, click the “Recommended repair” button to start the repair.
  5. Restart your computer. )

I could find the boot repair and it shows this

=> No boot loader is installed in the MBR of /dev/nvme0n1.
Suggested repair: ______________________________________________________________

The default repair of the Boot-Repair utility would reinstall the grub-efi of
nvme0n1p2,
using the following options: nvme0n1p1/boot/efi
Additional repair would be performed: unhide-bootmenu-10s use-standard-efi-file

Final advice in case of suggested repair: ______________________________________

Please do not forget to make your UEFI firmware boot on the Zorin OS 17.1 (17) entry (nvme0n1p1/efi/****/grub

I would like to save my files first before this.

Could you tell me how to find my personal files? I am not sure how to access my files. I hope they still are there.

I think I would need some advice before. Not really knowing what I am doing there, lol. :face_with_peeking_eye: Thank you! :blush:

I could find my files and access sdd. Thank so much for all support!!

I am thinking about a new installation to clear all this up. Maybe I will try the boot repair suggestions before to see what will happen.

Could someone help me which command would I need to reinstall the grub/efi of nvme0n1p2 and what else is suggested for Boot/repair.

(The default repair of the Boot-Repair utility would reinstall the grub-efi of
nvme0n1p2,
using the following options: nvme0n1p1/boot/efi
Additional repair would be performed: unhide-bootmenu-10s use-standard-efi-file)

I tried a lot of install reinstall commands with the desktop environments without really knowing what would happen. Would like to do this repair right and learn how to do this.

1 Like

Reading back your original post. Did you replace Pro with Lite then replace Lite again with Pro on the same drive and partitions?
or did you have both Pro and Lite installed alongside each other (as mentioned by Ocka)?

If you installed Lite over Pro as a single OS, then that should have formatted root and provided a clean start for Lite. Same if you then installed Pro over Lite again.

We can't see your setup, a Gparted screenshot of your drives and partitions setup may help our understanding, as I for one am a bit confused.

I have to say that I am not sure. I did not create different partitions, so I assume this was on the same drive and partition. There is only one drive.

I copied terminal commands for this from some instructions I found for changing desktop. I just wanted to check xfce and also mate, I was a bit upset because of not being able to drag & drop my Firefox bookmarks as I was used from Windows 7. I read later that it might be because of Nautilus. And I just decided to stay with the 17 Version and see how I could make things work. I think the appearance of Zorin is closest to what I wish from a new system and I will try to find solutions...

I think the Desktop installations were not so much the problem, it happened when installing the whole 16 version. I am not sure what happened. Might this have created a second partition? I understand that my description might be a bit unclear as I could not understand everything I did.

I was not able to repair the boot loader and had some more messages then like this.

An error occurred during the repair.
Error: NVram is locked (Zorin not found in efibootmgr).

I read it could be because of secure boot. I remember to have deactivated secure boot to be able to boot from usb for Zorin Os installation. And found no other solution then. I decided to have a new installation to clear this. So there should only Zorin Os 17 now.

What surprised me during installation or what I did not understand was a message that showed during installation when asked if delete data from harddisc.

This shows 2 partitions (it is in german, but might hopefully be understood). Coming back to the question if on same partition or alongside. I am not sure if I understood correctly or what the two partitions would mean... So I might never know what happened in detail... It felt better to start with a clean environment.

The Gparted screenshot, I think this might not be needed anymore? But will find out how to do this and to understand and might be helpful later.

I just found out about what you were asking for. Is this showing 2 partitions?

I did not consciously made a second partition. Could this have happened through the installations I did? The laptop, there was a user before, but I surely thought there was just one partition when I got it.

There is a lot to find out and understand. Thankful for this support :pray::pray:

See this, as a solution is marked there in post #32 re BIOS settings for RAID.

Can you enter your BIOS and see if it is set for EFI or Legacy boot, also RAID setting in BIOS.

Your Gparted screenshot shows grey keys marked against each of the 2 partitions.
Was that using Gparted run from your ZorinOS live USB?

Thank you for showing the solution for locked NVram you sent, I could not fully understand what was written there but it seems helpful.

My BIOS shows that both is enabled, UEFI and Legacy boot. Boot priority shows that UEFI will boot first.

I could not yet find out how to access RAID settings in BIOS, I do not see anything that looks like this.

The Gparted screenshot, I did this one after the new installation of Zorin OS 17.1. It still looks the same. I don't really understand the partitions. There is one OS and there should be one disk.

I found this description here to switch RAID to AHCI but I might first find out the used operation mode. I am a bit stuck here...

https://superuser.com/questions/1280141/switch-raid-to-ahci-without-reinstalling-windows-10

There is actually another way around this. Before you begin, make sure you remember your PC password (not PIN), or else you would be stuck in safe mode forever (with this way of entering safe mode). Also, I advise you to disable BitLocker before entering safe mode, or else you would probably need to provide a very long code to unlock your computer (not tested).

Booting into Safe Mode will work even though the storage mode has been changed... Windows will notice the change and load the correct driver on the next normal boot. Basically that means, you can do this:

1. Run cmd as administrator (not PowerShell, you would have to escape {...})
2. Copy-paste this command, which will start Windows in Safe Mode the next time you reboot:

* *bcdedit /set {current} safeboot minimal* *

3. Restart the computer and enter UEFI/BIOS setup.
4. Change the SATA operation mode from RAID to AHCI.
5. Save changes and exit Setup and Windows will automatically boot to Safe Mode.
6. Launch cmd again, as in step #1.
7. Copy-paste this command, which will start Windows in Normal Mode the next time you reboot:

* *bcdedit /deletevalue {current} safeboot* *

8. Reboot and Windows will automatically start with AHCI drivers enabled.

Note: Switching to AHCI is essential if you want to install any Linux as RAID mode is to my knowledge not supported, so you would not see your drive(s) in the installation menu.

If you have been through all yoir BIOS screens and cannot find that switch, don't worry maybe age of your machine or its BIOS preceed that.
Can I ask what is your make/model of machine?
Has its BIOS been updated?

I have read here on the forum, that nvme drives have a reputation of being difficult when installing linux distro's. One user @seanhinkley here on the forum, suggested selecting RAID not AHCI if you have a nvme drive, which yours looks to be, as the labels on your Gparted partitions seem to indicate that. Zorin OS pro 16.3 installer NVME disk not detected. - #11 by seanhinkley

My queston asked if you were running Gparted using "Try Zorin" mode off the USB or running Zorin and Gparted from the nvme drive. If from the nvme drive then I think that drive and partitions would expected to be shown as mounted/locked like your screenshot.
As you are using EFI then that EFI partition and its size are expected. The ZorinOS partition is then the ext4 formatted partition. Are you able to click the ext4 partition to expand and show partitions within that.

Are you able to boot ZorinOS Pro from your internal nvme drive or does it fail?

Note. As you have purchased Pro, you are entitled to request support from the devs, but do bear in mind they are only 2 people, so you would need to be patient with them.

Ok, I was unsure because of the BIOS. The pictures I found during research looked very different than the BIOS I am used to. Some showed a graphic interface and some an advanced BIOS menu. If there would be an option to open an advanced mode of BIOS, happy to know how to access.

I am working with a X270 Thinkpad. Sending some information, please tell me if something else would be needed or helpful.

Linux ThinkPad 6.5.0-35-generic #35~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Tue May 7 09:00:52 UTC 2 x86_64 x86_64 x86_64 GNU/Linux

CPU: dual core Intel Core i7-7500U (-MT MCP-) speed/min/max: 600/400/3500 MHz
Kernel: 6.5.0-35-generic x86_64 Up: 1h 29m Mem: 3239.5/15876.7 MiB (20.4%)
Storage: 476.94 GiB (5.5% used) Procs: 234 Shell: Bash inxi: 3.3.13

I did not update the BIOS. I don't know if someone did before I got this notebook. The update is currently disabled in BIOS.

This is a good information! Thank you. I will probably stop my research of finding RAID settings for now. Maybe it will get clear to me later.

I was running Gparted running Zorin and Gparted from nvme drive after the new installation I did yesterday, off USB :slight_smile:

Yes, I could click the ext4 partition in Gparted, it showed this.

After starting to write this I thought about starting from USB to see what the boot repair would show. It again showed this message

An error occurred during the repair.
Error: NVram is locked (Zorin not found in efibootmgr). Please report this message to boot.repair@gmail.com

A new file (/var/log/boot-repair/20240518_154352/Boot-Info_20240518_1543.txt) will open in your text viewer.

In case you still experience boot problem, indicate its content to:
*boot.repair@gmail.com *

Locked-NVram detected.

So, as I am able to boot and start the OS normally, off USB, I am not sure if this is something I would need to find out. Maybe I should open a new topic for this, considering the information from forum to better use RAID not AHCI when having a nvme drive. Or find a new title for this post because still some unclarities and issues. And would eventually request developer support later.

1 Like

Glad to see you've fixes the issue, i was just reading the last part about RAID.
To Clarify this ,RAID is used with 2 or more hard drives, without going into detail, Using RAID you can Eg; use one drive as storage & the other as the OS's, Swap/ etc etc.

So 1 drive is best run on AHCI mode.

keep up the good work.

1 Like

I am still not sure if that is true reading this:

Summary:
Julie is, as I understand, is only able to boot ZorinOS from her installation Live USB not from the internal nvme drive.
@Julie can you please confirm that understanding, as it is still unclear.
@Julie Also, have you ever been able to boot ZorinOS Pro, or Lite, from your internal nvme drive, with the installation USB removed?

Boot Repair reports "Locked-NVram" issue and it is a nvme drive, which adds difficulty.
I have removed the "Solution" flag at my post #4.

Note. In another thread @seanhinkley suggested using RAID rather than ACHI setting in BIOS where there is a nvme drive, but that is academic as there is no setting in Julie's BIOS for that.

EDIT:
I have just been looking at sopec of Thinkpad X270 (extracts)
Lenovo X1

@Julie in BIOS look at Security settings, particularly TPM and hard disk password settings.

I am not sure if true. Maybe RAID should be good with nvme drive but there seem to be no settings for this in BIOS. So I don't know about the current operation mode of disk. Let's see if we can find out what will work and how to do that :slight_smile:

This is not correct, I am able to boot from internal drive.

Yes, I can boot ZorinOS Pro from internal drive! :slight_smile:

I can boot from internal drive since two days after complete new installation and deleting everything else from harddisk.

This seemed neccessary as I was not able to go back to graphic environment without Live USB.

EDIT:
It's true that the Locked-NVram issue shows still up when running boot repair from Live USB.

As the post was named "Help to get back to desktop environment" I saw this issue as solved as I was able to access desktop environment with Live USB and save my files through that , which was what I was looking for :slight_smile:

But yes, I still could not solve Locked-NVram issue. But currently I am able to boot from internal drive despite Locked-NVram issue.

In the BIOS/ Security settings/ Security Chip, it shows TPM 2.0, the Chip is Disabled. Physical Presence for Clear is Enabled.

Security settings/ Password shows every entry as Disabled. Hard Disk1 Password is Disabled.

I hope this will help to find out more. Thank you for support!

1 Like

Ah good to hear. That clears a lot of misunderstanding.
Ignoring the Boot Repair error re Locked-NVram, does everything else work as expected when you boot Pro from your internal drive?
If true, and that Boot Repair error does not impact your use of ZorinOS, then it maybe is not so important.

EDIT: @Julie before you first went and installed ZorinOS on this laptop, did it have Windows on it? I am wondering if Windows was wiped before first disabling "fast-startup" in Windows Power Options. Ref: Before you install

Sorry @zabadabadoo ,
i noticed that the issue was "solved", & as a courteous gesture i gave my congratulations.

As for using RAID with only 1 drive.
It is not advisable due to a few issues that can arise.(Eg , Machine will continue writing RAID address's/instructions, OS not seeing the drive, etc etc.
These are some of the thing's that cause issue's).

Please read Here & Here, there is a graph near the bottom of the 1st link, that may save you a read, showing the config effects.

Yes the NVMe drive is faster than AHCI, but the difference is not noticeable, you will have more issue's in RAID mode than AHCI mode, with a single drive.
So for best results use AHCI,ATA, or IDE, with a single drive.

Hope this helps.

Added:
Note the Name. RAID ("redundant array of independent disks")

So using RAID Mode is an unelegant workaround that I've had to use on a couple of occasions when the other modes just simply would not work and it appears to have something to do with the BIOS and chipsets I unfortunately have no idea why it would work in RAID Mode and not Achi or IDE if I had to make a wild guess I would say it has something to do with Hardware security and changes to TPM protocols however I don't know that for sure (raid devices cant be isolated on the hardware for reasons)

One was for a two-in-one tablet device and the other one was for a netbook both had limited bioses geared towards Windows only

1 Like