How Did Your OS Update Go?

I decided that the thread on my Zorin machine was already big enough and thought it would be better to have a separate thread all about updates.

As some people have had troubles with their updates just in general, while other's went bad after a kernel update, I thought it would be a good idea to provide thread updates on my update situation.

Using the Timeshift APP for the first time, creating my first Timeshift backup, all files!

Backup completed...

Showing what updates are available...


OS Updated, requires restart...
Screenshot from 2021-10-19 10-08-44

Restart went OK, no boot issues, no black screen. Still can see my Star Labs splash and login background theme, nothing has been screwed up that I can see.

Providing my new Screenfetch!

Zorin OS 16 PRO Screenfetch Kernel 5.11.38


Your Tech Support Guru


I guess, you will be making a backup every time you're notified about of newer kernel update?
I sense fear in the force because of the updates, that this can possibly turn your system into a black screen/hole.

1 Like

My policy is not to jump on the new kernel when it is released. I routinely check the list of updates. If it includes a newer kernel, I hold back update a few days to make sure I would not have a problem with my NVidia card.


On my HP machine everything went well, have not tried my Lenovo yet. No problems, so far

Me still issa very happy camperrrrrr
You notta believa me? But issa true.

1 Like

Actually, I am using the default config options in regards to that. Backup every day, store up to 5 backups. When I first launched Timeshift, I didn't like it, cause it was giving me two choices, neither of which I knew what the heck they did.

One choice couldn't be chosen, but the other could, so I went with that. Then once I got to the main Timeshift screen, I was able to understand what I was doing more. I manually instituted a backup since the first one hadn't been auto created yet.

It didn't take too long cause I don't have much on the drive. But if this was on my MSI machine, it would take far longer, since I have a lot more on that drive with games lol.


If your MSI is used for gaming it will indeed take longer to backup. But do use the updates for the MSI?

And I guess you are not using the standard app for backup which comes with Zorin?

When it comes to installing or updating I see that the major headaches comes from users having to deal with a configuration using Nvidia graphics, just as FrenchPress explains.

OK, as many of you know by now, there was an update today from the Zorin team, which included a kernel update, which forced me to have to restart. Just letting you guys know, that my update didn't go 100% perfectly well.

The system updated, and after restarting, the system hanged on the ZORIN logo during the boot sequence, it never got to the Login screen. This kind of thing has been reported before on the forum, and I don't remember what causes it.

The only thing I could do was hold down the power button and force the computer off, and then turn it back on. The good news is, the computer was finally able to boot up after that. New screenfetch bellow!

1 Like

Everything went fine with a charm. All the updates are installed without any trouble.


Perfect without a hitch....however I try to review and watch as I install anything with Linux before I agree to update. Plus I keep a updated backup of all "just in case"

1 Like

Thank you guys for reminding me! I am using Timeshift on the old dual core computer's, Zorin installation of PRO. However, since the new installation of Zorin OS PRO on my MSI machine, I forgot to install Timeshift on it.

And since I didn't re-install my games, its not like I'd be asking Timeshift to try and backup 1TB of games. So, I sure was tempting fate here again, like I was when I was on POP OS without a Timeshift. So I am going to install Timeshift and make a backup.

Thanks for reminding me Bubby, your awesome buddy. Hey, Bubby buddy, your my awesome Bubby buddy, get it? OK, now that I am done being kawaii and silly over here, let me get to installing that Timeshift, and backup my OS before I end up losing it next for some reason lol.

1 Like

Everything went fine


Glad that you guys all have had successful updates so far this time around. The only people I know of that hasn't so far, is FrenchPress and I. Although, she had a kernel panic in relation to Nvidia 470 driver. Where as I am using Nvidia 495 driver.

UPDATE: Timeshift backup created manually for the first one. Using default settings though, automatic backup daily, saving up to 5 backups at a time.

1 Like

I noticed that we got a big update today, infact it was so big, the notification window wasn't calling it an update, but an upgrade. Since I haven't retested Zorin OS LITE since December, I am still running on the drive that has Zorin OS PRO/Gnome on it.

Since I have Timeshift installed on PRO/Gnome, I was ready for OS meltdown if the update/upgrade didn't go well, see...

And here we are updating/upgrading...

And here is my new screenfetch!

Its odd, cause the update/upgrade, left me to believe, that there was going to be an update to 5.11.44 generic kernal. But as you can clearly see, I am still running on 5.11.41. There have been a couple users who needed the 5.13 kernel because they have Framework notebooks.

5.13 has been around for a long time now. I think its time for the Zorin team, to upgrade Zorin OS 16, to 5.13 kernel. My old computer certainly doesn't need it of course, but my newer computer would appreciate it. And like I said, Framework notebooks need it imperatively.

But overall, how did my OS update/upgrade go? Surprisingly well! I was able to boot into the system to get the new screenfetch, I haven't run into any issues as of yet, no OS meltdown. How did you guys fair today?

I noticed that we got a new round of updates today, much of which were in the Zorin OS Base for Linux Headers. I just wanted to let everyone know, that after installing the updates and restarting, I am still locked into kernel 5.11.41.

I don't understand why this is happening to me and nobody else, at least, nobody who has bothered to check what kernel they are on, and report about it. Here we are 2-weeks later and the problem still hasn't been fixed.

FYI Still waiting on the Zorin dev's to fix this...

uname -a
Linux universe 5.13.0-28-generic #31~20.04.1-Ubuntu SMP Wed Jan 19 14:08:10 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
1 Like

uname -a

5.11.0-41-generic #45~20.04.1-Ubuntu SMP Wed Nov 10 10:20:10 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

It could be a blessing that you don't get to boot into kernel 5.13. It seems full of bugs compared to 5.11.

Have you tried kernel 5.16?

1 Like

When I was on POP OS 21.04, I was on kernel 5.13 then, and it worked really good for me. The only real issue that I had with POP OS, is often I would lose the keyboard after logging into the OS. Which required me to restart my machine over and over, until the keyboard still worked after logging in. I documented this well on the board here.

Zorin OS is not installing 5.16 that I am aware of, so I can't use 5.16. I suppose I could go into Synaptic Package Manager, and select the 5.16 kernel for install? But I don't want to risk doing that, because if Zorin OS isn't ready for 5.16, me trying to force myself into it, I perceive to cause serious issues.

It's a PPA the kernel 5.16 is on. Some have luck with it others don't. So, yeah, it's risky.

1 Like

I would recommend against the risk for now. I think StarTreker has struggled with this enough without biting that one off.
I am utterly stumped as to why the system refuses to see the 5.13 kernel, as well. In fact, I wouldn't have thought it possible to happen... Yet, here it is...