How to xrdp to Zorin os?

Hello all
i am trying to use windows remote dekstop connection to connect to my remote installed Zorin os

i have installed xrdp on zorin and its running and the user is logged out
but when i try to connect to it using windows remote dekstop connection i get a black screen

i had this issue with ubuntu budgie too but i could fix it by adding budgie-desktop to the end of the /etc/xrdp/ file

but i dont know how to do this with zorin

pls dont tell me to use vnc
its a cr@p client

szuru, are you using Zorin Core or Zorin Lite?

Could you please state what version of xrdp you are running?

Hi, i am using Core

Could you please try the following:

sudo add-apt-repository ppa:martinx/xrdp-next

sudo apt update

sudo apt upgrade -y

I am assuming you have checked firewall and privelages.

i just tried that and it works but the problem with that is
it shows you the gnone gui instead of the zorin gui
and opening terminal etc wont load using it
i had to uninstall it

Well, at least it was a move in somewhat the right direction. What about the suggestions made here:

You may need to remove ~/.xsession and restart xrdp.

i messed up my installation
so i am going to reinstall Zorin
and then will try your suggestion
i will let you know about 20min

okey i have reinstalled and updated zorin and installed xrdp
after that added xrdp-next and upgraded
after that i edited startwm but i get blue screen after logging in with xrdp

i corrected my typo from &HOME to $HOME but still the same

1 Like

A couple suggestions here:

sudo apt-get install xorgxrdp-hwe-18.04

And another is to

In /etc/xrdp/ change #!/bin/sh to #!/bin/bash

This is out of my ordinary area of usage... I do not think I can be very helpful, but hopefully I can help steer you in the right direction that helps you to find what you are looking for to solve.

I know that feeling. :wink:

1 Like

i get this

This user refers to it as the “infamous” popup:

yea but its not loading the Zorin theme

Are you saying you can handle the authentication, but your concern is that it is not honoring the system theme?
Hopefully, the same blogger can be helpful there, too:

1 Like

still the ugly gnome theme :sob:

1 Like

@Aravisian Hey, for some reason setting the appearance using Zorin Appreance fixed the issue even after restarting zorin

about us images hd

1 Like

Saves me from more web crawling. I have never used xrdp- I no longer use Windows at all.

1 Like

yea, the reason i use xrdp is when u use vnc the desktop is sluggish and laggy
but you dont have that with xrdp
its smooth and fast

Could you try following this guide online: