HP Pavilion G7-2310ED, wifi card got killed after a W10 update

Yeah, I just don't see people standing idly by and just taking it like that. I think people are going to revolt, either by suing MS for this, or jumping ship to Linux all together. I am happy to see that POP OS 21.04 detects your GPU's out of the box, thats awesome! Congrats!

1 Like

I dunno... companies have been bricking electronics and using planned obsolescence for a very long time.

People complain for five minutes. Then they buy it again. People don't care. They just don't.
Caring takes effort. Most won't walk ten feet to a trash can.

2 Likes

Well i bought a tp-link ac-1300. Booted up live in Pop! OS but does not detect the wifi card.

Doing some research now.

1 Like

Not when you can drive ten feet to it.
Opps. I do not mean to deviate from the OP subject. Where is @FrenchPress ?

2 Likes

Just so you know, I looked up your WIFI adapter on Amazon, I then looked at the Q&A section, typed in Linux. There were mixed results, some say there is no Linux driver for that adapter, others say it worked for them on Ubuntu 20.04.

With results such as that, its not definitive. All we know is, its not working for you currently at this time. But there might be a workaround.

1 Like

Got it to work using these commands.

sudo apt-get update
sudo apt-get install -y dkms git
mkdir src
cd src
git clone https://github.com/morrownr/88x2bu.git
cd 88x2bu
sudo ./install-driver.sh
sudo reboot

2 Likes

Oh my gosh, I am so happy for you!!! What a huge load off your back! Now she gets to enjoy Linux, no more of that Windows garbage. Time to use a real OS. I can tell you right now, that OS can do everything that she needs.

From what I remember you said about her, she's not a heavy user of Windows specific applications. So this should do fine for her. Microsoft just got a good kick in the pants form Michel.

No we aren't gonna take it, we won't stand for you breaking it, were not gonna take it, anymore. :stuck_out_tongue:

1 Like

Hehehe thanks, she asked me to install the older sims games and older rollercoaster games haha. Let's see if i can get them to run in Lutris.

Nah she rarely is using the laptop, the laptop is more stored then in use haha.

Yeah time to use a real os indeed, microsoft does not get into this house anymore. Killing the wifi card yesterday made my wife a bit angry, i told her that linux will run better on her machine AND she does not need to reboot after every update. Today installed over 70 updates and did not reboot once :sunglasses:. Microsoft can learn from Linux

1 Like

My laptop is only 3 years old and when I took the Win 11 test it told me my computer was to old ... that is when I started looking of another OS ... sure glad I found Zorin and this board ...

By the way you don't need to install any of M$'s updates ... as I said my computer is 3yo and when I got it I installed Pro ... from that point on I didn't download ANY updates from M$ till this day ... there are ways around it but only with Win 10 Pro ... before 10 I ran 8.1 for years again never updated anything with Win 7 and below you could opt out in the OS ... drivers were done from the manufacture ...

Don't mind updates from Zorin as I trust them ... M$ is just into data mining and privacy breaching and they don't give a flip about you ... I told everybody I came in contact that with the free installation of Win 10 there was something very wrong ... because as you didn't pay for it they owned you and the software and you had no legitimate way or reason to complain ... and I was right you lost all your privacy ... the only reason I went to Win 10 was because I bought a new laptop and it was already installed on it ...

Thank god I won't be having any of those problems as I can stick Win where the sun don't shine very soon ... I stay on Zorin all day and only keep Win around in case I screw something up with Zorin and need help getting going again ...

1 Like

I totally agree FROG!

When I bought my new MSI computer back in April, it came with Windows 10 on it. But I had already seen enough of Windows 10 in tech media to know, I didn't even want to boot into it to check it out! Win10 never got to see the light of day, never got to connect to my network and spy on me, no sir!

I loaded up the POP OS installer, booted off of the USB drive, and I used GPARTED to remove all the Win10 partitions. I had trouble at first doing this, no down MS's BS security methods. But the 2nd attempt was the charm, and I got those partitions removed.

I then installed POP OS and I haven't looked back since, sent those Win10 partitions right into the MSI black hole, right where they belong, sucked into oblivion. lol

2 Likes

My laptop is 4 years old, probably to old as well but as soon as i have read Windows was going to change the specs i was googeling for a linux distro. Back in Augustus i have read alot about Zorin OS 16 and that this was 1 of the best distro's for users who came from Windows or Mac. Tried it, like it and didn't look at windows anymore. Loved to sort some things out/how things where working. Took me a few weeks to get steam running with Proton, steam lists proton builds but they don't download automaticly ... i tried adding a non-steam game and i was really like "grrrrrr why does it not work!!!!'' but yeah without the proton installed it is the same thing running a pc game in a ps5 machine haha. Everything got set-up here, i am so happy with my Linux. It is so much improved compared with 8 years ago when i tested linux for the first time.

2 Likes

The usb wifi stick is bloody fast, booted the laptop without the stick to see how fast it detects wifi. It took 1 sec. Here is a picture of the stick :sunglasses:

1 Like

DUDE, TP-Link makes some excellent hardware! I used to be a fan of Netgear, but some features they put in as afterthoughts and are half-baked, and I won't buy Netgear anymore.

Don't you love the super fast speed that you can get out of a tiny device? You look at that thing and your like, "OK, this thing is obviously made for convenience, it won't match up to an ethernet connection." Then you start using it, your next words are, "Holy guacamole Batman, she's fast!"

And then I as Batman will say, "I know Robbin, she gets me there in half the time!" I tell ya Michel, you made a good choice picking that one. I wanna show off some sexy TP-LINK for you to see too, this is my Gigabit ethernet switch I bought this year from that brand.

TP-Link TL-SG1016D 16-Port Network Switch
TP-Link TL-SG1016D 16-Port Network Switch
1000GB Network Connected Via TP-Link Switch
And yes, this screenshot was taken just before I changed my theme to Material Black Blueberry. lol

1 Like

Yeah tp link is a awesome brand! i see you have a nice switch and great speed!. You use a lot of ports haha.

1 Like

And I'd be using more ports, but society forces us into WIFI these days. And though I could probably connect my Zorin machine up via ethernet too, I would need to buy a set of new ethernet cables. Cause I just have patch cables left, and patch cables don't seem to work.

If I remember my early networking training from when I was still in HS, I believe patch cables are used to connect two computers together to communicate with each other, without the use of a standard network.

i did eveything that you told me to do but im at the that downloaded thethe driver but now im at the part that it tell me to put down cd 88x2bu but it says no such file or directory what do i do and how do i put it in a file

1 Like

im now at this point where do i go next

@ericthered45, did you get your wifi card to work ?

For people who has the same AC1300 usb stick, if you upgraded to kernel 5.15 then your driver does not work anymore (from post 13). I found a new solution, working now with kernel 5.15

git clone "https://github.com/RinCat/RTL88x2BU-Linux-Driver.git" /usr/src/rtl88x2bu-git
sed -i 's/PACKAGE_VERSION="@PKGVER@"/PACKAGE_VERSION="git"/g' /usr/src/rtl88x2bu-git/dkms.conf
dkms add -m rtl88x2bu -v git
dkms autoinstall
2 Likes

Just wanted to share that this old laptop even works great with Linux with hdmi + a dvd. My wife wanted to watch home alone 2 on dvd and tried everything to turn the movie on (for some reason the ps3 refused). I told her to use her laptop for that, will you do it for me ? I never tried it she said ... Sure i will.

4 Likes