I'm getting stressed trying to install Zorinos core

When I tried booting into zorinos via usb it just shows the zorin logo and doesn't boot at all. I have tried checking the sha file but there isn't any defects I also tried using safe graphics same result I would try using nvidia drivers but thats useless because my system uses intel graphics

1 Like

What year make and model computer is it?
32bit or 64bit?
Notebook or Tower?

Is it Z15 or Z16 you are trying?

its a 64bit intel i3 computer

Does it use SSD? HDD?

1 Like

Nvme ssd

1 Like


NVMe SD is not the same as SSD. It is, like eMMC, notoriously difficult to get NVMe to take Linux. It is possible sometimes, however, with some work.
Others have less luck:

1 Like

Oh that makes sense so that means i wont be able to install zorin? it works with manjaro ubuntu and fedora but zorin os doesn't work?

It means that you may not be able to. We can try some tricks - like advanced Grub prior to running the install...
Here is a guide:

Since your Zorin is not yet installed, you must do this a little differently.
When you boot the USB, hit the e key at the Menu. This will pen the Editor for grub.
Scan the screen for "quiet splash" and when you find it, place this exact line one space after quiet splash:


Exit the Grub Editor and proceed to boot. If it boots and you are able to install, you will need to make that change permanent in grub, so we will need to Walk Through That portion prior to you rebooting the computer.

1 Like

so after installing zorin os will just have to just update the grub with sudo update-grub to make it permanent?

No. We must change your grub configuration, then update it prior to rebooting. But you must mount the freshly installed Zorin Partition, then access the file in Root.

alright thank you for your help i will do this later and report back if it works

1 Like

so if its able to boot and I start the zorin installation normally what should i do next after the installation is complete?

Once installation is complete, it will ask to restart. Choose "Restart later and continue trying Zorin."
If you do not get that option and it reboots- you can still drop to Recovery Menu and edit grub from there.
But let's say everything goes fine:
Continuing on the LiveUSB, open a terminal and enter in (
Where sdaX needs to be replaced with your Actual Drive I.D.
It's the one you chose to install to in installation. If you are unsure, you can first run lsblk to list the blocks and identify yours by the Size.)

mount /dev/sdaX /mnt

Once mounted, you can then access the Graphical way or by Terminal.
Let's cover graphical:
Double click the Mounted SD Drive icon on the desktop or use the File Manager to navigate to it.
One open, click "Other location" in the left sidebar. Then select "computer" (Why gnome does the round about way I will never know. In Zorin Lite, you just hit the Up arrow and you're done.)
From "Computer" double click etc, then default and finally, scroll down to the Grub File and double click to open in the editor.
You will see this:
GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian

Change it to:
GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvme_core.default_ps_max_latency_us=0"

Then click Save.
Then exit.

Open a terminal and enter into the mounted partition as root:

sudo chroot /mnt

Then update grub:

sudo update-grub

exit the /mnt


Then unmount the partitions to safely reboot:

sudo umount /mnt/dev
sudo umount /mnt/sys
sudo umount /mnt/proc
sudo umount /mnt/

Thank you for making it so clear im still downloading zorin os core so ill do all your steps later

1 Like

welp it didnt work it couldn't boot at all anyways thanks for your effort and help ill install another distro

You listed that several are configured to seek out and address NVMe. I appreciate your feedback on that - I think we should forward that to the ZorinGroup to examine whether than can enhance Zorin OS so that it does the same.
If Zorin is patched for it- will update this thread.

Wait... You listed Ubuntu...
Zorin OS is built off of Ubuntu.

Were you installing Zorin OS 15 or Zorin 16?

1 Like

My guess is that OP was trying to install 15,3.
It seems NVMe is supported in Zorin 16 but not in 15,3.

I think we should make it a habit to ask the version of Zorin to those who have a problem with NVMe installation.

I did that early in the thread without any respons -_-


Right! I just saw that.

It started to make me feel like that we need a doctor's office like questioner. You have to answer all questions before allowed to see doctor :wink: