Issues with dual boot

Hi everyone, I have tried many times to install zorin os 17 core in dual boot with win 10. Every time failure.
I have seen some videos and read some tutorials. Here my procedure.

  1. I tried via Ventoy.
    1a. I created an unallocated space in win 10 with the internal disk utility
    2a. I installated zorin by creating 1) boot partition of 1 Gb (/boot); a root partition (/) of the remaining space, approximately 40 Gb
  2. The bootloader was placed on /sda
    No results.
    I tried via Rufus. No results.
    Secure boot=disabled; legacy mode
    It should actually work and I do not understand why it does not. I am beginning to think that it could depend on the fact that my notebook acer travelmate was some years ago in dual boot, but after some use I deleted the ubuntu distro and fixed manually the boot in win 10. This is the reason why the notebook does not boot directly in win10, but it boots in a sort of grub menu with only win10. This menu could be located in an unidentified small partition (msftres of 128 MB) which resists to the new installation. I cannot document this at the moment, but I will do in the next days. I would like to keep win10 for another year, since the notebook will receive updates until dismission of win10. After that date, I will format the whole and install from scratch zorin in the ssd, which will be for sure easier. In the meanwhile an alongside installation will do fine, but I am not able to do it for some specific reason. Any help would be much appreciated. Thanks a lot

Welcome to the Forum!

When You installed Zorin why did You have chosen to make the Partitions manually? Did the Installer not shown an Option to Install Zorin beneath Windows?

To create a bootable stick Balena Etcher is a Toll what works not bad. I have made good Experiences with it. Simply format the Stick to FAT32 Format.

Do You still know how exacly You deleted it?

It would be nice if You could do a Picture from the ''Grub Menu'' and the Partitions in the Windows 10 Disk Management if possible.


Hi there, thank you for your reply. I tried also to install it automatically, but with no results. So I checked some videos and tried manually. I did this many times with other ubuntu-based distros with success. I think the problem lies in this notebook with these specific partitions. Unfortunately, i do not remember how i deleted the ubuntu distro. I will make photos of the whole configuration as soon as i can. Thanks a lot


Hi, here some pictures which show the issue

Perhaps the problem lies in /dev/sda3. I am sure that booting zorin with a usb formatted via balena etcher would lead to the same failure. I tried a dozen time with all possible configuration, automatically or manually. No way. I guess, order should be made in win configuration first.
If you have ideas, please let me know. I read that the 128MB partitions msftres should not be touched otherwise win becomes unbootable, but I cannot say for sure.
Thanks a lot

1 Like

When you remove Linux partitions make sure you also follow the steps mentioned below to remove the Linux Efi entry, otherwise Windows will not boot directly.
(This guide was previously shared by Ponce-De-Leon)

1 Like

Parli italiano? Because I don't (I could try)...

Well, deleting a distro (for Windows computers) is to delete the partition on which the distro is installed. I took have had success installing distros (albeit Pop! OS did not work).

Bene, eliminare una distribuzione (per computer Windows) significa eliminare la partizione su cui è installata la distribuzione. Ho avuto successo nell'installazione delle distribuzioni (anche se il sistema operativo Pop! Non ha funzionato).

Plus, this could be a BIOS system, which I don't work with, but I am guessing you may need to prepare for your BIOS system to be Linux-ready.

You can check on preparing Zorin OS for legacy booting using the post below. Hopefully, it helps.

Inoltre, questo potrebbe essere un sistema BIOS, con cui non lavoro, ma immagino che potresti dover preparare affinché il tuo sistema BIOS sia pronto per Linux.
Puoi verificare la preparazione del sistema operativo Zorin per l'avvio legacy utilizzando il post seguente. Speriamo che aiuti.

Okay, Thank you for the Pictures. On Your first Picture I can See that You should have an UEFI BIOS but on Your second Screen stands on Boot Mode Legacy. Can You change that? Or do You want to use the Legacy Mode?

Another Thing are the Partitions. On GParted is this msftres Partition to see but on the Windows Overview is it not. And you have 2 FAT32 Partitions.

the Grub Screen is not Grub. It is the Windows Boot Manager.

@littlekun wrote a Comment with a Description from me. You could try this. But be careful with it.

Hi there,
thank you. Yes, I tried both legacy and uefi. I know, ubuntu-zorin should be installed preferably in uefi, and usb boot should be prepared accordingly. I can try again with balena etcher. Probably, when I install manually or automatically, the boot loader should not be located on /sda, but in another partition, namely in that with win boot manager, since grub should take command over the boot. Thanks a lot anyway for your comments. Very useful

Hi again,
I deleted firmware entries no problem. I formatted an with balena etcher an usb, and choose an automatic installation (alongside). Also, I discovered that on acer notebook you have to set a password in order to modify secure boot option. So I set boot in Uefi and secure boot disabled. I created an empty, unallocated space with gparted and started again the installation process. I was quite confident this time, but I see again windows boot manager. Please, notice that I did not see the graphic screen in which you can give more or less space to the two operating systems by moving their partitions with the mouse. In this case Ubuntu very likely was not installed in UEFI mode, so that the boot loader was not placed in the right place. I wonder If I can make it right via boot-repair software or something like that. Thanks a lot

This option only appears when you Select the Install alongside with Windows option.

And when you proceed with the Something else option then make sure you are putting the correct values for /boot partition.

Hi, I tried boot repair, standard repair. I did not work, but it was useful, since I got a log, which will eventually lead - as I hope - to a solution. Please, find the log attached. There is something wrong, but I cannot say exactly what.
For instance, I read
Boot successfully repaired.

Locked-NVram detected. (Zorin) Please report this message to
Please do not forget to make your UEFI firmware boot on the Zorin OS 17 (17) entry (sda2/efi/ubuntu/grubx64.efi file) !
I cannot understand that and hope that someone could tell me where the error lies.
Unfortunately, the system does not accept files in .txt format and a conversion to png was not satisfactory

type or paste code here

Okay, you turned off Secure Boot; that is good. You set Your BIOS to UEFI Mode; that is good too. You created an USB Stick with Balena Etcher, okay. So, the Preperation sounds so far good.

And on Your Windows System how is it there with the Partition Overview in Disk Management? When all is fine there should be an EFI-Partition in FAT32 Format from Windows, Windows itself and maybe a Recovery-Partition from Windows.

When You now use the Installer it should show You 3 Options:

  • Install Zorin alongside Windows
  • Erase the Disk and install Zorin
  • Something else (which is the Manual Partition)

When You choose the first Option it is the easiest Way. There You don't need to create an empty unallocated Space for because You can adjust how many Space You want to use. It should look like this:

If you should not see this it seems that the Installer not detects Your Windows System. In this Case You must do a manual Partition and You must choose the ''Something else'' Option. In this Case You need an empty Partition, yes.

To make a manual Partition You need only to do 2 Steps:

In the Overview You choose the free Space that You created and then You click on the + and the Window will open. On the last Option ''Mount Point'' you simply choose the / for mounting.

After that You go to ''Device for Boot Loader Option and choose the Windows Boot Manager. Then Zorin sets his Boot Stuff in the windows so You can get the Dual Boot. It should look like this:

Hi, I think we are close. Everything was done right. The last step was wrong, since I left the device for boot loader on /sda. I run boot repair. Unfortunately, I cannot upload the .txt but I can paste a short text
chroot /mnt/boot-sav/sda5 update-grub
Sourcing file /etc/default/grub' Sourcing file /etc/default/grub.d/init-select.cfg'
Found theme: /usr/share/grub/themes/zorin/theme.txt
Found linux image: /boot/vmlinuz-6.5.0-21-generic
Found initrd image: /boot/initrd.img-6.5.0-21-generic
Found linux image: /boot/vmlinuz-6.2.0-39-generic
Found initrd image: /boot/initrd.img-6.2.0-39-generic
grub-probe: error: cannot find a GRUB drive for /dev/sdb2. Check your
Found Windows Boot Manager on /dev/sda2@/EFI/Microsoft/Boot/bootmgfw.efi

Unhide GRUB boot menu in sda5/boot/grub/grub.cfg

Boot successfully repaired.

You can now reboot your computer.
Please do not forget to make your UEFI firmware boot on the Zorin OS 17 (17) entry (sda2/efi/ubuntu/grubx64.efi file) !
If your computer reboots directly into Windows, try to change the boot order in your UEFI firmware.
If your UEFI firmware does not allow to change the boot order, change the default boot entry of the Windows bootloader.
For example you can boot into Windows, then type the following command in an admin command prompt:
bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

Similar case here

Perhaps there is a quicker solution to make Uefi firmware boot on Zorin, whatever it means. Otherwise I can reinstall

1 Like

If your boot was successfully repaired, you may be able to address your boot order using efibootmgr in Zorin OS:

You do not need to install efibootmgr, it comes preinstalled on Zorin OS. You can run


to note the boot numbers.
Then append it as the above guide walks through.

Theoretically You should can do it in the BIOS. You have posted this Picture:

That is your Boot Order. There You should set on the first Position the ubuntu Bootloader. In my Case it is simply named ''ubuntu''. When this is on the first Place the Grub Menu should appears.

If You prefer to do a new Install You can do that too. Delete Zorin and then try to make it like it is described at the Pictures if You must do a manual Partition. That is Your Decision.

Hi everyone, thank you so much for your replies. For the records. I tried many solutions. The first one was according to boot repair. It did not work. Then I tried to reply exactly the procedure suggested for a fresh manual install, this time with boot loader placed on /sda2 (win boot loader). It did not work. It became too complicated. From nautical experience I have learned that too complicated knotes have simply to be cut. So I started again from the beginning. Fresh win install (no prob about that) and then install zorin alongside. The graphical installer has behaved like never before. It allowed a flexible range for the dual boot. Usb prepared with balena etcher, Bios: Uefi; secure boot disabled. I thought, this time I can do it, but - hey - no way. I am starting to think there is something wrong with the installer. I attach two picture of the actual situation. I tried efibootmgr. I can see the ubuntu partition, but it is not included in the boot order. I make a last attempt tomorrow. Otherwise I delete the partition and use just win for another year. For further instructions I will be grateful. Otherwise, thanks a lot for your help. I have learned many things.

1 Like

I would say Your Partitions look so far good. But there is one Thing in Your efibootmgr Overview what I found weird: the Timeout. It stand on 0 Seconds? When it is on 0 Sconds You can't get a Grub Menu.

Maybe You could control the Grub Timeout. Type sudo nano /etc/default/grub and look for the Line with the Grub Timeout.

And there is another Thing Boot0006 ubuntu should go to the first Position. Because when You look to BootOrder there stands:

2001 (EFI USB Device)
0007 (Windows Boot Manager)
2003 EFI Network

So the ubuntu comes not to work.

1 Like

Hi again,
I set the timeout to 5 seconds. But that was not the problem. I changed the boot order, but at reboot win starts. The line in efibootmgr is ignored and here is why: Nvram locked detected. boot repair does not work because of this error. I read from various reports that It a general uefi issue and it is not easy so solve. I went through the bios again, disabled TPM, deleted every possible password. The issue could depend on the old bios of acer travelmate p-236, or maybe it was how the usb stick was made. I made it via balena etcher on another pc with Uefi and Secure boot enabled. I do not know if this could play a role.

Please try resetting your CMOS battery.

Hi, good idea. But I cannot locate it. It it probably of a type which I do not know of.
Do you have an idea where it is? Acer Travelmate P236-M