I've finally moved to Zorin OS for good but I have a few questions if someone can help

Installing Snap is not bad if you don't care about open source. Most users do and would rather use Flatpak. Personally, I don't like both and will only use AppImage if I really have to.

2 Likes

Hi Toshi, its really nice to see you active on here! You seem to be well motivated, not just with using Linux, but also in community, and I want you to know that I appreciate that. Your amazing! :smiley:

In regards to ARM, yes, it appears to be the wave of the future for mobile computing, everybody wants a piece of it. There was some talk about Nvidia wanting to heavily invest in ARM, and it made people nervous lol.

When I mentioned Virtual Box, I didn't actually think you were going to try it, I assumed you were going to jump onto that other one forget its name now. But I am happy that you are enjoying Virtual Box, and that it is able to do what you need.

I use a tablet to view my security camera's, and I have my tablet connected to a chromecast, which allows me to view the feed from the tablet, on a 24" IPS monitor from BenQ. Works great.

I think its pretty stellar how Aravisian put Linux on an Xbox, that just shows his excellent resolve. He had an idea, he knew what he wanted to do, and he did it!

Linux takes time to get used to, you don't learn it over night. I've been using Linux for at least 6+ years now, and I am still learning new things!

I've never known someone who needed so much SWAP file, but what that tells me, is that you use your computer in a way that I don't. Keep in mind, you could always buy a super fast hard drive, put a SWAP partition on it, and dedicate it for SWAP use.

If you want to have a nice read about my new Zorin OS 16 PRO experience, just click on the link bellow.
Installing Zorin OS 16 PRO on a Dual Core machine.

2 Likes

Hi StarTreker, thanks for your lengthy message!

I really like this community because it seems to be filled with knowledgable individuals who gained their knowledge by doing something they genuinely liked.

Installing Linux on an Xbox and using it as a security system device is amazing. When I was 9 years old, I built my first website. As a child, I always modified my cell phone, installed different custom ROMs and etc. Even if I didn't know much of what I was doing, I loved learning. And I can tell that this community has a lot of such people.

About the swap file.. I use about 100-200 open tabs in Google chrome and quite often I have other software open and running. I am a freelance writer and a web designer. I already have a quite fast SSD from Samsung. On windows, I made a 20gb page file and my device was flying.
On Linux its all great until I fill up the 12gb ram, then it gets a bit troublesome. I hope I find a way to use the swap file as efficiently as windows uses the page file.

I checked out your link. Did you ever consider being a writer? Not many people are able to keep the reader's attention as you do. Trust me (I have been in the writing industry for years). Maybe you could apply to write for Linux blogs if you have that much passion in writing about these systems :smile:

Also, I have another question for anyone who might know about this issue. I keep getting this error in my taskbar from the update manager. What can I do to resolve it? I tried running the apt-get in a terminal but I get nothing special from it. Thanks!
image

2 Likes

Believe it or not, I really love the way you push your computer to the limits. And sometimes, we must break things for science! HEHE

Thank you very much for your kind words about my writing. I guess it all started back in school when I had to write essay's. Then later in life I began writing reviews professionally, until the website died of course.

I have written a few super short stories, written from the perspective of the hopeless romantic. But it was just a personal adventure, and only shared with a couple of people. I never published anything.

I am a mechanic by trade, I fix small engines, lawn mowers, that sort of thing. Speaking of which, I do a little lawn mowing on the side, always good to make a little extra income. I am also a bit of a computer tech, I love computers what can I say? lol.

You should know I am a big movie buff, some people on here have already noticed that, as I post material from lots of different sources, I will make a movie buff out of Kedric before the year is over! lol. And I love to play video games of course.

One of the wonderful things about Zorin OS, especially if you buy PRO, is that it comes loaded with pretty much, most of the apps your going to need to do production work. And what it doesn't come with, you can find in the software center.

Since you are doing strong production work, you might want to think about upgrading your RAM eventually. I do some production work on occasion, mostly photo editing and video editing.

This is an old screenshot I took of Stacer, which is showing how much resources I was using, while rendering a 1-hour 4K video, in Kdenlive.


And yes, I do recommend Stacer, as its an awesome resource monitor, and system cleaner APP.

Regarding your question at the end. First try restarting your computer, if a simple restart does not fix this issue, we will dive deeper into it later.

2 Likes

You should definitely be a writer lol :smiley:
If you ever feel interested in doing it professionally, feel free to DM me and I'll give you some pointers where you can apply for freelancing jobs. Sites like problogger, certain reddits and etc.

Unfortunately, I can't upgrade RAM. My laptop has a 16gb maximum support and 4gb is soldered to the board. I added 8gb ram because finding a stick of 12gb where I am from is next to impossible.. I really don't understand the engineer who designed this motherboard setup..

I will checkout Stacer. It looks great!

I tried restarting and whatnot but nothing fixed this issue. Here let me know what you think of this terminal text.

dusan@Dusan-PC:~$ sudo apt-get update
[sudo] password for dusan:       
Hit:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://ppa.launchpad.net/zorinos/apps/ubuntu focal InRelease             
Hit:3 http://ppa.launchpad.net/zorinos/drivers/ubuntu focal InRelease          
Get:4 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]      
Hit:5 http://ppa.launchpad.net/zorinos/patches/ubuntu focal InRelease          
Hit:6 https://repo.protonvpn.com/debian stable InRelease                       
Hit:7 http://ppa.launchpad.net/zorinos/stable/ubuntu focal InRelease           
Hit:8 https://packages.zorinos.com/stable focal InRelease                      
Hit:9 https://packages.zorinos.com/patches focal InRelease
Get:10 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [27,6 kB]
Hit:11 https://packages.zorinos.com/apps focal InRelease        
Get:12 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [61,0 kB]
Get:13 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 DEP-11 Metadata [2468 B]
Hit:14 https://packages.zorinos.com/drivers focal InRelease
Hit:15 http://rs.archive.ubuntu.com/ubuntu focal InRelease
Get:16 http://rs.archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Get:17 http://rs.archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]                                                
Get:18 http://rs.archive.ubuntu.com/ubuntu focal-updates/main i386 Packages [536 kB]                                         
Get:19 http://rs.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [1214 kB]                                       
Get:20 http://rs.archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [283 kB]                                 
Get:21 http://rs.archive.ubuntu.com/ubuntu focal-updates/universe i386 Packages [633 kB]                                     
Get:22 http://rs.archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages [855 kB]                                    
Get:23 http://rs.archive.ubuntu.com/ubuntu focal-updates/universe amd64 DEP-11 Metadata [352 kB]                                                                                                                                             
Get:24 http://rs.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 DEP-11 Metadata [944 B]                                                                                                                                            
Get:25 http://rs.archive.ubuntu.com/ubuntu focal-backports/universe amd64 DEP-11 Metadata [10,4 kB]                                                                                                                                          
Fetched 4304 kB in 8s (539 kB/s)                                                                                                                                                                                                             
Reading package lists... Done
dusan@Dusan-PC:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  libprocps8 procps zorin-connect
3 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 300 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ppa.launchpad.net/zorinos/stable/ubuntu focal/main i386 zorin-connect all 1.2.2 [34,1 kB]
Get:2 http://rs.archive.ubuntu.com/ubuntu focal-updates/main amd64 libprocps8 amd64 2:3.3.16-1ubuntu2.3 [33,0 kB]
Get:3 http://rs.archive.ubuntu.com/ubuntu focal-updates/main amd64 procps amd64 2:3.3.16-1ubuntu2.3 [233 kB]
Fetched 300 kB in 1s (540 kB/s)
(Reading database ... 285600 files and directories currently installed.)
Preparing to unpack .../libprocps8_2%3a3.3.16-1ubuntu2.3_amd64.deb ...
Unpacking libprocps8:amd64 (2:3.3.16-1ubuntu2.3) over (2:3.3.16-1ubuntu2.2) ...
Preparing to unpack .../procps_2%3a3.3.16-1ubuntu2.3_amd64.deb ...
Unpacking procps (2:3.3.16-1ubuntu2.3) over (2:3.3.16-1ubuntu2.2) ...
Preparing to unpack .../zorin-connect_1.2.2_all.deb ...
Unpacking zorin-connect (1.2.2) over (1.2.1) ...
Setting up zorin-connect (1.2.2) ...
Setting up libprocps8:amd64 (2:3.3.16-1ubuntu2.3) ...
Setting up procps (2:3.3.16-1ubuntu2.3) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for libc-bin (2.31-0ubuntu9.2) ...
Processing triggers for systemd (245.4-4ubuntu3.13) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...

I think that the programs mentioned in the update are not the same as in the upgrade. Like the update command downloaded the files but the upgrade command didn't install all of them.

1 Like

Just... just kill me now...

I need a little help... I did scroll up, but still lost.
Which issue are you fixing currently?

That terminal output looks normal, to me.

3 Likes

Thats why you need 32GB of RAM Aravisian, how else are you gonna load in 600 tabs in Chrome? LOL! :joy:

I agree, Toshi's terminal output looks normal to me too, I saw nothing that said "FAILED"

However, if you feel strongly that you might have broken packages due to an upgrade, that didn't take correctly, here is the steps in TERMINAL to fix that.

You already know how to open a terminal...

sudo apt-get update --fix-missing

Then run this one next...

sudo apt-get install -f

Then just run this and your done!

apt-get update

3 Likes

I guess this sort of worked.

With the apt-get update I got this error

usan@Dusan-PC:~$ apt-get update
Reading package lists... Done
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
W: Problem unlinking the file /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permission denied)
W: Problem unlinking the file /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permission denied)

But then, after adding the sudo prefix it worked.

Everything seemed to have worked.

dusan@Dusan-PC:~$ sudo apt-get update --fix-missing
[sudo] password for dusan:       
Hit:1 http://ppa.launchpad.net/zorinos/apps/ubuntu focal InRelease
Hit:2 http://rs.archive.ubuntu.com/ubuntu focal InRelease                      
Hit:3 http://rs.archive.ubuntu.com/ubuntu focal-updates InRelease              
Hit:4 http://dl.google.com/linux/chrome/deb stable InRelease                   
Hit:5 http://rs.archive.ubuntu.com/ubuntu focal-backports InRelease            
Hit:6 http://ppa.launchpad.net/zorinos/drivers/ubuntu focal InRelease          
Hit:7 http://security.ubuntu.com/ubuntu focal-security InRelease               
Hit:8 http://ppa.launchpad.net/zorinos/patches/ubuntu focal InRelease          
Hit:9 http://ppa.launchpad.net/zorinos/stable/ubuntu focal InRelease           
Hit:10 https://repo.protonvpn.com/debian stable InRelease                      
Hit:11 https://packages.zorinos.com/stable focal InRelease                  
Hit:12 https://packages.zorinos.com/patches focal InRelease
Hit:13 https://packages.zorinos.com/apps focal InRelease
Hit:14 https://packages.zorinos.com/drivers focal InRelease
Reading package lists... Done
dusan@Dusan-PC:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


Although, I find it weird that it says that 0 is upgraded, installed etc.

I wish I had 32gb of ram! Then I could keep 1000 tabs opened :smiley:

Anything that needs Root Permission to run will require Root elevation. In this case, sudo which is SuperUser DO. Do as in "do this."

Why is this weird?
Are you expecting some updates?

1 Like

Usually when a package manager, such as terminal in this case says, 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

This means that your software is up to date, and your sources list is up to date, so nothing needs changed. So all is good from what I can tell.

Good work Toshi! :slight_smile:

1 Like

Thanks guys! I hope that error won't be shown anymore in the taskbar!

also for anyone wondering how I function with 100+ tabs open.

here is a phenomenal plugin you should checkout Tabs Outliner - Chrome Web Store

Does it come with a fire extinguisher? :flushed:

1 Like

Just make sure the fire extinguisher is not made in Britain, or this could happen. :rofl:

2 Likes

Hahahaha that's ridicilous!

Here is fun fact though. Fire extinguishers are made for different types of fires. Chemical fires, liquids, solids and etc. Not every fire extinguisher can be used with any fire type

1 Like

I do know of this, I have a family member who served onboard a Navy submarine. One of the first things you learn before graduating to submariner, is you are trained on how to fight fires. And thats one of the things you learn in that regard, you fight different types of fires using different types of methods. For example, oil fires, you use the foam agents.

1 Like

The IT Crowd - comedy very good.

What is Zorin premium?

There is no such version. Zorin OS 16 Pro is the version targeting businesses and the office. It provides several applications included with the OS that focus on regular business tasks, documentation, presentation, financial as well as a few that concentrate on niche environments (CAD, development, music creation, video creation) as well as the four additional gnome layouts.

Anyone trying to market "premium" is most likely pirating and should not be trusted.

You should know the versions, you've purchased and installed almost all of them multiple times now.

1 Like

https://www.g2.com/products/zorin/reviews#survey-response-4925930
If you still wondering if Zorin is great OS here people answear.