Lenovo onboard keyboard not recognized

Good morning, afternoon, evening dearest Zorin OS userbase.

I come to you with a specific issue, I use Zorin OS 16 on a new Lenovo i9 Yoga Slim, which has a built in touch screen. I assume the touch screen is giving some interference, as it doesn't recognize the physical keyboard when it is turned on.

I have tried reinstalling xserver-xorg, but that didn't seem to resolve the issue.

I hope to hear from you soon!

Can you edit grub and add a grub parameter to specify your keyboard for the system to see and use:

sudo nano /etc/default/grub

Find the line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash "
and change it to:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.direct i8042.dumbkbd"

(Yes, that says "dumb keyboard.:stuck_out_tongue: )

Once done, hit ctrl+x to exit, hit the y key to say yes to save, then the enter key to save as current configuration and close.
Once done, in terminal update the grub:

sudo update-grub

Reboot and test.

1 Like

Thanks for the amazingly quick response Aravisian!

Sadly the dumb keyboard doesn't want to get going with the changed commandline!

Do you have something else I can try? :slight_smile:

Please repeat sudo nano /etc/default/grub and change to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.reset"
Then, sudo update-grub

Test..
If that one also does not work - Try:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash atkbd.reset"

sudo update-grub
Test...

Or...
GRUB_CMDLINE_LINUX_DEFAULT="atkbd.reset=1 i8042.nomux=1 i8042.reset=1 i8042.nopnp=1 i8042.dumbkbd=1 quiet splash"

Lots of grub updating practice today...
sudo update-grub

Test that one.
If still no good, please let us know.

2 Likes

9 posts were split to a new topic: Lenovo i9 Yoga slim touchpad issue

You said the first one worked?
Maybe try a variation:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nomux=1"

Ugh, I'm going to move down the list, it's a strange issue, after a third reboot the keyboard is not functioning again. I'm going to try your other solutions as well.

1 Like

No solution seems to be working anymore :confused:

Oh! There seems to be something in line with a previous issue like this, perhaps this can be of some use?
https://zoringroup.com/forum/4/14257/
sudo dpkg-reconfigure keyboard-configuration

1 Like

It's worth a shot. Thinkpad is a little different from the yoga- Might ensure your grub file is back to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" then sudo update-grub if testing the keyboard reconfigure command.

Done! Thanks for the warning.
Is there any way for me to find out what type of keyboard is in this laptop?

Nice, I took a generic keyboard with Alt GR, and now the keyboard seems to be functioning :slight_smile: Does Zorin OS remember this setting, or should there be an imput in the grub settings?

sudo dpkg-reconfigure keyboard-configuration is remembered - as that is not a setting but a reconfiguration of the keyboard installation.

1 Like

I have tried them before installing synaptics, yes, I am going to try them again though, let's see if it changes something

Woah, the GRUB_CMDLINE_LINUX_DEFAULT="atkbd.reset=1 i8042.nomux=1 i8042.reset=1 i8042.nopnp=1 i8042.dumbkbd=1 quiet splash" has succesfully launched my keyboard!

I'm going to try rebooting a few times, to see if it sticks!

Three reboots along, and it seems like my keyboard is here to stay! Thank you so much!

1 Like

One down, one to go. I moved some posts to a new thread to try to focus on the Touchpad issue:

1 Like