Lite - Black screen after update

I run an HP desktop, I did about 6 updates to Zorin today, and did the restart it required, and when getting to encryption password, entered and accepted by the software. then Zorin finishes uploading, and goes to a black screen. After pressing the power button the Zorin logo comes on, and shuts down the PC. So what do I need to do to get my computer back up and running? Help me out!

Can you try the steps here (exact post linked)?

I have done this as stated, and i can get to the ecrytption, log in through it, and then the screen goes back to black. I just do not understand the situation.

I can however Hit Ctrl-Alt and F1 and get a Login, but it will no tlet me login in to anything at all, so it appears to me that the graphics card is not the issue, but I am newer to the Linux, and Ubuntu environment. But I am in the process of switching over everything I own!

To confirm, you got into recovery mode, added nomodeset and then it still gives a black screen?

yes that is correct.

Can you try the selected answer here?

The Ctrl+Alt+F3 onwards.

So in the GRUB menu has this
setparams ‘advanced options for Zorim’
menuentry ‘Zorin, with Linux 5.40-54-generic’ --class zorin --c
lass gnu-linux --gnu --class os $menuentry_id_option ‘gnulinux-5.4.0-54-generic–advanced-c75a3aba-7fb3-4103-8304-8635e148a976’ {
gfxmode $linux_gfx_mode
insmod gzio
if [ x$grub_platform = xxen ] ; then insmod xzio; insmod \
lzopio; fi
insmod part_msdod
insmod ext2
set root=‘hdo,msdos1’
if [x$feature_platform_search_hunt =xy ]; then
search --no-floppy --fs-uuid --set=root --hint -bios=hd\0,msdos1 --hint-ef1=hd0,msdos1 --hint-baremetal=ahci0,msdos1 d29dd336-e\845-462f-9670-0f61ca29da6e
search --no-floppy --fs-uuid --set=root d29dd336-e845-/462f-9670-0f61ca29da6e
echo ‘Loading Linux 5.4.0-54-generic …’
linux /vmlinuz-5.4.0-54-generic root=/dev/mapper/\zorin–vg-root ro initrd=/casper/initrd.lz4 quiet splash $vt_handoff
echo ‘Loading initial ramdisk …’
initrd /initrd.img-5.4.0-54-generic
menuentry ‘Zorin, with Linux 5.4.0-54-generic (recovery mode)’ --class zorin --class gnu-linux --class gnu --class of $menuentry_id_opti\on ‘gnulinux-5.4.0-54-generic-recovery-c75a3aba-7fb3-4103-8304-8635e148a\976’

I’m confused. I thought you were going to try: ?

Working on that one now!!

ok done all this, cant get back into the program, I have uninstalled, reinstalled, and done updates, and back to the same issue. I now get to what looks like a dos screen, and I can login, but cant get into the normal Zorin screen. I can run commands in this screen, any ideas?

Hi, ribivi and carmar,

I have the same problem and it happened at around the same time, after yesterday’s updates. So I’m wondering if it’s caused by the updates. (Dual booting Windows 7 and Zorin 15 Lite 32-bit.)

I followed the steps in carmar’s first linked post. In the Grub text editor, there is no line for “ro quiet splash.” As in ribivi’s menu, there is instead:

ro initrd=/casper/initrd.lz4 quiet splash

Entering “nomodeset” does not make a difference, except that the Zorin logo does not appear while booting.

At the blank screen, ctrl+alt+F1 does summon a text-based login. From there, I ran the commands recommended by the linked post (sudo apt-get update, etc). The system checks for updates and drivers, but returns nothing, and when I reboot, it’s the same blank screen.

Then I tried the top three solutions recommended by carmar’s second linked post. Nothing.

Before yesterday’s updates, booting was no problem.

Any help would be appreciated. Thanks.

@ribivi & @cnimi
I assume that sudo ubuntu-drivers autoinstall also doesn’t fix the issue?

@ribivi - are you running Lite or Core? 32bit or 64 bit?

PS - please also try sudo apt dist-upgrade

Hi, carmar,

Thanks for your response. Yes, I’ve tried both of those commands. No luck.

I’m not sure of the etiquette on forum boards, but since ribivi started this thread, I’ll keep quiet and listen for possible solutions. I just wanted to register that there’s more than one user with this problem. Thanks.

Thanks. It is fine to chime-in if you have the same problem - only need to start a new thread if there is a different problem or a variation to the same problem. Yours is the same issue.
I’d like to see if @jgordon or @AZorin can weigh-in because at this point I don’t know what the issue could be.

Thanks, carmar.

OK, I have made a little progress, but not much. Continued reading other solutions buried in your last linked post. After getting to the shell, tried:

sudo apt-get install --reinstall lightdm

Nothing. There is a suggestion to purge lightdm, but it looked as though it might take Zorin down with it. Also a suggestion to reinstall xserver-org, but don’t know what that is.

My understanding is that lightdm is the manager by which the user logs into the desktop. Is that correct? There’s an additional suggestion to try installing a different manager, gdm. Would that be worth a shot?

Finally, from the shell, I tried:


That gets me into the desktop. But I can’t figure how to get there directly by booting into it. Any thoughts?

Can you try sudo systemctl set-default ?

PS - If that doesn’t work, try sudo systemctl enable --force and then the first line.

Thanks, carmar.

I tried it in terminal. Here’s the response:

Created symlink /etc/systemd/system/ → /lib/systemd/system/

I’ll try rebooting now. By the way, I had a look inside .xsession-errors, and it’s filled with WARNINGs and CRITICALs. Would any of that information be diagnostically useful?

Tried rebooting. No luck. After the Zorin logo, the screen still goes blank. I can get into the shell with ctrl+alt+f3, and then log in, and then start the desktop with startx.

Is there any way to undo yesterday’s updates?

To be honest, this is pretty discouraging… Yesterday the operating system was working normally, and today it’s suddenly dysfunctional.

Can you check if there are any broken packages in Synaptic? If there are, use the selection under Edit to fix them.

As for reversing updates, the only thing I can think of is removing the kernel and falling back to an older one. To first check on that, when you boot, check in grub that under Advanced options you have an older kernel that you can boot into. Boot into the most recent older kernel (call it, N-1) and see if your machine works fine. If it does then remove the most recent kernel (call it, N) using Synaptic. Do a search for “linux-image” and then “linux-header”. On my machine, I have 5.4.0-54 as the current version and 5.4.0-53 as the older version. So, if I wanted to remove the current kernel and boot into the older one, I would completely remove 5.4.0-54 for both linux-image and linux-header.