Live USB taking longer than 20 minutes to boot

i am trying to install 16.3 Pro from a Ventoy USB. it worked well for 16.2 but now it gets stuck showing the Zorin OS logo after choosing the .ISO to boot from. Any ideas?

i.e. do this:

1 Like

Yes sha-256 checks out

What other distro's (if any) do you have on your Ventoy USB? Do they boot OK?

Windows 10 pro works, ubuntu works, its just mint and zorin os pro that this is an issue with. Both were added today.

Have you seen this advice: Before you install

1 Like

Looks like i had fast boot still on. Changed that but accidently fiddled with the CSM settings and dont know what it should be on. Do you happen to know?

You can have CSM enabled.
If you have CSM disabled, you may not be able to boot anything using Legacy (MBR) boot.

Ive followed all suggestions so far. Still isnt letting me past flashing zorin boot logo

Fast Boot or Fast Startup is Disabled in Windows > Control Panel > Power settings?

Secure Boot is disabled in BIOS Settings?

If 16.2 .iso is working, why not use that, then just run

sudo apt update && sudo apt upgrade

to elevate 16.2 to 16.3?


Yes on fast startup and secure boot state is set to User and OS type is set to other OS. Secure boot mode is custom. Only can choose between custom and standard

I already deleted the 16.2 iso unfortunately

Ok so i fixed it. I reset the bios to default settings and then changed what i needed too and it worked somehow. Thanks for all the suggestions


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.