Login loop - Unable to login

Hey guys,

I am unable to login to my user account via both Xorg AND Wayland :confused:
I have Zorin OS 15.3 up to date.
I upgraded the system one day and was unable to restart the computer, I had the computer on for a few days, before I was able to power it off. The problem started after I powered it up. I also installed some apps from Flathub in that period. So I am unsure if it was the update that messed with things.

The machine:

Laptop with i5 8250U processor
On board graphics (no Nvidia)

What I've done:

  • Tried to login using Wayland

    • login loop persisted.
  • Checked Xauthorithy permissions.

    • there is no file called ".Xauthority", just one called ".ICEauthority" that is owned by the user.
  • Checked /tmp permissions:

    • it is set to "drwxrwxrwt"
  • Installed another display manager:

    • installed LightDM, chose it as default, (think Zorin uses GDM by default?) and still had the same issue.
    • after i uninstalled LightDM, all ttys (1-7) show terminal windows. no login screens show up after boot now.

And this is where I am right now. Would love if I could get some advice on what to do next.

I have some back ups from a some months ago and could fish for files with a bootable drive, but would prefer not to format the machine, at least until Z16 is out...

Thanks in advance.

Are you able to access tty?
When you removed lightdm, did you install and switch to gdm?

grep "install " /var/log/dpkg.log

You may need to reconfigure gdm3.
You might try:

sudo /etc/init.d/gdm stop

sudo dpkg-reconfigure xserver-xorg


sudo X -configure

sudo /etc/init.d/gdm start

Yes, it boots into tty1.

I did not reconfigure GDM after I uninstalled LightDM, I assumed it would revert back to GDM.


grep "install " /var/log/dpkg.log

returned this:


sudo /etc/init.d/gdm stop
sudo /etc/init.d/gdm start


sudo: /etc/init.d/gdm: command not found

Good call- it looks like the kernel installation corrupted. Perhaps a net-droppage...

sudo apt install linux-image-5.4.0-66-generic

Then reboot and test

linux-image-5.4.0-66-generic was installed successfully.

running this afterwards:

grep "install " /var/log/dpkg.log

returned this:


sudo /etc/init.d/gdm stop
sudo /etc/init.d/gdm start

again returned:

sudo: /etc/init.d/gdm: command not found

I am missing something here. At first, I thought that maybe the log files were showing a previous half-install. But looking at the time stamps, those are really close together.

That init cannot start gdm (command not found) suggests that something is wrong with gdm3, as well.

What could I do to try to get it working again?
All I did was install LightDM, choose it as the default over GDM via a prompt immediately after installation, and then uninstall it after I could not login with it either.

I've not seen this particular type of login loop. I wish I was sure.

Have you tried launching from an earlier Kernel by selecting from the Recovery Menu?

No, I have not.
I was not aware that was possible/helpful. Could you walk me through it?

It is possible as long as you still have earlier installed kernels. Generally, when you install a new kernel, the older one is set aside, rather than removed.
You can launch from the Recovery Menu by holding the Left Shift Key at boot. For some users, slamming the ESC key works, instead.
Select "Advanced Options for Zorin"
This will open the recovery menu offering you a Selection of Which kernel to boot from. Arrow key down to the earlier kernel.

Ok thanks, I will give this a try when I wake up and report back

1 Like

Left shift didn't do anything, and "Esc" brought up a screen to edit grub.
I guess there are a few things I could try, such as creating another user and reinstalling LightDM.

But, I will just format it and be done with it, started the back up right now.

Now, this whole thing got me a little bit apprehensive regarding the stability of Linux (Ubuntu?). From my searches this problem seems to be rather common, and It strikes me as odd that this type of thing still exists and is not patched from LTS to LTS... If anything gotta step up my back up game.

Things like these make me wary of encrypting my laptop's SSD. Would hate to be caught in this position (old backups) and not be able to fish for files in the SSD.

Thanks a lot for your help!

I am long in the habit of backing up often and just reinstalling at the drop of a hat. But this is more due to me introducing instability, than the OS doing it. I like to poke at things until they break, then figure out how they work.

As far as stability of the OS, consider how many searches of Windows or Mac OS issues will come up as common on a web search.

Hey guys, I finally found out what was causing my login loop problems on my new install: my custom icons.

I like to manually change some icons on the system, and I do this when I first set up the OS. These are the steps I take: in the "Main Menu" application, I select an application, double click on its icon and select a new one from some custom ones I make (mostly edits from Papirus icons svgs).

Doing the above creates new .deskop files at ~/.local/share/applications. Deleting those .deskop files from tty solves the problem and I am able to login.

So, before I go trying to figure out exactly which icon causes the issue: What is the proper way to change individual icons (without changing the entire icon pack)? Is there another (better) way to do this? I love the Zorin OS icons, but I would like to change some of them.

What you can do is open your file manager at Root.
Navigate to /usr/share/icons and copy your preferred Zorin Icon set folder to /home$USER/.icons

($USER represents the account username on your computer that you created when you installed Zorin. So for you, it would be whatever your username is, not $USER).
Change ownership and read/write access recursively of the Zorin OS Icons directory either by right clicking it in your Elevated Root File manager and selecting Properties, then Permissions tab- or in terminal using the chown or chmod commands. Change them to your user account.
Now exit the root file manager and open your ~/.icons folder normally in your file manager. Right clickt he Zorin OS Icons directory and select Change Name - change it to something that differentiates it from the Zorin OS Icons name, just to make it easier to find.
Open the directory and navigate to index.theme. Open in a text editor and change the name to the same name you chose in the step above. Set the value "Inherit=Zorin" or "inherit=ZorinBlue-Dark" or whichever preferred Zorin Icon set you want to Fallback to.
Save and exit the index.theme.

From here, you can change out the .svg scalable icons to your preferred ones.
That done, you can change out any of the Fixed icons in the sized folders.
It can get tedious... make sure you find them all.
I use a batch processes to change one icon, then batch process the changes
resizing the new icons to the right folders down the line.

Sadly, this is the only way I know of what you describe above: cutting around that can lead to major display problems.

I see, not as easy as what I was doing before.
Thank you for that answer, it helps shed light into how icons work in Gnome.

From what I could gather from your answer, I could create a new folder "user_icons" and pass it as an inherit in my icon set - say in a copy of ZorinBlue-Dark in ~/.icons - before Zorin, like so:


I suppose this would make any icons in user_icons take precedent over the Zorin ones. Essentially using the system default app icons, system wide, except for the icons I add to user_icons, right?

Now, if the above approach works, could I get away with using SVGs rather than PNGs? Do the display problems occur because of the use of SVGs?

Yes, you could do exactly that, as long as your user_icons directory contains an index.theme which notes the sizes to be used. If your user_icons directory is formatted correctly, what you just described will work like a charm.

The use of Svg's did not cause the error. However, (And I experienced this recently and scared myself and another member of the forum pretty good), if the index.theme does not properly dictate the size of a scalable icon, then it may well scale to its maximum size, causing display issues - freezing, login problems, etc. This is true for .svg, png or any other format. This happens when it tries to build and load an action toolbar fitted with a bunch of 256px icons... Which looks pretty hilarious if you can catch it without freezing your desktop (I have done this a few times)...
The advantage of .svg is that you can have a sized 16 icon that scales up to 256 or 512 without any distortion. Files .svg are Text-Based Images, not raster images.
A sized 16 .png image will look awful scaled up to 256px or 512px...

The downside of .svg files is- if you are working with a lot of them; it can get Tedious doing
in Inkscape.

If you know a way of Batch Processing .svg image files - By all means please share it.
As it is for myself, whenever I make an icon set, I use .svg files as sparingly as possible, now. I only use them for Symbolic Icons which will be primarily sized 16 but can be scaled to 256 or larger. Part of my bias is that in my sets, sometimes I am dealing with 600 different icons or so or more.
If you have only 20 icons and a little bit of patience, feel free to use .svg files all you want. It will save space and give better small-to-large-scaling.
For large-to-small scaling, .png and .svg look exactly the same scaled.

Must "user_icons" be in /usr/share/icons, or can it be in ~/.icons?

Now, would the below steps work?
I put my custom app icons (named just like in Zorin) in scalable/app in user_icons, and have this for an index.theme:

Unsure if MinSize had to be 16 in all entries, or whatever Size is.

Yes, I love SVGs. They are vectors and easily editable. Very handy when I get bored of a color or wanna mix two icons together. What edits do you perform on your icons that you can do in batch? I change 30 or so icons, so I edit them one by one.

Oh, and i think I may know the culprit then.

There is this one icon I created for the Software store that is 1000x1000 px (my default Inkscape canvas size). I haven't checked, but he is my main suspect after what you have said hahaha.

They must be in ~/.icons in order to give them priority.

Icon theme and index.theme you relayed looks good. Min size should be 16. I change some of mine to 24px, instead, for better visibility. But certain boxes call only on size 16, so, for example: Places - would cut off the outside edges of the icon if size 24px is used instead of 16. some playing around with it to map it all out may be necessary if you want to use larger than size 16.

On .svg icons- None. Each must be done individually, which is painstaking and why I keep the usage of .svg icons to a minimum. You can imagine trying to edit 400 or more icons one at a time...
For .png, what edits I make vary a lot- from color changes, to fitting in details to changing different layers- but once you make the edit, you can batch process the change to the same icon as sized in the different size folders or if dealing with layers, to different icons that use the same layer. You can do this using Gimp batch Processing.

YUP! I bet that is it.

Thanks man, that has really worked flawlessly. Now I am just going ham changing my icons. hahahah

And I hear your plight. 400 icons all at once is indeed nuts. I am going to take my time, play the long game, only changing a few icons here and there. Maybe after a while I will reach that number