Media Keys stopped working?[Play/pause,Next&Previous track keys]

A big "What the heck" moment for me.
My Media keys stopped working. My "volume" wheel is still working though.
I am using a Razor Ornata v2 and it worked absolutely fine.
Decided to listen to some music and then they stopped working and i cant set them as shortcuts either.

Again, they worked before but now they dont :smiley:

Would be cool if someone could help me :sweat_smile:

EDIT I tried resetting my keyboard settings already, even unplugged the damn thing and plugged it back in and OFC rebooted many times. meh :frowning: :sneezing_face:

To segrigate a hardware problem from a software problem, could you try it out with another OS, such as Windows or Live USB of any Linux distro.
If you encounter the same issue, then it is likely your hardware that gone bad.
On the other hand, if your problem does not occur, then it is your currently installed OS that has a problem.

Here is something funny, when i press the buttons while texting or something, this happens: bcdfhjklmnprstenprstefhjklhjklfhjklefhjklhjklbcdhjklbcdbcdbcd

They type 3 letters and also depending on the combination, for example each key will produce a bcd but when i spam them "bcdfhjklbcdfhjklbcdhjklbcdefhjklnprstbcdhjklfhjklbcdhjkl" this happens.

It must be software, they worked before. But okay, i will quickly boot into a live USB

Tried it on liveUSB , they work fine there.

Which version and edition of Zorin you installed?
32 bit or 64 bit?

Can you please try:

sudo apt install --reinstall playerctl

You may need to open your Keyboard Settings and bind your media keys to the proper keys simply by adding it as a shortcut.
Once done - it should stay done, regardless of updates.

Check man playerctl for more information.

1 Like

=( It did reinstall fine but i still cant rebind the keys in the keyboard shortcut menu.

Still not working q.q

Can you please describe in detail what is going wrong? Do you follow the proper steps but nothing happens? Or does it pop up an error?

sudo apt install --reinstall playerctl <- Reinstalled, no error there.

But my media keys still do this "bcd" instead of actually being recognized as media keys. I also cant bind those keys in the shortcut, they are not being detected.

sorry my guy i forgot about you. I installed 64 bit :slight_smile:

maybe you have an idea?

You got my gender wrong :girl:
Someone also reporting a similar (but not exact) issue regarding function keys.

You might want to check the solution @marko94 suggested there.

I dont have problems with brightness though :smiley:
And all those solutions seems only to fix exactly that solution unless i am missing something here.

ΓΆ_ΓΆ unless i am super blind

What happen if you press fn key and those media keys at the same time? Sometime media keys are mapped as real function keys and additional key is required to make them work as media keys.

They just activate my keys for "gaming" mode that disables the Special Key for example, or turn off/on LEDs on the keyboard. They all work fine.
The mediakeys itself are standalone keys you know what i mean :smiley:
They are above the numpad, no FN key required to use them.

And if i try to use FN with it together nothing happens obviously =(

I am using Apple keyboard which has no independent media keys. So it depends.

I wonder @Storm might have some idea. He uses gaming mode for sure (and I don't).

I got no problems with FN mdeia keys and/or gamemode. So I can't say.
I got a logitech K750 wireless keyboard.

The "game mode" is just to disable the special key and i can see it activate with LEds. Dont worry there is nothing with my keyboard that should interfere here.
Just normal media keys without FN :smiley:

It is beautiful.
I like the colour of the backlight.

But really, I cannot think of any solution other than what I have told you already. If you are using GNOME desktop (Zorin 16 Core/ultimate) version, you might want to try Zorin 15 Lite (XFCE desktop) to see if it helps.

Super masculine combination i know :>

Purple Keyboard and pink mousepad lololol

I have asked on the Linux help subreddit, maybe someone knows something.

1 Like

:heart_eyes:

I hope you will find a better luck there.