Minimized App icons not showing in Panel


My Rhythmbox when closed, is minimizing to tray panel but not showing any icon. And there is no way in GUI to close it. Any one else?

There are currently two standing threads that describe a similar issue: That icons are not showing up in the panel.
You are not alone....

What happens if you restart the gnome shell?
alt+F2 and type in r, then hit enter - Does the icon in use then re-appear?

I'm using the standard core installation and some applications, like Discord, does not appear in the system tray when minimized.
The app is running, but I see nothing in the system tray.
But some other applications, like Telegram, works just fine and appear in the system tray.

Several users have reported this issue. App Icons are not showing up properly in the taskbar when minimized.
Tagging to @AZorin and @zorink due to the frequency of reports on this issue.


I have taken an odd liberty of Combining Several threads all noting the same issue into one in order to try to help narrow down the troubleshooting.

If, ultimately, one users issue is resolved but others are not - we can separate them out. But as the issues are so similar, I suspect a similar root cause.

The ZorinGroup has responded to this issue with this message from Zorink (Kyrill Zorin):

In order to narrow down whether it's an issue with the AppIndicators shell extension or Discord, perhaps it might be helpful to try installing an alternative system tray extension – like "Tray Icons Reloaded" – to see if the error still occurs. It can be installed on a stock Zorin OS 16 system by following these steps:

  1. Open the Terminal and enter this command: sudo apt install gnome-tweaks chrome-gnome-shell
  2. Open the Zorin menu > search & open "Extensions"
  3. Switch off the "Zorin AppIndicators" extension in the list and close this window.
  4. Navigate to this page in the Firefox web browser: Tray Icons: Reloaded - GNOME Shell Extensions
  5. Select the option to install the Gnome browser extension and follow the on-screen instructions to complete the process.
  6. After the browser extension is installed, reload the webpage for the "Tray Icons: Reloaded" desktop shell extension.
  7. Click on the switch to turn on this extension, and accept the prompt to "Install" it.

Tags on users: @Daunk, @nzalmeida

I don't quite have the time to test all of this out.
But I feel like anyone should be able to debug this, as Rhythmbox literally comes pre-installed with Zorin OS and it exhibits the same issue as Discord.
I will however say that once I installed Discord from the official homepage - and not the store - the system tray icon works.

1 Like

Until this is figured out, you can use the alt + tab keyboard shortcut to cycle through open apps. Stop on the one you want. Fyi, alt + f4 will close applications. I'm sorry i can't be more helpful.

1 Like

This does not solve the issue.
For example if you close Rhythm box by pressing the window close button; the application goes into the system tray, becomes invisible and keeps playing your music.
But at that point it does not show up in the Alt Tab menu.

It wasn't meant to be a solution... just something to assist until it is resolved. It will not help with everything.

Sorry, not trying to be rude.
Just making sure the developers don't think there's some kind of workaround using Alt Tab.
This is a big issue that needs to be fixed.

I agree- that is a major workflow interruption.

Did anyone flag the devs about this? I think @AZorin and @zorink will be the only two that could actually fix this issue. We may be able to find a workaround, but I'm sure it wouldn't do the system justice.

Yes, ZorinK's response is in post number 5.

For this workaround did not work. I have to say though that originally it worked then after a refresh I think 1-2 of weeks ago it stopped.
What I do is to go into Extensions and switch off and on the AppIndicator extension to have Discord and qbittorrent show up. I guess it will be fixed somehow. :slight_smile:

1 Like

I have just run into this problem; the Gnome shell restart worked for me. The tray icons have been working since I built my Zorin 16 Pro system, then.. just stopped in the last week.
One other observation: Every time I open an app that has a tray icon, I have to restart Gnome shell to make it appear.


This is appearing less like troubleshooting and more like feedback.

Just an additional observation that a single restart of Gnome shell doesn't fix the problem permanently in a session; a restart is required for each subsequent app that's opened. Presumably some service/daemon is "stalled", but I'll leave that to the experts, which I'm not :wink:

1 Like

I guess it looks like reloading the gnome shell is the only way that actually works properly. Hopefully @AZorin or @zorink will fix the issue in the future. :pray:

Nevermind, I read on a previous post that installing 'libappindicator-dev' would fix the issue, and for me, it did! All my tray icons now display properly without having to refresh the desktop! Thank you so much @NevC

1 Like

For me it didn't... :frowning: So annoying.