MP4 sound ok in default Videos app, nothing in VLC or Kaffeine

I've been searching online for a solution to this problem for over a week now and all the suggested fixes I've found, and tried, have failed to resolve the issue on my system.

I reinstalled VLC, via the command line and via the Software app (I currently have both versions installed for testing, but I started off with only one installed at a time, no change in the audio issue either way). I have the most up to date OS version, patches and kernel. I completely purged and reinstalled Pulse audio volume control and Alsmixer. I checked all the settings in both and they're all correct, nothing muted, auto-mute mode disabled. I installed all the latest VLC related codecs and packages via the Synaptic Package Manager.

I executed all the following commands successfully:

sudo apt-get install chromium-codecs-ffmpeg-extra
sudo apt-get install ubuntu-restricted-extras
sudo apt install ubuntu-restricted-extras

After installing all the latest VLC related codecs and packages via SPM, I noticed there was a new recommended application for MP4 playback called Kaffeine, which I also tested. But just as was the case in both versions of VLC, the result was perfect video, no audio whatsoever. The system sounds are working fine and the sound also works in the default Videos app, but the video itself doesn't display properly, terribly actually, and the app crashes when I try to skip ahead.

So the default Videos app is out of the question. I wouldn't mind using Kaffeine if anyone can honestly recommend it over VLC, but since the audio isn't working in either app anyway, I really would prefer to use VLC if someone can help me resolve this problem once and for all! :wink:

1 Like

Which version of VLC are you using?

People have been having trouble with the snap version. They recommend removing that one.

I have no issue with my VLC playing MP4 at all. I don't use snaps either though, first thing I removed from the system.

1 Like

I'm assuming "Snap" refers to anything installed via the "Software" app? I did install that version of VLC and that release number is But I also installed the other version of VLC via the command line and that release number is I did try both versions individually installed as well, but there's no sound in either version, installed either way, with both installed at the same time or either one by itself.

Can you open a terminal and post back the results of:

cat /proc/asound/cards

You may have a point...:wink:
But no, most of the software in the Software Store is APT.
You can click the Sources button in the upper right titlebar to see the Source of the package on any selected app that has more than one source.
It will show if the source is Snap, Flatpak or APT.

Have you checked in VLC tools > preferences > audioto see what it is set to? It may need to be 'audio output' rather than 'alsa'

0 [MID ]: HDA-Intel - HDA Intel MID
HDA Intel MID at 0xd7420000 irq 37
1 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xd3000000 irq 16

I don't see a "Sources" button or link in the upper right titlebar, in Help > About or anywhere else in either version of VLC I have installed. Based on what you said, could that mean both releases I have installed are actually from the same source?

The Sources button is in the Software store application.
It is only present on applications that have more than one source.

Ok, sorry I was looking in the wrong spot for that Sources button! I found it in the Software app now and one VLC version says "Flatpak" and the other one only says "package"? Would that mean APT or Snap?

I would purge all VLC installs start again and then follow the advice here:

i.e., install ubuntu restricted extras, bottom post in above thread.

I thought I purged both versions of VLC correctly before but I probably didn't purge everything the last time I tried as I searched and found several different opinions regarding what command I should use to purge them completely! Could you provide the best entire command that will completely remove everything related to VLC?

And after I successfully purge them both, which version should I reinstall this time, by itself, before running the ubuntu restricted extras command?

You want the apt version not the snap or flatpak

The source "Package" refers to APT - Advanced Package Tool.

1 Like

Ok, I followed your instructions exactly and now, with only the APT version of VLC installed and the ubuntu restricted extras, sadly there's still no sound :frowning:

In the VLC app, have you navigated to tools > preferences > audio and changed the default to ALSA audio?

I did, I've tried all the different output modules including ALSA, and I think I tried all the devices as well, still nothing ... maybe the purge commands I tried using from the askubuntu link DeanG provided (there are several command suggestions on that page) aren't fully purging VLC and any VLC extras entirely. Or it could be something else. I just don't understand what could be causing either version of VLC to output no audio while the audio works fine in the default Videos app and the system sounds are of course working fine too. I also just recently installed and tested the MP4 playback in Kodi and the audio worked fine in that app as well!

One other odd thing I noticed is when I open the Pulse audio volume control panel while a video is actively playing in VLC, VLC should be showing up in the Playback tab (if I understand correctly, all apps actively playing anything with audio should appear in that tab), but it's not there, it's almost like Pulse audio volume control doesn't recognize that VLC is playing a video, or maybe it doesn't detect VLC at all?

Anyone have another suggestion, maybe a more advanced command or script to wipe away whatever is interfering with VLC playing audio? Sorry, I'm just getting desperate and I've already reinstalled the entire OS from scratch, twice. And it shouldn't be this hard, even for a linux based OS, to get the most popular open source media player across all OS types to play audio from a simple MP4 file. If nobody can suggest anything else I'm starting to wonder if Zorin was the way to go ... :unamused: btw, I really do appreciate all the help so far, it's just that this is beyond frustrating lol

This is also a really annoying issue to have given that everything else on the system, every other device and application, works perfectly! Is there a release of Zorin that doesn't use Pulse or ALSA that only uses audio device drivers and the system settings to control all audio, no matter the source? I know I'm reaching here :slight_smile:

I get you're frustrated but I don't have a problem playing anything with VLC nor do many other people, otherwise you would see thread after thread of people having issues. This is clearly an issue with your setup whether a hardware issue or software issue.

What have you looked at outside of this forum? This forum should not be your only go to in regards to 3rd party software. When you google, you can put " VLC no sound Ubuntu 20.04". Fixes will generally work for Ubuntu or Linux Mint on Zorin as well.

Are you sure you installed all the codec files? Did you select accept on the EULA license? Did you also install all the gstreamer codecs? What Kernel are you using, is it updated?

What is the file that you trying to play?
mp4 is a container so whether you can play it will depend on what is inside it. I have h264 and h265 mp4's that I use and you can use other formats in an mp4 container too. For example if there's no video then you won't get video.

If you go to here there are some different formats of mp4 to try out. I don't think the videos have sound, btw.

Actually, I've found plenty of people with this same issue, I've been researching it for several weeks now. And if it were hardware related, I wouldn't be hearing any sound at all, system, app or otherwise, but it's only VLC with audio issues.

Numerous forums and tech blogs, including VLC support forums, spoke to unix technician colleagues in person, many with Ubuntu or similar installed at home, I never focus on only one source of information. And agreed, most Ubuntu suggestions will work for Zorin as well, just not in this case, and I've tried them all, Zorin, Mint and Ubuntu specific fixes.

Yes, see my initial post, I used several commands in terminal to do so and even installed everything VLC related from the SPM. Again, unless there's a command or app that installs additional codecs that I couldn't find in all my numerous searches, which is very possible. I did click accept on the EULA license. And yes I also installed the gstreamer codecs. Kernel version: 5.15.0-52-generic