Nautilus crashes when searching

everytime i try searching something on nautilus it crashes. everything else seems to work fine
i have tried reinstalling nautilus but that dint help.
any help is appreciated.
currently I have set nemo as my main files manager and search seems fine on that..On googling my issue it seems there is a possibility that this bug might not be fixable so in that case can i remove nautilus? and is yes how so?
also when I lauched nautilus with super + e i could start typing a file name, but on nemo i need to select search first,any way to directly search on nemo?(if nautilus is not fixiable and i need to switch)
i'am on
zorin core 16.2

Nautilus is part of the Zorin OS Desktop and is integrated. Sadly, it cannot easily be removed without removing other essential dependencies.

I also use Nemo (5) as my default File Manager. The search functionality is unparalleled. It includes file search as well as file content search.

You can start typing in either Nautilus or in Nemo to search.
The difference between them:
In Nautilus, typing a search into the Home Directory Window will search only within the Home Directories.
In Nemo, typing a search into the current Directory Window will search only within the current Directory.

There is no workaround for either of those that I know of. I just got used to clicking the search button to search.

1 Like

I'm using Nemo ver 4.4.2 .... how to upgrade to ver 5 ????

You must run all three of these commands successfuly:

sudo add-apt-repository ppa:linuxmint-daily-build-team/daily-builds

sudo apt install nemo

sudo add-apt-repository --remove ppa:linuxmint-daily-build-team/daily-builds

WARNING: If you fail to remove the repository in the last command, it can really mess up your whole system upon next upgrade.

Just to make sure I don't stuff this up I hit ENTER and not Ctrl-C

Press [ENTER] to continue or Ctrl-c to cancel removing it

Press enter key
and remove that sucker before it takes over your system, injects alien code and begins cranking out terminators intent on taking over the World.

1 Like

I think I did that a while ago when I disable updates .....

1 Like

So there is no fix for nautilus? and if so then can i remove nautllus icon from app drawer?
Also i was refering this article to add more functions to nemo

but most of these are blacked out(double click to rename,bulk rename) or not there(folder color)
running the sudo apt install commands gives following error
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package nemo-preview
I guess i need to build dependencies first, any help in doing so would be appreciated..
mainly I want
double click to rename
bulk rename
folder color
right click-->new document(rightnow i can only make txt files but I would like to be able to make libreoffice files as well)

Nautilus should not crash while searching.
Honestly - if I experienced that, I would reinstall Zorin OS. It would mean that something is wrong with the Desktop,

Yes - select Main Menu from the App Menu and uncheck Nautilus in the Accessories Category and any other category it is placed in.

These are not blacked out on mine. And they work ( I Just tested to be sure.)
Can you run

nemo --version

and relay what version you have?
You can up it to Nemo 5 here:

I have no idea what that Article is going on about. And if I try running the install command for nemo-preview, I get the same result.
A lot of these articles are just like reading Yahoo News. They just copy and paste whatever they saw somewhere else on the web without bothering to fact check or verify anything.

Let's check your nemo version and maybe install nemo 5 to see if that gets everything working properly.

hi thanks for the reply
output for nemo --version is 4.4.2
I updated the nemo version to 5.6.0 but the options are still blacked out
also for the last command i dont think it removed the repository as i coudnt see it removing anything in terminal
output in terminal;
Use at your own risk and make sure to perform regular system snapshots.
More info:
Press [ENTER] to continue or Ctrl-c to cancel removing it.

(base) farhaan@farhaan-Vostro-3491:~$ nemo --version
nemo 5.6.0
what should i do now?

additionally i did some search and found that the plugin for set as wallpaper was installed but i couldn't do right click-->.set as wallpaper

Also,in behavior there is no checkbox for bulkrename

Another thing is that i do have libreoffice files in templates but clicking on create new document only shows option for a new text document

This was also the case when using nautilus, but it seemed to work on thunar
finally i managed to get "double click to rename" working, for which i had to switch option from "single click to open files" to "double click to open files"

That is normal, but you can check to be sure.
The location is /etc/apt/sources.list.d - look for a file named linuxmint-daily-build-team.

Can you please post a screenshot?
I wonder if we are looking in different places.

unfortunately i cant screenshot with right click menu open so i took pictures instead hope that its alright

  1. no option to set image as wallpaper
  2. rename blacked out for multiple selection
  3. new document only shows text file option even though i have all templates in templates folder

I see - thanks for the photos, that clarifies a lot.
Are you using Nemo-Desktop to manage the Desktop or is that still set to be managed by Nautilus?
You can add nemo-desktop (as command) to your startup list to ensure it is always on.

I ran the following two commands

gsettings set org.gnome.desktop.background show-desktop-icons false

gsettings set org.nemo.desktop show-desktop-icons true

Is that enough? I don't know any way to check if what you asked is the case

I am afraid i don't know how to do this, do I go
startup app-->add-->then type nemo-desktop in command box?

Running that command in terminal gives :slight_smile:

Gtk-Message: 16:09:46.150: Failed to load module "xapp-gtk3-module"

** (nemo-desktop:11263): WARNING **: 16:09:46.190: Current gtk theme is not known to have nemo support (ZorinPurple-Dark) - checking...

** (nemo-desktop:11263): WARNING **: 16:09:46.212: The theme appears to have no nemo support. Adding some...
** Message: 16:09:46.222: nemo-desktop: session is not cinnamon (checked XDG_SESSION_DESKTOP,DESKTOP_SESSION environment variables.) Applying default behavior

after which I guess there is some process running in background which seems to take forever
(process running prompt when closing terminal as well as no (base) user@user:~$ comes up to type new commands)

should I do this ?
Make your computer open nemo whenever nautilus is run, by making a symbolic link named "nautilus" in your ~/bin folder, but have it point to nemo!:

mkdir -p ~/bin  # create ~/bin dir if it doesn't exist
# see where the executable for nautilus is; sample output: `/usr/bin/nautilus`
which nautilus  
# see where the executable for nemo is; sample output: `/usr/bin/nemo`
which nemo
# create symlink to back nautilus path up; this allows running 
# `nautilus_real` to run the real `nautilus`!
ln -s /usr/bin/nautilus ~/bin/nautilus_real
# create a new `nautilus` symlink to point to `nemo`; this means
# that if you run `nautilus` it will actually run `nemo`!
ln -s /usr/bin/nemo ~/bin/nautilus

Log out and log back in. Now, running nemo will run nemo, running nautilus will run nemo, and running nautilus_real will run nautilus.

this is taken from

Interesting. I have never done that one...
I would do a Timeshift backup right before trying it...

I might test that one out myself, too. Thanks for sharing it.

1 Like

You scare me with 'intreasting' :slight_smile: so are there any safer alternatives?
Currently my main objective is to make nemo run system wide,because just as you said most application still use nautilus as the filemanager (emails,web browser and zorin connect for file-share etc)

PS should i make a new post for nemo specifically? as this feels out of scope of original post


xdg-mime default nemo.desktop inode/directory

Reboot and test... If that does not produce the full Desktop Options you want... YOu could try the above. Interesting though it may be...
Honestly, it is likely pretty safe. I just have not tried it so I won't stick my neck out.

Another option would be to install the Full Cinnamon Desktop on Zorin OS.
I have made the Zenith Themes, which include Cinnamon, essentially mimicking the Zorin OS Themes.

1 Like

Can I remove gnome afterwards?
Not really a big gnome fan and cinnamon look like a great alternative I did some reading ,but couldn't come up with a way to remove gnome completely/or atleast the non essential parts

1 Like