Network broken, can I update with dvd?

My network just vanished on me and I can not seem to make it work. The nic is part of the mother board and it clearly communicates with my switch. ifconfig -a shows no sign of it.

I really do not want to reinstall the OS, I just want it back. Can I do an update from the dvd?

Happy to try to fix the nic but it is rather hard since I can not get on the net to copy in commands. I certainly can not show logs this way.

Try tethering your phone to your PC? Use your phone's hotspot, perhaps? Worth a try ...

Welcome to the Forum!

Do You use a Wifi Connection? If yes, You could try it with a Cable Connection. Another thing You could try: Restart Your Router.

No this board has no wifi. I have a few computers, no router. Everything goes in to a switch. This PC was working ok, nothing but time change. Strange that it lost the interface but its gone now.

Only thing in the dmesg I find that stands out is ACPI bios errors bug. And there are a few of those.

I have a few usb wifi's but plugging them in does nothing, reboot shows nothing.

Also had a usb to network interface and that does nothing. I think something else is broken and do not think it the network devices that are the issue. If I watch dmesg I see it added the USB device ok.

Also noticed there is no /etc/network/interfaces, I thought that was pretty standard. Is Zorin using netplan ? I see the etc/netplan but its an empty folder.

lspci shows both networks on the system, 1 realtech ( on board ) and 2 my USB nic.

This seems to be what my issue is

Although I'm not sure the best way to fix it.

I tried installing a few other network cards but they all give me error when making
saying missing files in
/lib/modules/5-15.09-generic/build

Is there a way to put the headers back? I could install offline but too many headers out there to pick from.

I guess I have to answer this one myself. No

I tried to use a 17 ISO to update and it seems to get online just fine but offer no update.

I also see what may have cause the issue, I did a
ls -l /usr/src/linux-headers-$(uname -r)
and it wants 5.15.0-91 that I do not have. If I install that it complains of a missing linux-hwe-5.15_5.15.0. I did locate this but it looks like a huge hive that requires building. I'm sure I'd do more harm then good installing it.

I tried to change grub to
GRUB_DEFAULT="Advanced options for Ubuntu>Ubuntu, with Linux 5.15.0-88-generic"
and then update-grub and reboot but it still boots to 91?

Wow, I'm appalled to the level of support here. This was ridiculously simple to solve.

All I had to do was hold shift on boot and select my old kernel. Everything works fine.

The only thing I learned in the last 3 days was that I made a great decision not to pay for pro... I'm not very familiar with linux but if no one in the community could think of this, I have no faith in this team at all. This should have been suggested days a go.

1 Like

You did not try enough with free editions and bought Pro. Furthermore, you couldn't wait 3 days. Haste makes waste.

1 Like

Thats no way to speaking to other users on here. You do realize that everyone on this forum are volunteers? I myself just like to come on here to help new users, even if i may not always have the answer you are looking for. Computers takes time to troubleshoot :stuck_out_tongue:

4 Likes

Feedback that is critical or not complimentary is still honest and useful feedback. Indeed, no helpdesk should ever remove critical feedback as that would be a confirmation bias and censorship.

Post #7 above balances a very fine line. This post was flagged by the community due to its criticality being a bit over the top.
However, since it also contains the solution and only very narrowly fits as still "within the guidelines" I have chosen to take the unusual step of annotating a Moderator Action publicly rather than resolving the issue and annotating it in the moderator forum.

@ulao, please read this Introduction.
Specifically:

Please bear in mind that this is a Community Forum populated with Forum Members and Volunteers. We are not the staff nor are we part of the Zorin Group Company. We are peers.
Members may offer suggestions or solutions to posted problems. A suggestion may not always be helpful, but please always remember that the Poster is still being a helpful member. It can take many attempts, sometimes, to successfully diagnose an issue. While a person asking for advice on solving a problem may prioritize the problem they need solved, your peers must also prioritize keeping the forum a welcoming place.

Certainly, you were frustrated as the clock was ticking. But there are important elements missing in the troubleshooting.
Certainly, trying the older kernel and even defaulting to it are suggested swiftly on this forum - I have even written standing guides on this in the Tutorials & Guides Forum. As have others.
The initial posts describing the problem, but also the timing of the problem and any recent events like updates and upgrades can be instrumental in determining the direction of troubleshooting.
Beware the X - Y Problem. Focus on the actual issue, rather than asking how to perform an assumed fix.

The Public Community Forum support is all volunteer supplied. This allows volunteers to learn as they go honing their skills and increasing their knowledge.

By taking the initiative and researching your issue, you were able to find a neat and simple solution as well as where the likely cause was. This allows you to contribute as a community member and file a kernel bug report or rely on that experience to help other members in future.
@freshjeff really said this well: It can take a lot of narrowing to troubleshoot an issue and while something may seem simple in hindsight, having key information at the outset can make all the difference in how the problem is approached and considered.

Post #7 remains for the record, but Ulao has the option of editing the post and reconsidering whether the frustration of the moment made the post more critical than necessary.

2 Likes

I'm glad that you found a solution, and that you shared it with others. It has been said already but we're all here to learn and help... for instance, TIL that you can hold shift on boot to select an older kernel. Thanks!

1 Like

Hold left shift to pull up the Grub Menu - Advanced Options if using MBR (legacy) boot.
If using UEFI boot, instead tap the esc or tab key.

1 Like

Thanks, I'm glad I never had to do this but it's very good to know how to get it done. Good to see you around, seems like it's been a while.

1 Like

This is a whole 'nother topic...:stuck_out_tongue: I have not "returned" and have been present all along.

Summary

It is true that I have stepped back from providing Front-End support for Zorin OS due to the recent changes announced for Zorin OS direction.
Initially, this departure was planned to coincide with the end of Zorin OS Lite.

I am still providing Member support in support of members, but no longer providing Zorin OS specific troubleshooting or support.

Certainly, we can all relate. Most of us disagreed with the direction Microsoft was taking and as such, departed from showing support for Microsoft and Windows. This can be amicable: "We disagree and will not agree, so it is preferable to part ways" rather than transforming it into some enmity.
It is up to the ZorinGroup to learn and grow and develop their being in touch with the community members, rather than me being that bridge for them, now.

4 Likes