No Bluetooth Found

Hello there! I recently dual booted ZorinOS 16 Core(disabling Secure Boot and Fast Boot) with my Windows 11, but later learnt bluetooth wasn't getting enabled for some reason

Checked for additional drivers to find that it was not detecting my bluetooth adapter(Realtek 4.2 Bluetooth Adapter)

Screenshot from 2021-09-28 10-49-33

Bluetooth works fine on windows don't know what's the issue on the linux side

These may help to assess my situation -

inxi output

systemctl | grep -i blue output

(This shows up only after I tried systemctl enable bluetooth.service and systemctl start bluetooth.service but no change)

dmesg | grep -i blue output

lspci output

lsusb output

I'm clueless on how to proceed further and wish to be helped!
Thanking you in anticipation

1 Like

I am just going to assume you tried flipping on the toggle on the upper right hand side of the Bluetooth menu, and it was not turning on Bluetooth correct.

Initially, I would have suspected that you didn't have the driver installed for your wireless adapter. But seeing your additional drivers APP, tells me that you do have the drivers installed.

Another solution is to avoid the Bluetooth functionality that Zorin OS 16 comes with, and upgrading to Blueman. Go to the software center and search for "Bluetooth Manager." You will know you have the right one found, as its by the Blueman group.

Install that, then after Blueman is installed, restart the computer. Then click on the :zorin: logo at the bottom left of your screen, and type in "Blueman." If Blueman finds your Bluetooth adapter, it will ask you to turn it on.

Once your Bluetooth adapter is on, it should be functioning normally. One last thing, I am sure you've already checked this, but usually most notebook computers have the ability to switch the wireless adapter on/off on the hardware level via the FN key shortcut.

So just double check that as well, to make sure its not off. If everything above fails first, then check that. OK, hope this helps!


Thanks for the quick response!
Is a single wireless adapter responsible for both wifi and bluetooth?

Followed your steps:-
Installed Blueman but it failed to detect the adapter.

sudo /etc/init.d/bluetooth status output

I didn't knew about the FN key shortcut.. I searched about that and found fn + f12 should turn bluetooth on but didn't happen. What else should I try?

Usually, yes.
What output do you get if you run:

sudo apt-get install rtl8821ce-dkms

You may need to get missing firmware:

git clone git://

sudo cp linux-firmware/rtw88/rtw8821c_fw.bin /lib/firmware/rtw88


Thanks for responding!
It seems I had that already installed.
Screenshot from 2021-09-29 09-25-46

Also it didn't generate any output for the sudo cp command(After I cloned the firmware.git)

Do you have blueman installed?

Yes, I have.

1 Like

Keep in mind that sometimes hardware in computers are made by the manufacturer, to only support WINDOWS. This means no matter what you do, you will never get it working in linux. This might be the case for your unit.

As we already know that you do have a bluetooth adapter, and while that message from bluemean usually means you don't have one, we know you do have an adapter, cause you were using it on Windows.

There is an easier way around this issue. Go to whatever your country uses for an online store, they seem to differ global wide. We here use Amazon. Pickout a well rated bluetooth adapter that supports linux. It will be an USB dongle.

Then all you gotta do is plug that sucker into an available USB port, and I can 99% gurrantee you, that Blueman is going to pick that puppy up and say, do you wanna turn it on? And your going to say, heck yes I do, click!


Can you please download the following driver:

Open your Downloads folder, right click the Linux_BT_USB...tar.gz file and select extract here.
Double click into the newly created Linux_BT_USB... directory. Right click an open area and select "Open in terminal."
If the menu does not have that option for Gnome's file manager, then open a terminal with keyboard shortcut ctrl+alt+t
Paste into it:
cd ~/Downloads/Linux_BT_USB_v3.10_20170802_8821CU_BTCOEX_20170516-1616

Now enter in the installation command:

sudo make install -s

Check configuration:

hciconfig -a

Once done, reboot and test...


What does sudo modprobe btusb yield?

Can you try:

sudo apt-get install backport-iwlwifi-dkms

Let me know if you get an error that says includes a BUILD_EXCLUSIVE directive which does not match this kernel/arch. This indicates that it should not be built. Skipped.

1 Like

Yes I got that error.

What bluetooth devices have you tried connecting to?

Haven't tried any...just following what all you told to install

Can you please try connecting a bluetooth device and relaying the results?

How should I connect..can't turn on the Bluetooth manually and also tried running blueman it couldn't connect.

2 posts were split to a new topic: USB 5.0 adapter blocked by automatic suspension

This is the part I was looking for. Sometimes, turning the device on and then running Blueman will jar the system and cause it to start working.