Bluetooth doesn't work on Zorin 16

Hello everyone and happy holidays!

For some reason bluetooth doesn't work on the latest ZorinOS 16, I can't even enable it since it shows:

I tried downloading Blueman and other stuff mentioned here but after starting Blueman it just flashes Bluetooth icon in the taskbar and that's it - it doesn't even open any GUI or anything.

Note that checking if bluetooth service is running returns me that it's active and running. I've recently switched from Windows and I don't know what am I missing.

My Bluetooth/WiFi adapter is Qualcomm QCA6174

Any of these help?

There is a newer firmware file available that might help

cd /lib/firmware/ath10k/QCA6174/hw3.0
sudo mv firmware-6.bin firmware-6.bin.bak
sudo wget
sudo mv board-2.bin board-2.bin.bak
sudo wget


If this newer firmware does not fix anything you can revert it back using the below commands.

cd /lib/firmware/ath10k/QCA6174/hw3.0
sudo mv firmware-6.bin.bak firmware-6.bin

Seems like you have Qualcomm Atheros adapter, same as mine, might be different in serial number.

1 Like

Hi there, thanks for the answer.

I did follow those commands but it didn't help. I mean, it didn't break anything but it most certainly didn't fix it - it still displays the same issue.

And how did you manage to make it work?
Or was it working properly "out of the box"?

1 Like

Is there a bluetooth switch prehaps on your keyboard ? like fn + f3 (sample)

Unfortunately no, there is only airplane mode switch on fn + f3 (I'm on Acer Aspire).
Also I don't see Bluetooth in the "quick settings" menu in the taksbar.

I honestly don't know what am I doing wrong...

Well we know the chip works because it's a wifi and bluetooth in one.

1 Like

It was working properly out of the box

Thanks, I'll then just keep on trying.

Meanwhile, can you tell me if I've done something wrong?
I've tried following first two best answers but none of them worked again, and now I'm concerned if this rtbh done something that I'm unaware of since I don't like modifying kernel and stuff related to kernel. Also, Bluetooth status is now dead(inactive) and before was up and running, how can I revert that and this command if it's necessary?

Once again, I really appericiate your help and time and I apologize for my lack of knowledge.

Have you tested the hardware? Reading this thread, most of the suggestions made really should have worked.
How long has Zorin OS been installed?

1 Like

I've installed it 5 days ago, I might re-install it for the third time and hope it'll work properly this time...

Nope, I guess I'm lost cause - I just reinstalled Zorin 16 and it still doesn't work. Note that it worked properly on Windows, so it shouldn't be hardware issue.

Thank you everyone for your contribution.

thanks, bro, saved me


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.