No wifi symbol on zorin core

Hello everbody!

I just got a new computer and decided to download zorin. However there is no wifi symbol for the wireless wifi and i can only connect to the internet through a cable. I have tried to update everything but i still cant get the wifi to work.
Do anyone know how to solve this problem? Is it possible that the problem is due to something in the hardware?

Sorry if the question is asked in the wrong forum or badly formatted. I am new to this.

@Josr Hi and welcome to ther forum.

Can you tell us more about the hardware you have Z16 Core running on?
especially: Processor, RAM, WiFi card/device.

Does WiFi show up when you use Zorin USB in "Try Zorin" mode?

In the Zorin Software Updater app settings, check that it is pointing to "Main Server", not a local server. You can also do a check for additional drivers whilst in there.

Can you please open a terminal (ctrl + alt + T) and run

lshw -c network

Post the results here.

There seem to be one or two simlar instances of this on the forum. e.g. No wifi icon in taskbar Zorin 16 Core

1 Like

Hello and thank you!

When I run the try zorin i still dont have wifi.

I am not completly sure how to check if it is pointing to the main server, how do you do that. It says downloading from server from sweden, I changed it to main but it still doesnt work.

This is the result i got when running it in the terminal:
WARNING: you should run this program as super-user.
*-network
description: Ethernet interface
product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:03:00.0
logical name: eno1
version: 15
serial: 7c:8a:e1:ab:79:64
size: 100Mbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.11.0-43-generic duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=192.168.1.151 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
resources: irq:36 ioport:2000(size=256) memory:d0504000-d0504fff memory:d0500000-d0503fff
*-network UNCLAIMED
description: Network controller
product: MEDIATEK Corp.
vendor: MEDIATEK Corp.
physical id: 0
bus info: pci@0000:04:00.0
version: 00
width: 64 bits
clock: 33MHz
capabilities: cap_list
configuration: latency=0
resources: iomemory:fc0-fbf iomemory:fc0-fbf iomemory:fc0-fbf memory:fcf0200000-fcf02fffff memory:fcf0300000-fcf0303fff memory:fcf0304000-fcf0304fff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

What is the terminal output for:

lspci -nn | grep 0280

1 Like

04:00.0 Network controller [0280]: MEDIATEK Corp. Device [14c3:7961]

It appears that this device did not get support until the 5.12 kernel...
Zorin is currently running the 5.11 kernel.

Due to a rather inane bug in Ubuntus kernel, that would be easy to fix, but they simply will not, you cannot simply install the 5.12 kernel with one easy terminal command.
But I can help you install a later kernel if you would prefer to stick with Zorin OS. Bear in mind... It is always a bit risky to use a higher kernel than what is vetted by the developer.

1 Like

Oh okay! I really dont know any of this, what is the risk of using a higher kernel?

This is hard to define, really... Usually, crashes or inability to boot. I strongly recommend performing a thorough backup of all personal files before trying to elevate to a higher kernel than the released version.

1 Like

it is a new computer so i have nothing on it. But if it crashes and stuff like that can you go back to the old kernel with no harm done or does it permanently damage the computer?

1 Like

An alternative would be to change the hardware. i.e. get a cheap USB WiFi dongle as oft prescribed by @FrenchPress

2 Likes

I believe that this is the safer and more reliable option.

1 Like

Maybe see this: In quest for Linux compatible WiFi

2 Likes

I bought a cheap usb wifi dongle and it worked! Thanks you all for helping me!

3 Likes