Nvidia drivers causing a script error with a fresh install and also after driver updating

I have been using Zorin for a long time. For no reason at all, I started getting this error after a install, but also have been getting it during a fresh install. I have loaded it on the same computer before with no problems. If I turn off download updates during a fresh install, it works fine, until I goto update the driver and get it again. Workled fine on the same computer many many times before, but just started doing this recently. I have numerous iMac's 27. It feels like it is something on the Zorin update server process. Any update or known issues with this and Zorin 17? Thanks.

Another user mentioned this as well:

The latest kernel does not agree with the Nvidia DKMS

You can use the Advanced Options for Zorin to rollback to the working kernel and lock it in as default boot:

Well! Time for everyone to switch over to AMD.

I see plenty of threads seeking resolutions to AMD GPU issues... With Nvidia, you can try combinations of kernel and Nvidia driver whereas with AMD, you can only try different kernels with the hope that AMD supplied the full drivers each time.

Strangely, Intel has the best track record for GPU stability and performance, easily.
It's had a few flubs, but AMD and Nvida have had far, far more.
But AMD and Nvidia promise high performance and that gets wallets out of pockets.

Point taken. Fair enough. But I'm just going by my experience. When I switched from NVIDIA to AMD, all my video driver issues with Zorin OS went "poof." I haven't had any issues since. It helps that AMD is a partner with the Linux collective and contributes to driver development, as well.

1 Like

@macisp2000 Welcome. Hope you can get stable iMac with Zorin like I'm trying to do so.

In case of system failed after that error, I suggest the following plan,
Fresh Install of Zorin 17.0 but DO NOT upgrade.
Install TimeShift using software and create baseline snapshot on separate partition or external HDD/SSD for emergency.
make sure you have 6.2 kernel (type uname -r in terminal) before you Install nvidia driver 390 and reboot to ensure that GPU is loaded.
Insert the following file to stick with kernel 6.2

sudo tee /etc/apt/preferences.d/nolinuxupgrades.pref <<EOF
Package: linux-*
Pin: version *
Pin-Priority: -1

and run update & upgrade normally.

That's why I moved from iMac 17.1 to 14.2 yet I still can't figure out the comfortable resolution; Please assist.

As shown above, I'm using 125% fractional scale to get 2048*1152 resolution as only two options are available too small and too large ones!

Please hint on how to get native 2048*1152 resolution to disable scaling.

Check your modeline:

cvt 2048 1152 60


cvt 2048 1152 75

Copy the modeline (but not including the word modeline and paste it after xrandr --newmode:

xrandr --newmode "2048x1152_60.00" 197.00 2048 2184 2400 2752 1152 1155 1160 1195 -hsync +vsync

Use the xrandr command to get your display name. It may be hdmi-1 or DP-1 or VGA-1...


Replace EXAMPLE with the display name you got from xrandr above:
Add the resolution:

xrandr --addmode EXAMPLE 2048x1152_60.00

You can apply it from Displays or:

xrandr --output EXAMPLE --mode 2048x1152_60.00

The command

xrandr --addmode DP-2 2048x1152_60.00

results in the following error,

X Error of failed request:  BadMatch (invalid parameter attributes)
Major opcode of failed request:  140 (RANDR)
Minor opcode of failed request:  18 (RRAddOutputMode)
Serial number of failed request:  34
Current serial number in output stream:  35

Well, I was able to get 2048*1152 by using Nvidia Settings GUI under advanced ViewPortin and Panning to 2048x1152 while keeping ViewPortOut as it is 2560x1440+0+0 (even though it doesn't make sense) but it works cause any changes yields to position the desktop on the upper left corner and leave the rest of the display empty

Now the GPU is working normally having lower temperature with 5-7% used memory as compared with 37-43% (without playing videos or any activities dealing with high graphics) for scaling option.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.