Oh no! something has gone wrong after installing nvidia-34 driver


I followed this guide: Activate NVIDIA Graphics Card - Zorin Help to install the Nvidia driver instead of the Xorg driver for my old 8600 GS on my new Zorin OS Core 16. I clicked on the only Nvidia driver listed: nvidia-340 and pressed apply: there was a pk-client-error-quark error exit status 10 (313).

I tried to reboot to see if it works anyway, but now I have the "Oh no! Something has gone wrong" message at every boot.

Can you help me, please? If it is related to the Nvidia driver, is there a way to force the Xorg driver to go back?

Thanks :slight_smile:

I solved my issue :slight_smile: :

  • Esc on boot: grub menu
  • Advanced options
  • Enable networking
  • apt-get update && sudo apt-get dist-upgrade
  • apt-get clean && sudo apt-get autoremove
  • apt-get remove nvidia-340
  • Reboot

I hope it was a good and clean solution, but It works now and I'm back with the Xorg driver and I just made a system backup :wink: .

I wanted to install the Nvidia driver to enable h.264 hardware decoding support for video playback and have the VDPAU option in Kodi.

Is installing an Nvidia driver for my 8600 GS the solution for this, and if so, do you know why installation via additional drivers does not work?


1 Like

Because it is an old card - you are better sticking with the Open Source nouveau driver that is part of the Linux kernel. Personally I have had no end of trouble using nVidia dedicated drivers when I used Zorin as my daily go to. The other issue is security as nVidia uses proprietary drivers.

Thanks, that's what I was thinking of doing but since I reverted to this driver, Steam won't launch anymore :frowning:

Does this article help?

I just managed to repair Steam, hoping that it continue to works: Steam won't launch anymore on Zorin OS 16 Core - #53 by nonobio

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.