How to enable h.264 hardware decoding support for video playback with my Nvidia 8600 GS? (VDPAU option in Kodi)


I tried to install the Nvidia driver to enable h.264 hardware decoding support for video playback and have the VDPAU option in Kodi but I had a big issue after reboot: Oh no! something has gone wrong after installing nvidia-34 driver - #2 by nonobio

Is installing an Nvidia driver for my 8600 GS the solution for this, and if so, do you know why installation via additional drivers does not work?


Your card may be to old for nvidia supporting it anymore. You could try downgrading the kernel and use a driver that fit your card.

Yes, it is not very young. I'm not going to commit too much at the risk of causing more problems because it works pretty well despite the absence of hardware decoding (the processor manages to decode most of my files). A solution would be for me to change my graphics card to a more recent one..., maybe one day :slight_smile:
Thank you anyway


1 Like

Since everything seems to work again with my new driver, including Steam, I think I will keep this driver.

By any chance, is there another way to enable VDPAU for Kodi without installing the Nvidia driver and without the risk of breaking my config like with Nvidia driver?

I found this:

Step 1
sudo apt-get update -y
Step 2
sudo apt-get install -y vdpau-driver-all

You can try running it and see if it works.
The absolute beauty of using the terminal commands to install things is that it is verbose.
It tells you what is going on. It tells you if the install was successful. If something goes wrong, it tells you what went wrong. It even offers suggestions on how to fix it. So much better than other methods that leave you wondering or mystified.

1 Like


I just thought of something: since Flatpak uses a sandbox, that could be the cause of the absence of VDPAU in Kodi?!

So, because I'm curious :wink: , I installed Kodi from Zorin source (18.6) and then from Kodi ppa manual install (20.2) and yes, hardware decoding options are here (with both versions) unlike the Flatpak version!

These are the hardware acceleration options which was missing in the Flatpak version:

Very happy, I hasten to activate the MPEG-4 VDPAU option and test a video in this format :slight_smile: .... and... :frowning: , Kodi still using the CPU to decode the video...

I am trying to install vdpau-driver-all but if I understand correctly it is already installed:

I installed vainfo which tells me VAProfileNone :frowning: image

While doing research I tried to install libvdpau-va-gl1 and mesa-vdpau-drivers but at least for the latter, it told me that I already had a more recent version.

As I said before, I can live without the hardware acceleration for the moment, but that would still be a plus for some videos that my CPU pain to decode, so if someone has a solution...

These are video system info in Kodi if it can help:

Message from a Kodi developer:

We don't support VDPAU via nouveau as there is no GLX interop supported.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.