OS 17 stops for GRUB

HI: On an HP Laptop running 16.3 I tried installing 17. Reads USB and says GRUB and quits. Same thing when I tried the 17 Beta. Does the installation require a clean SSD to install it on? Or is there some other thing to try? I've used several downloads and BalenaEtcher and a different 'flasher.'
Any help appreciated.

Have you tried Ventoy to create the USB installer?

1 Like

I had to reinstall 16.3 a couple of months ago and I ran into this, I think I solved it by booting to a Live USB and if I remember correctly running 'Boot Repair' and I'm pretty sure that was actually a part of the Live USB (look in Start/System Tools I think) pretty sure I just needed to tun it on default settings and reboot.
Otherwise you might need to reinstall Grub from a Live USB, should be fixable.
Disclaimer I am dual booting Winsux :innocent:

This may help, but as I said I'm pretty sure it was on my 16.3 Live USB install.

Hi: I tried Ventoy and now instead of GRUB I get VT Loading ........ and it hangs.
I was about to wait for another batch of Zorin updates. But Del369s answer gives me an opportunity to play around. You'll have guessed that I'm coming from Windows - I had to Google GRUB to find it what it was. Well, you have to start somewhere I guess.

This really sounds like a ISO/USB drive issue. You shouldn't need GRUB already installed on a machine to use a Live USB to install a Linux OS. Before going through anything below, consider getting a different USB stick and trying again; including a freshly downloaded ISO file with a verified checksum. You might even go so far as to use a different USB port on your computer.

No, you can install on a SSD which contains other OS and other data.

Did you get the same result on each separate downloaded ISO file? Or did results vary between attempts?

If you do the Boot Repair option, please post the results here. As mentioned by @Del369 , boot up the Live USB and use the Boot Repair application. If it's not on there, you can download it while running Live USB. Boot Repair checks for issues and has a few features, but I believe it's most-known for re-installing GRUB. It may be easier to just reinstall GRUB at this point though. There are several guides out there to help with steps to take and what to consider when you re-install GRUB.

Do you have Secure Boot disabled in BIOS settings?

When you hit Esc on boot, what options are you given? Can you change boot order, or go into the EFI menus to find your previous bootloader used with 16.3? Your symptoms make me wonder if it's somehow corrupted - but that would also mean that it's trying to boot into the corrupted loader as a result of not being able to boot from the Live USB.

1 Like

Do you have a Legacy boot, or UEFI enabled machine? :thinking:

When you made the USB, was the drive still active before ejecting? Noticed the write caching would take forever with larger files; like making a bootable.

Also if it's UEFI - you can cut out the middle-man (Etcher, Rufus, etc.) by formatting the USB in NTFS, then extract the .ISO to the root of the USB, then boot! My favorite way in the recent years :wink:

I try ventoy not boot zorin os

I would suggest people with installation issues have a quick look at advice in this thread.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.