Printer printing problem, How to install Magician, How to stress test MB

Canon MB2720 installed on Zorin 16 Lite but will only print 1 page out of many.
Need to install Magician to test 1 TB SSD. In Lite how to run stress test on MB to eliminate MB causing Freeze problems.

Does your previous solution still apply?

The printer on wife computer and installed on this computer under Zorin 16 Pro is Canon-MB2700 series Ver5.40. I tried adding printers 3 times and none added had Ver5.4 in their name.
Must be doing something wrong. What is cnijbe2//?port=net&serial=74-38-B7-08-FD-18

I'd suggest you connect the printer via USB cable initially, then assign it either a static IP address or a permanent lease, then switch to a wifi network connection using the assigned or leased IP address if that's what you want to have.

Describing how it's connected now, and a bit about your network might help troubleshoot the problem.

It is connected with USB cable. Don't understand "then assign it either a static IP address or a permanent lease, then switch to a wifi network connection using the assigned or leased IP address if that's what you want to have."

Have internet and the computer is hardwired to Switch box that is hardwired to the modem. Have another printer Zebra label printer USB connection.
I have installed Zorin 16 Pro last August and just now installed Zorin 16 Pro LITE due to freeze problem on Zorin 16 Pro. I was hoping no Freeze one the LITE version but had one freeze so far. Printer will print OK but only 1 page at a time no matter if you are printing 3 pages.
This printer works OK on Zorin 16 Pro but had a hard time getting it set up.
Hope this helps

Here is what I have found with Xfce configure printer software.
The cups will not work at all for MB2720 Canon.

Xfce discovers my Network printer immediately. I can delete it and it reloads in less than a second. It will print out only 1 Page. All other functions work.

Next I tried "Add Printer" using USB. This option will let you select Canon then select the model MB2720. I made the menu wider and found the driver version is 5.3.3. MB2720 uses Ver5.4.0 in GNONE (pronounce G-NONE) world. Then I decided to look for any model that had Ver5.4.0, Guess What, all Canon Maxify MB printers (a bunch) in the list have the same ver 5.3.3. Next I tried to Change drivers and that part of software locks up "freeze" You just keep clicking any button to get out of this menu and finally a menu pops up and says it must be busy, do you want to wait? Yes or NO.

How can the correct drivers be installed or is there a way to get Xfce to finish this printer program or is it on Zorin side?

Also I notice yesterday my MB has code AA displayed in fact right now and LITE is not frozen. So there may be hope it does not freeze.
So right now I have 2 choices, use GNONE and deal with freezes but the printer works or use Xfce and maybe no freeze but printer only prints 1 page out of multiple.
Now I really need HELP!

Have you tried this action, yet:

Here is what I get:

Unable to open document “file:///home/ezorb/Downloads/cnijfilter2-5.40-1-deb/”.
File type shell script (application/x-shellscript) is not supported.

I do not understand how you got that. The post I linked you leads to a .deb file. Are you saying that Gdebi gave that as an error?

cnijfilter2-5.40-1-deb.tar.gz When clicking on 1st link above it open a menu to highlight cnijfilter2-5.40-1-deb and click on EXtract. That opens Downloads menu and a Blue Extract button. I highlight the Document folder. (assuming Extracting here). After clicking on Extract button I get Extraction comp;eted successfully either Close or Show the Files. I clicked on Show files. That opens my Documents folder with folder for cnijfilter2-5.40-1-deb. Right click on the file opens with lots of choices with Execute I click on Execute and opens file with 3 folders packages, resources. and I double click and I get the error message "File type shell script (application/x-shellscript) is not supported -- Unable to open document “file:///home/ezorb/Documents/cnijfilter2-5.40-1-deb/”.

When I click on that error message pops up.
Dont understand Gdebi.

This part is the important part:

Once downloaded, extract the file. Opening the extracted directory, you will see a folder named Packages .
Open that and you will find cnijfilter2_5.40-1_amd64.deb

You only need to double click the *.deb package - the installer will open a GUI popup window.
Gdebi is a .deb installation manager that I find to be a bit better than the Software Store at installation.
You can install it with

sudo apt install gdebi

Once done, you can set it as your preferred .deb package manager or you can just right click a .deb package and choose "Open with gdebi"

The Gdebi installer will open offering you choices to install or reinstall or remove - depending on if the package is already installed or not... And it will note any missing dependencies, if any.

After clicking on cnijfilter2_5.40-1_amd64.deb I get window asking "Are you sure,,,,,,,is an unknow package" I click on Run anyway. I get window with cnijfilter2 with Blue Install button. I don't get Gdebi I get the Install button. After clicking I get Authecticate window so I insert PW and clicking Authecticate. It now shows installed. I will restart Lite and see if it works.

That did not work the printer just spit out paper. I will try with the Network printer. The printer screen shows printing and that is all that happens.

You may need to check the printer configuration tool and ensure that everything there is correct...

It still shows ver5.3.3

This is where I start becoming useless...

From the app menu, searching "Printers" does that dialog window show Your printer listed?

Yes it does but that is where it is messed up. Every MB printer has the same ver5.3.3 installed. That is not correct.
I assume when installed ver5.4.0 it is suppose to replace the ver5.3.3

What if you uninstall / remove all printer drivers, then run that .deb file through the installer once that is done?

How do you do that and you mean only Canon.
Is there a way to use skylink and use the printer under Gnome?

You can use APT in terminal to search for the drivers or use Synaptic Package Manager to search for and remove them.

I have no idea... Printers are my weakest subject. I usually left that to FrenchPress and Swarfendor and others to address...