Probably just a me problem, But trying to use wine for a specific program

So the program I am trying to run is called Chummer5a. It is a character sheet manager for Shadowrun 5e, a table top RPG. I wasn't sure if I should post this question here, but I have been hitting my head on a wall for a couple months, I even reinstalled Zorin OS on my laptop to start fresh after following all the online tutorials. I got it to work once on a Desktop I put Linuxfx Plasma on after I ran the Wine installer built into the OS, but it only worked that once. I tried that distro on my laptop and a couple other computers and had the same issues I have trying to get it to run on my Zorin OS. I feel like I just don't understand Wine at all and so I must be doing something wrong. I did notice that when I first put Zorin on this laptop that Wine and Winetricks was in the software store, but now it is not, and when I try to add it per their instructions on the website I don't seem to be getting the release key to work to add the repository in software updater. I had to do the entire install through Terminal, which is not difficult, just how I had to do it. If anyone is willing to help me out with figuring out how to get this one program to work on my laptop, it is literally the only Windows program I want to be able to run. I just need to find some kind of solution.

In case anyone wants to try and play around with the program, this is it. All the players in our Shadowrun Game use this and it is a safe program, but don't take my word for it if you are concerned it may be a malicious file, I just wanted to share the link in case anyone wanted to try and get it working on their end and then tell me what to do.

Did you try this tutorial ?

According to WineHQ - Chummer it works on older wine versions.
Try PlayOnLinux to install some older wine versions and see if that works. Explained in #4 here: Walkthrough/Tips for troubleshooting - PlayOnLinux (POL) - running Windows applications easier than plain vanilla Wine
POL is much easier than using just Wine.

2 Likes

Ok, I'm going to work on both of these links. I have seen other postings mentioning that older Wine versions might work. The crazy thing is the only time I got the app to work was when I set up a buddy on Linux FX Plasma, and clicked on their Wine/MSI Auto installer, and it worked. Once, I tried it again on two other Desktops and it didn't work at all. I'm hoping that eventually I will get the hang of it.

I feel a little like a traitor posting on the forums right now, they other day my WiFi driver disappeared from Zorin for some reason and I couldn't get on the internet, I was out of town and I needed my laptop working, and the only USB I had with me was my Windows Boot Media. So I am currently running Windows10 on my Laptop again. I plan to reinstall Zorin as soon as I get back home and grab my Easy2Boot USB, and I think this time I am going to Dual Boot for a while until I get better and fixing things lol :slight_smile:

Recent updates have included higher kernels. If you were running a wifi driver that was not DKMS, this would explain the wifi driver.