Problems at using Zorin on NVME!

Hi,
i am using Zorin OS on my Laptop and thought about change to Zorin OS on my main PC, too. It using Win 10 right now.

First at all, my Hardware:
Ryzen 9 3900X
32GB Ballistix DDR4 3200
MSI B450 GPC
AMD 6800
PNY CS3030 NVME 250GB
Crucial MX500 1TB SSD

When i install Zorin on the PNY, i have problems with stuttering, freezing for a second or too, stuttering sounds....
Installing i on the MX500 it works perfectly...

So.. does anybody know, whats the problem with the PNY NVME?
Not supported right now, or is there a solution to fix this problem..?

Greetz
Fuchiii

Welcome to the forum Fuchiii. I hope that you'll continue to post going forward.

What leads you to think that the PNY nVME SSD is causing the issue, instead of one of the other components, such as the Ryzen 9 or the AMD 6800XT?

I ask because PNY SSD's are vanilla, and generally don't cause issues. I use PNY SSD's on all my computers for that reason. I'm running Zorin 16 on precisely that model (PNY XLR8 CS3030 250GB M.2 PCIe NVMe) PNY SSD without issue.

I haven't looked into the issue in any depth, but a quick search of "AMD 6800XT linux issues" brings up a number of threads about stuttering, so my first instinct would be to look in that direction. I don't want to explore that potential source of the problem if you have pinned down the PNY nVME drive as the problem.

Hey, thank you for your answer.

I gave it a try and installed it on the Crucial MX500 - thats an 2,5" SATA SSD.
On this drive Zorin runs fine - no stuttering no problems.

So i guess, it must be the NVMe or the m.2 Port of my Mainboard...?

It also wasn´t a Problem of Zorin only. I had this problems with fedora, i tried to install after Zorin did not want to work, too.

My 6800 worked fine on gaming :smiley:

well, thats exactly the same i use... well..then... could it be the m.2 slot of my B450?

Thanks for testing. I see why you are looking at the PNY nVME. That's useful in helping to pin down the issue.

The Crucial isn't running off the M.2, so that might be a direction to explore.

Let me do some internet searches about issues with the PNY and see what I come up with ... you can take a look, too.

We also might want to explore the motherboard. What model motherboard are you using?

On Windows 10 running off the PNY or on Zorin running off the Crucial SSD?

I suspect that someone will come along who might be able to help us pin down the problem. I'm almost always pleasantly surprised about the depth of knowledge in this community.

2 Likes

Its an MSI B450 Gaming Pro Carbon.
I am on vacation, so poorly i havent my pc here.

But Il give solutions a try when we are back home next week :slight_smile:

NVME M.2 drives use PCIE gen 3 or these days, gen 4. The external USB ports are connected via the same PCIE gen 3 or gen 4 lanes. If it were indeed a problem there, by just trying to boot off a drive via USB, or by trying to hookup an external USB mouse or keyboard, you might discover issues with the.

However, if everything works normal with them, then that indeed will point to the NVME drive as being the culprit. But as Tom said, as long as you are sure, that you have the AMD drivers fully installed and operating within normal parameters.

Some food for thought, just don't get hungry while in your thought.

Hey StarTreker,
thank you for your thoughts to my problem.

Thats an interesting thought, too. Il check that when im back home!

A Queston to the AMD-Drviers. I had installed the graphicsdriver from the AMD-Website. Is there another important AMD driver i may forgot?

:grin:

Knowing that you got the AMD driver from their website, and I assume you got the correct one for your GPU as well, then I think you did it the best way! So kudos to you Fuchiii, you are stellar! :star2:

I have faith that we will get this figured out soon enough. Well, I am going to be going to bed and get some sleep, I been up for nearly 24-hours, so ya, my body is like, what you trying to do to my fool? Get your butt in bed before you have a body cramp or something. lol

On Win 10 running on the PNY, as well as on Zorin running on the Crucial.
With zorin on the PNY i didnt get to gaming, casueof the freezes :smiley:

haha :smiley: yeah, after 24h its time to get to bed xD

Thanks for the information. It looks more and more likely that the PNY might be at the root of the issue, maybe a firmware problem. I'm going to see what I can find out about PNY CS3030 nVME issues. I'll report back what I find out.

1 Like

My samsung 980 nvme has issues as well, after installing it refuses to boot. When i look in a live session and check the disk the boot and another partition have a mark (!). Saying the disk can not be booted. I suspect microsoft made a deal with samsung to lock the disk for other operational boots. I installed linux on a sata m2 and works fine

I just got a thought. Since when do you have Zorin installed on the CS3030? Maybe i tried it before and now its working fine..?

I checked Amazon, and the PNY nVME was delivered August 3. I didn't wait too long to put it in the computer, but it might have been mid-to-late August.

A consideration to keep in mind: My computer and yours are very different animals. Mine is vanilla Intel -- iCore processor with onboard graphics -- and yours is higher-end AMD. What works on mine might not work on yours, for whatever reason.

1 Like

Ok, thank you. I tried Zorin at 27th August.
Maybe i have to have a look at the mainboard and its drivers.

I know theres a problem with the soundchip in linux, but i got it to work and had good sound on the mx500.

Think i got to go into myself if i go to zorin or Win 11 on the desktop.

If it not works with Zorin use a different distro, microsoft uses alot of spyware and such.

My nvme refuses too with systemd bootloader, i installed linux on a sata m2 and it works just fine. I use the nvme for downloaded stuff and games. nvme does have good speeds but you would not notice much difference at all when booting.

I also refuse to use any microsoft products ever...used windows for 21 years (if not longer) and i am tired of them. Their spyware policy and their idiotic specs for a updated windows 10 aka 11 is just stupid...forcing to buy new hardware for they stupid toy(s).

Yes i know, but my nvme has 250GB and my sata has got 1TB(Gaming SSD).
I want the system to be on a seperate drive :slight_smile:

I fell in love with Zorin on my Laptop, so..if it wont work right know.. Ill just wait until it works, maybe :smiley:

I am using my pc for Video/sound editing and also for gaming, so windows is very comfortable at that. But i see how gaming is getting better and better on linux.

One thing you might try when you get back from vacation is to see if Ubuntu 21.04 (runs kernel 5.13) will install and run without flicker. If Ubuntu 21.04 runs okay, then that points us to the kernel.

nVME drives and the Linux kernel are a mixed bag. Solus OS is my primary Linux build, and there was an issue with Linux kernels 5.7 and 5.8 and certain models of Samsung nVME drives, which led the Solus to hold off and skip the kernel update until 5.9, when the kernel fixed the issue. I've seen many other reports (e.g. Michel's above) on issues with nVME drives and Linux. The issue seems to arise because nVME drives are heavily optimized toward Windows (and, no Michel, it isn't a Microsoft plot, just OEM's following the market).

I assume that your computer is running Windows 10 at present. I tested Windows 11 starting with the Beta release a few months ago, and it is a solid operating system. I installed Windows 11 on my two Windows production machines last week. So if you eventually decide to keep using Windows for the time being, an upgrade to Windows 11 should be fine, given your equipment.

2 Likes