Random horizontal delays when using apps

Hello hello
So I recently fixed my screen tearing that was caused by turning on fractional scaling by reinstalling Zorin. Though, I noticed immediately some horizontal screen delays when using the Software app in Zorin. This is a new laptop btw that didn't have these delays out of the box.
Attached is an image of it.

As you can see from the image, the "Education & Science" thingie is not supposed to be there. Neither is the "Communication & News" and "Productivity". These delays happen when there's a change in something dynamic or when opening something within an app (in this case the Software manager). Though it goes away if I let the page load a few extra seconds or by hovering over the part that has the delay.

Here are my specs

The only thing I've tried was :point_down: and it didn't work.

sudo apt remove --purge xserver-xorg-video-intel

Whatcha think I should do? I couldn't really find anything in this specific problem. Lmk if you want any more info on this problem or tests I should do to better diagnose the problem.

Are they horizontal screen delays or what looks to me delays in the Software Manager bringing back the packages to view? I've never been overly fond of Software Channels/Stores etc. Do you get the same issue when you run Synaptic Package Manager?

It's horizontal screen delays in every application. But for whatever reason, it's a lot easier to make it happen in the software app. It's random and after switching windows or any sort of movement, there's a delay that shows part of the window that I had come from.
So I imagine I could make it happen on synaptic but it doesn't relate to a specific kind of app. It's all of them that I get this problem.

Wonder if this might solve the issue?


What is this? Or what will it do?
I'm not so technical.

They are Intel drivers for Intel GPUs on GNU/Linux.

Doesn't Zorin/Linux come with the drivers we need? And I only do up to the first part of "Install run-time packages"? And uninstalling this will make it as if I never installed it in the first place correct?

I'm no expert on CL but sometimes there are GPUs that don't run well in GNU/Linux and sometimes need specific drivers or code to run correctly. This is because manufacturers gear production to Windows. Most drivers are embedded in the Linux kernel and have had to be reverse engineered to get them to work.

Okay so now that I've finally sat down and taken a better look at the guide, it doesn't make much sense to me.

So do I enter these individually or paste them all? I tried paste it all but the formatting is getting messed up.
And are these 5 individual commands or three?
If not, then what's with the indent when moving onto the next link and next command? Specifically these three parts:

  • "...graphics.key | "
  • "...key add -"
  • "...repository \ "
sudo apt-get install -y gpg-agent wget
wget -qO - https://repositories.intel.com/graphics/intel-graphics.key |
  sudo apt-key add -
sudo apt-add-repository \
  'deb [arch=amd64] https://repositories.intel.com/graphics/ubuntu focal main'

And after turning off my laptop, so I need to do sudo apt-get install -y gpg-agent wgetagain?

And I only do up to the first part of "Install run-time packages" correct?

Hi, You should just highlight all of the text in the terminal windows, copy and then paste into the terminal. Same for runtime. You don't need the developer element.

Did exactly as you said, but it seems stuck except the sudo ls because I thought it was necessary.

This is what I meant by formatting issues. Unless it worked or skipped a step that wasn't in the guide. What should I do now?

Oops I closed the terminal

Well like I have stated previously I am no expert. I am tempted to say, backup any critical data and do a fresh install. While you do have it installed you could install MultiSystem on Zorin. Get it from here:


Tutorial video here:

Then you could try another distro like MX-21 KDE or Devuan 4.0 live desktop to see if same issue occurs with other distributions.

But I haven't finished trying the first idea :frowning:

Reinstalling Zorin won't work because I already did that. And I don't want to use any other operating system but Zorin.

Appreciate what you are saying, was suggesting process to determine if issue software related or hardware issue.

This problem wasn't there when I first started using the laptop. So it should be software. I'd like to try a few more things before giving up.

Fair enough.

So how should I go about implementing the first solution correctly? We still haven't finished trying that yet.

Do you get any further following this guide?

1 Like

Well, I haven't finished the first guide. This one seems similar. Though, I still have the same exact problem as before. Well I think it's a problem. I don't think the last command completed. Here's another screen shot of that with info about my intel drivers on top.

But if the command worked properly then then it didn't work because I still have the same problem.

Remember this is all new to me. I may be comfortable with the terminal, but I still don't know how to use it properly.

1 Like

Just had a thought (dangerous I know!). I am wondering if it is not taking because the machine will be identified as Zorin not Ubuntu 20.04 ("focal fossa"). Think I posted something recently but can't remember the procedure to temporarily change the machines id to a different OS then back again once you have installed the software. Bear with.

Update 13:50 GMT - Open a terminal and enter the following (the ones in bold), one at a time:
Oops - Markdown keeps the ** instead of showing the key elements of bold!

zorin@zorin:~$ **cd ..**
zorin@zorin:/home$ **cd ..**
zorin@zorin:/$ **cd etc**
zorin@zorin:/etc$ **sudo nano lsb-release**

You will get a screen up like this:

Change Distrib_ID to Ubuntu
Change Distrib_Release to 20.04
Leave codename as is.
Change description to "Ubuntu 20.04 LTS"

To save changes in nano editor, press Ctrl+ O to write out the new changes. You will be asked if you want to overwrite - say yes.
Then Ctrl+ X to exit.

Once you have made the changes, try installing again and if successful, remember to reverse the procedure so you get updates to Zorin!