Running down a Steam rabbit hole

Okay, I was having trouble running my favorite game (Civ 6 on Steam). It doesn't open. Although it did open once after the issue began, but I couldn't get to the "create a game" option. Now It doesn't start at all, although Steam claims it's running. I couldn't find it in System Monitor, so I presume Steam is full of *it about that.

It's not a Proton issue. I tried Experimental, 7.0.4, 6.5.8. I tried all with and without forced compatibility. I know it can run on Zorin, because it was doing it for months.

I had this problem prior months ago, and I had remedied it by following Michel's procedure step-by-step, on this Forum.

So, I uninstalled Steam, Lutris, and Wine and repeated the step-by-step reloads. It was going great until I came to Steam.

I downloaded the Steam .deb file and realized I couldn't remember how to install one of those. The step-by-step skips that step. I couldn't find a straightforward answer to how to install one. A lucky click on the file told me it was in the software store and gave me the option to install from there. I thought downloading the .deb file and using the command line was to get a better version than found in the software store. I clicked on the alternative, opening the file. And I get a message that necessary dependencies are missing. I remember I saw something about that on the forum yesterday. I couldn't find it again, though.

I've got to say these kinds of issues make me want to try a dual boot with Mint. But that's a different topic. It works well for professional software, but in gaming absolutely nothing is straightforward. Of course, 2K and Aspyr don't support Zorin.

So, any suggestions on getting the game running again?

No need for Proton as it runs natively on Linux. I got the game myself.
Install Steam

sudo apt install steam
1 Like

Thanks. However, I couldn't complete your instructions. I checked ./.steam/steam/steamapps/common/Sid Meier's Civilization 6 and found no civ6*.txt file. It has a lot of files that start with civ6, but with more characters appended to the name and none listed as a txt file. I quashed the temptation to look for something close.

Then, I tried to remove the version of Steam that I have installed, thinking if I just reinstalled it from the website I would then find that file.

But the app store doesn't give me that option with Steam. I also tried "sudo apt remove steam" and it tells me it's not installed. That's obviously not correct. It's in my app menu, on my taskbar as a favorite, it opens, and I can play most games, but not Civ. And I can navigate through its folders.

I must've did this in my many uninstalls and reinstalls attempting to remedy the problem. At one time, I did have two installs of Steam showing up on my applications menu. They both opened and worked, only not with Civ. I went to the store and removed one of them. I guess this "ghost" install resulted.

My issue now is, how do I get rid of this defective version of Steam that's both there and not there, so I can follow your directions?

5 Likes

Thank you very much. I'll follow those instructions as soon as I get this rogue Steam app off my system.

2 Likes

Actually, I've undertaken a dual boot Zorin and Mint. Mint will be my gaming OS.

So, thank you.