Scrambled dialogues in Zorin 16 with AMD Radeon RX Vega 10

Hi all,
I'm am a new user of Zorin and Linux. I recently installed Zorin-16 Core and run into a strange phenomenon. Everything appears to be running smoothly, but every now and then a dialogue or submenu of a program (in this case both Thunderbird as well as BlueMail) appears as totally scrambled.
Like in:
Screenshot from 2022-04-02 14-22-05
As far as I can see, it only happens in dialogues or submenus, not in the main programs.
My laptop is an ASUS M712D, Ryzen 7, Radeon RX Vega 10 system with 20GB Internal memory.

After the first couple of appearances I tried several installs (either with and without propriety drivers), no difference. I also installed the latest amdgpu-install package, which also did not make any difference.
Has anybody encountered this likewise and knows how I can/should progress to solve this? Thanks for your help in advance!

I agree with you- This looks like graphics driver issue.
What kernel are you running?

uname -r

Thank you Aravisian for your quick reply!
The Kernel I'm running is: 5.13.0-37-generic

Hmmm...
Can you install inxi

sudo apt inxi

Then run

inxi -Fxzd

and post the output here?

Yes I can indeed. Thanks for your help!

System:
Kernel: 5.13.0-37-generic x86_64 bits: 64 compiler: N/A
Desktop: Gnome 3.38.4 Distro: Zorin OS 16.1 base: Ubuntu 20.04 LTS Focal
Machine:
Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X712DA_M712DA
v: 1.0 serial:
Mobo: ASUSTeK model: X712DA v: 1.0 serial:
UEFI: American Megatrends v: X712DA.303 date: 03/31/2020
Battery:
ID-1: BAT0 charge: 23.5 Wh condition: 26.3/32.1 Wh (82%)
model: ASUSTeK ASUS Battery status: Discharging
CPU:
Topology: Quad Core model: AMD Ryzen 7 3700U with Radeon Vega Mobile Gfx
bits: 64 type: MT MCP arch: Zen+ rev: 1 L2 cache: 2048 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 36730
Speed: 1221 MHz min/max: 1400/2300 MHz Core speeds (MHz): 1: 1222 2: 1221
3: 1282 4: 1218 5: 1222 6: 1222 7: 1308 8: 1246
Graphics:
Device-1: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel
bus ID: 03:00.0
Display: x11 server: X.Org 1.20.13 driver: amdgpu
resolution: 1920x1080~60Hz
OpenGL: renderer: AMD Radeon Vega 10 Graphics (RAVEN DRM 3.41.0
5.13.0-37-generic LLVM 12.0.0)
v: 4.6 Mesa 21.2.6 direct render: Yes
Audio:
Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
v: kernel bus ID: 03:00.1
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
driver: snd_pci_acp3x v: kernel bus ID: 03:00.5
Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus ID: 03:00.6
Sound Server: ALSA v: k5.13.0-37-generic
Network:
Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
vendor: Lite-On driver: rtw_8822ce v: N/A port: f000 bus ID: 01:00.0
IF: wlp1s0 state: up mac:
Drives:
Local Storage: total: 1.14 TiB used: 242.53 GiB (20.7%)
ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLQ256HAJD-00000
size: 238.47 GiB
ID-2: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB
Message: No Optical or Floppy data was found.
Partition:
ID-1: / size: 47.81 GiB used: 14.97 GiB (31.3%) fs: ext4
dev: /dev/nvme0n1p5
Sensors:
System Temperatures: cpu: 46.1 C mobo: N/A gpu: amdgpu temp: 46 C
Fan Speeds (RPM): cpu: 0
Info:
Processes: 292 Uptime: 6m Memory: 17.52 GiB used: 1.25 GiB (7.1%)
Init: systemd runlevel: 5 Compilers: gcc: 9.4.0 Shell: bash v: 5.0.17
inxi: 3.0.38

Everything looks fine...:expressionless:

The only thing I can think to test would be trying a different kernel.
You might roll back to a previous version. Or install a newer kernel than is currently offered by Zorin.
I wouldn't worry too much about locking the working kernel in, as the next update probably will not have the same issue.

1 Like

Oops, there you really need to help me :blush:
Being quite new to Linux and relatively little experience with installing anything other than Zorin and some light Terminal work, I do need some explanation on installing older/newer kernels.
I'm willing to have a go with it. My current Zorin install will be replaced with the Pro-version soon anyhow, and for the sake of maybe finding some useful info for people who might experience the same thing later, I'd like to help and see what happens.
Therefore: where should I look for a newer version of the kernel and what do I need to do to install that?
Thanks again for your help Aravisian, much appreciated. :+1:

There are many methods and they all safely work.
Let's keep it simple for the moment...
Installing an older kernel:
This is easier, since you likely already have the older kernel in the repositories added to your system.
For example, straight out from terminal:

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic

Or

sudo apt install linux-headers-5.11.0-27-generic linux-modules-5.11.0-27-generic linux-modules-extra-5.11.0-27-generic linux-image-5.11.0-27-generic

sudo apt install linux-headers-5.13.0-28-generic linux-modules-5.13.0-28-generic linux-modules-extra-5.13.0-28-generic linux-image-5.13.0-28-generic

You can also download the four needed packages from the Mainline kernel webpage and install all of them at once using dpkg. I can detail this method, if needed.

Installing a newer kernel:

To boot from a different kernel than the one you are using:
At boot, tap on the esc or tab key to bring up the Advanced Options for Zorin grub menu - arrow key to the kernel you wish to boot into and enter to select it.
You can verify that it worked by reaching the desktop, then running

uname -r

in terminal.

1 Like

It’s been a while since I posted in this thread. In the meantime (in my sparse free time) I’ve been through the suggestions posted above. Installed both older as well as a newer kernels. None of them having an effect. Have also tried different distro’s (Feren, PopOS and others). These did not have the observed scrambling. Then I did install Zorin Lite and much to my surprise this did NOT suffer the problem.
So maybe I’m cutting corners, but my first impression would be that the kernel may not be the problem. Maybe the desktop is causing the problem here, I’m not exactly sure how, but the desktop is in a way affecting the look and feel of windows and pop-ups.
At the same time I must admit that I really like the Lite version (though not really needed on a Ryzen7 with 20GB of memory :blush:). I’ll continue using that one for the time being.

In the meantime I’m awaiting a new version of the Desktop to see if problems do solve itself. A question that I have here is: does the Pro-version have such differences in the Desktop that it could solve the problem also?
And is it possible to use another Desktop in Zorin-Core?

No, it is the same Desktop Environments on Pro and Pro Lite as on Core and Lite.
Pro / Pro Lite just come with other perks. They do not "unlock" performance. Zorin OS is not locked behind a paywall.

Yes, you can install the Lite Desktop on Core or straight XFCE, or Plasma or Cinnamon or Mate...

I would suspect GDM3 in this case, then. You might try testing Core replacing GDM with LightDM.

XFCE (and Zorin OS Lite) are Full Functional Desktop Environments. I only use Zorin OS Lite on my GeForce 3060 machine...
It is a complete misconception that XFCE is delegated only to low end specs of older machines... It is about the Desktop Experience - it just so happens that Lite may be better for performance on lower specs, is all.

1 Like

Wow Aravisian, you continue to amaze me with the immediate and extensive responses. Thanks a lot :+1:t2:.
I”ll test the GDM replacement and will also play around with installing other desktops. It’s a bit of a learning curve for an ex-W10 user, but it certainly is fun :sunglasses:.

Unfortunately replacing GDM did not solve the problem.
The first time I logged in with LightDM active it could not start the session unless I choose "Zorin on Wayland" as Desktop. After the initial login, the subsequent logins with the normal Zorin desktop were possible. But the scrambled dialogues still exist.
I reverted back to GDM, cause a black screen with a login-dialogue at the left of the screen with options that only appears when hovered over with the mouse feels a bit clunky to me.
I'll play around with some other DE's. See what happens.

are these apps from flatpack, snap or deb versions?
check with flatpack list and snap list

This is for 18.04, but the procedure is the same on the current Zorin OS 16:

Might try this...

Bluemail is installed as Snap, Brave is installed as flatpack, Thunderbird as neither of them. In all of them the problem arises in pop-ups (in Brave when opening the just-downloaded item in the bottom of the screen, in Bluemail when pressing the “About” button, in Thunderbird when it opens the “Compact” dialogue during start-up.

Alas, no change in the behaviour.
Have uncommented the Wayland related line in /etc/gdm3/custom.conf :

# Uncomment the line below to force the login screen to use Xorg
WaylandEnable=false

But still no effect.

OK, my hope has been tempered a bit :frowning:
I've installed XFCE on Zorin Core, but the fun was only temporarily.
The scrambling still occurs but the display also shows some slight inconsistencies for example with the lines around dialogues and windows. They are interrupted around the corners and above the window-icons.
It was nice to experiment and to get it working (remember I'm still a novice), but I reverted back to the standard Core-desktop.

I think it is the Graphics drivers, then...
You might try using the Liquorix kernel:

sudo add-apt-repository ppa:damentz/liquorix -y

sudo apt update && sudo apt install linux-image-liquorix-amd64 linux-headers-liquorix-amd64

I have checked brave and thunderbird from the sources you mentioned, i am on latest zorin os core and have no issues like that.