Serious Screen Tearing in Zorin OS 16 Core

Hi, I am a Linux newbie that just installed Zorin OS 16 lite on an old LAPTOP and am having serious screen tearing issues.
Setup was ok using the 2º option: safe graphics. While loading and after it, the screen is tearing I can barely see nothing. The only solution is loading using SAFE MODE.

core 2 duo p7350 - 64 bits
ati mobility radeon hd 3470 graphics
350 gb
2 gb memory

Please if you need further information, please ask me.
Many thanks for your help

Try the method given in the link below. It worked for me.

1 Like

Thanks for help. I've been following the guide but I can not open "your Settings Manager then Window Manager Tweaks " because there are not in Zorin, or at least I couldn´f find it.

I modified the files: 10-radeon.conf (not working), and later: 10-amdgpu.conf because my card is AMD Radeon... so I was not sure which one I have to choose...

Finally, I installed Compton Compositor. When I launch it on Safe Mode is not loading when I try to launch it.

New ideas are welcome.

Your profile says Zorin OS Lite as does the title, but your screenshots look like Core.
Core does not have a Window Manager because Gnome dropped support for Window Management by an applied window manager.

1 Like

Make a file called 20-amdgpu.conf in /etc/X11/xorg.conf.d/ and paste the following. If a file named this already exists there, modify it to look like this.

(make a backup of the file before you change it.)

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  Option "TearFree" "true"
1 Like

Thanks for the comment. The version installed is CORE and RECOVERY MODE may not have this option or I can not find where is.

File didn´t exist , I created it but It didn´t work. After loading, the screen is completely useless without any icons.... Same situation as I installed it for the first time.
Anyway, thanks for your comments!

That is not possible. XFCE uses the XFWM4 Window Manager.
I really think we need to clarify which version you have installed.

Further; the screenshot of your Blue Screen looks like a Graphics Driver issue. Are you using AMD Graphics Card?

1 Like

Oh my bad. :man_facepalming: I made a mistake. I posted the Intel one. @thunderdome, delete what is inside the 20-amdgpu.conf and paste the following then save and reboot. Let's hope that this one works.

Section "Device"
        Identifier      "AMD Graphics"
        Driver          "amdgpu"
        Option          "TearFree" "true"

I enclose a screenshot with full details.
Can you tell how to open Window Manager on my version? Thanks!!!

No worries Jeslin!
File upgraded but still the same problem.

Other user using the same laptop with the same error as mine
You can watch the video:

Your screenshot shows Gnome Desktop, which is Zorin OS Core.
Would you please update your profile to reflect that it is Zorin OS Core that you are using?
I edited the Title to say "Core" instead of "lite".

For your AMD graphics, can you please open a terminal and run

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt update && sudo apt full-upgrade

Reboot and test.

1 Like

Thanks for your help. Sorry about the version I was using. I wanted to test LITE version, I mistakenly downloaded & installed CORE. (I've just updated my profile with CORE).

I runned your instructions but same bad result.

After checking info on internet (Screen flickers after I applied linux-4.15.0-65.74 update - Linux Mint Forums) a guy with the same laptop as me wrote: "I'm stuck with Kernel 4.15.0-54 (and the contemporary 5.0 and 5.3 kernels). I cannot upgrade to newer kernels."

About my own, today I have being trying different Distros on USB LIVE just for testing: XUBUNTU 21.10 , linux lite 5.6, linux mint 20.3 XFCE and linux mint 19.3 mate are also not working, serious tearing too.

However, linux mint 19.2, 19.1 y 19.0 mate are working on LIVE USB and "visually" operational. These DISTROS use Kernell 4.15.0-54, so install an old version may be a solution if it has a relation with the kernell version.

Great researching. It looks like you have found your own solution.
Currently, the earliest kernel available in the Zorin OS repos is 5.4.0-81

It may be worth trying that one and seeing if it works. If not... You would need to download the individual 4.15.0-54 packages and install them.

You may need to enter the recovery menu:
Can you please try tapping tab or left shift key or esc key At The Motherboard Splash Screen to pull up the Recovery Grub menu.
IF tab does not work, try esc . Tap with vigor.
Once you see the Recovery Grub, select Recovery Mode. Enter the recovery menu. Arrow key down to "Enable Networking." Follow the prompts to enable net connection. Once done, back out to the menu and arrow key down to the bottom to Drop to Prompt.
Enter in:

sudo apt install linux-headers-5.4.0-81-generic linux-modules-5.4.0-81-generic linux-modules-extra-5.4.0-81-generic linux-image-5.4.0-81-generic


I followed your instructions.

After choosing "Enable Networking", I got this message:

and finally I had to choose "Resume" because there was just a "refresh" of the screen. (BTW I don't know why I have to choose "network" cause it's working in Resume normal boot)

I entered the command but same bad result. Nothing changes.
I thought it may update the actual kernell version but it still the same.

Final solution would be try to downgrade to 4.15.0-54 kernell version. Is it affordable?

Thanks a lot!

What "bad result" did you get? Was there an error?
Was the kernel installed? If you install an earlier kernel, the system will not automatically boot into it. You must select that kernel from the Grub Menu in order to boot into and test it.

1 Like

There was no error, I wanted to say the "tearing" is still persisting at the same level.

I executed the command you wrote: "sudo apt install linux-headers-5.4.0-81-generic linux-modules-5.4.0-81-generic linux-modules-extra-5.4.0-81-generic linux-image-5.4.0-81-generic" (I dont know what exactly it does) but the kernel version before & after is the version: 5.13 0-27 generic.

Try tapping the esc key or the tab key or the left shift key at the MotherBoard Splash screen to pull up the Advanced Grub Menu with
Advanced Options for Zorin
Use the arrow keys to move to and select the 5.4.0-81 kernel, then hit enter to select it and boot on that kernel to test it.

1 Like

Tested it: Tearing persisting in "Zorin, with Linux 5.4.0-81 generic"

1 Like