Software Store - authentication not working

Hello all,

Using the built-in Software Store (Zorin key > Software) to install software, I’ve been prompted “To continue you need to sign in to the Snap Store.” Okay, not my preference but I did that, created an account an password, all that.

But after creating the account (and making sure everything was correct, even changing and re-checking my password to avoid pilot error on my part), it just won’t authenticate. Which means I can’t install apps through the built-in Zorin Software Store.

It’s obvious that, when I enter my email address and password (and have “I have an account already” selected) and choose Continue, it’s not even going out to check. The UI just blinks at me - meaning I click the button, it acknowledges the click, but does nothing.

I’ve tried selecting “I want to register for an account now” (takes me to my already-established account, which is in good standing). I’ve tried selecting “I have forgotten my password” (and changed it, again in case it’s me - it’s not), to no avail.

The Software Story is so convenient (when it worked, now it doesn’t for me), I don’t want to install apps from the Terminal from here to infinity. Can anyone tell me how to reset this?

Also - while I’m at it - for the weeks since I’ve been on Zorin (absolutely love it), the featured application has been “Amazon EKS” - man, I’m tired of looking at that, don’t really like AWS. Is there a way the folks at Zorin (or wherever) could cycle that thing once in a while? To… anything else?

Thanks in advance for any input.

I will try to help the best I can but be aware that I don’t use the Software Store but instead only use Synaptic. So, if I misunderstand any part, feel free to correct/elaborate.
When I did use the Software Store, I don’t recall any account setup required, that seems Snap specific. So, I think your question on login can be best answered at this forum: https://forum.snapcraft.io/categories

Thanks for the quick response. Indeed, when I first was using the Software Store it didn’t require a login, now sure how / why that changed.

I’ll check out that forum - but it seems like the attempt isn’t getting out of Zorin; as in, it’s not submitting anything from that dialog, it’s just not letting me move forward. I’ll check out Synaptic too. Thanks again.

Just to confirm we’re referring to the same program, see the attached screenshot.


If this it it, something may have gone wrong with yours - I didn’t need any login. Try reinstalling it - again I suggest you do that using Synaptic. Search for the package gnome-software and reinstall. May fix it.

Like other replies, I have never come across any Snap Store signin prompt when opening Software.

1 Like

Thanks for the replies. Yes @carmar that’s the app I’m talking about, from your screen. I uninstalled/removed (with confirmation) then re-installed the Software Store (from Terminal) but it didn’t help. I didn’t wait long between remove and (re)install, nor did I reboot, so maybe I was being impatient. But… no change in behavior. Here’s that screen where it’s asking me to authenticate:

Software-store-login-requirement

I’m installing the Synaptic next, will follow up on how that goes. Thanks again all.

The Software channel will provide that message the first time you are trying to Install or Remove any Snap Package From the Software channel. My own personal solution is: I never use Snap. Snap has a variety of its own problems.
You can also just remove the package using terminal with

sudo snap remove____

With the ____ being the package name.
Or install with

sudo snap install _____

The reason why it wants you to authenticate with Personal Information: Canonical hosts Third Party Companies providing Proprietary software in the Ubuntu Repository- It’s all about the Money.

EDIT: I just re-read the OP- you say you created an account, but it will not authenticate. Try opening the Software channel using pkexec from the terminal first, then run your installation or removal and authenticate as normal;

pkexec gnome-software

OR you can change the permissions:

sudo chmod +s /usr/lib/policykit-1/polkit-agent-helper-1

That is a screen I have never seen - clearly a Snap screen. Did you use sudo apt purge gnome-software to get rid of any configuration files? No matter because Synaptic can do that for you with the complete uninstallation option.

Maybe that is something new. I have in the past accidently installed a Snap version of an app (since uninstalled). I have never seen that Snap Authenticate screen and have never signed up to that service.

Thanks again all. I definitely unintentionally / carelessly installed a few Snap packages - I’m new to Zorin / Linux, and was a kid in a candy store with everything available.

I installed Synaptic as suggested, it installed with a generic brown box as the icon in the Zorin menu, but doesn’t launch when I select it.
Tried opening the store with the pkexec command, no change.
Tried changing permissions as suggested, no change.

Purged gnome-software as suggested, that clearly worked - it removed Software Store from my menu, and I got a message “Execution of gnome-software failed: command not found” when launching from the Zorin menu (no worries, I’ll figure out how to reinstall it).

On the Snap Store, I figured requiring the account was a data grab, assumed that was the entry price for the convenience of getting software from there. Turning out to be not-so convenient, since Zorin worked fine before I stumbled onto it. Oh well, learning all sorts of things now.

I’ll try to unwind all this later this weekend, keep track of what I do, and provide a recipe to escape my newfound software cage - then post it here in case others run into this.

Again, thanks!

That is very strange. Installing Synaptic with

sudo apt-get install synaptic

Should have no difficulty, at all. Similarly, I know that opening gnome-software with pkexec MAY fail (depending on several factors) but was worth a shot- But the permission change should have worked.

There is a difference between a Convenience and a Tool. A convenience disables the need for a tool. A tool allows you to get the job done.
It can be tricky to tell the two apart, at times. I suppose an easy way to tell the difference is to determine which one costs more. Whichever comes at a higher price- is usually the convenience.
Snap and Flatpack are… Very Convenient. They are also a security risk, and are based on Controlling the User and the Installation. They sandbox the app that is installed, cutting it off from .so files, the system theme and cannot be installed or removed by the normal methods.

Installation is fast and easy- With The Terminal.

I Have gotten that “Authentication” message before on the Software Channel. But I solved it differently- I removed all Snaps, Removed Snap and Removed Snap.d - Then installed the package I wanted normally.
Because Free Open Source Means Free Open Source. Canonical Promised that it would NOT close source with Snaps and place Exclusive Products as Snaps. And Canonical has Broken that promise. Flatpack and Snap both Violate Free Open Source and they both have security flaws to put icing on the cake.

1.) As a newcomer to Linux, you have a learning curve ahead of you. No one can lessen that load or make it easy- but it sure can be fun. Always remember that here at the beginning, Your Operating System is probably Doomed. In my first month of using Zorin, I probably wiped and reloaded the OS a dozen times from me making mistakes. So- Back up files- Often. Many will promote pretty GUI apps to do that. Me, I don’t bother with all that… I compress my Home Folder and save it on another drive once a week. Back ups- done. Easy.
“But what about my installed programs in Root?” No problem. You can elevate to root and back that up exactly the same way- Compress / directory. Save it on another drive. Done. It works- I have been doing it this way for months.
2.) Installing with Terminal:
To install most software, you need only use “sudo apt-get install ___” because most items are in the Ubuntu Repository or Zorin repository. If it is not, do a Duck or Google search for the repository you need. “Sudo add apt repository ___” With the terminal, you have constant communication, telling you line by line what is going on. You do not have that with the GUI apps. They might throw a vague error if something goes wrong or they might tell you what went wrong. The terminal tells you what went wrong… Which brings us to:
3.) Dependency problems:
The number one cause of Dependency problems is when a user tries to install an outdated or no-longer-maintained app. They do not think to check the last update date on the package or one is not readily visible. I have seen cases of users trying to install a package that was last supported in Ubuntu 12.
If installing from an active repository, and you get a dependency error; Look in the terminal screen for the first missing package. Then use “sudo apt-get install -y ____” with the ____ being that package name. Then once that installation completes, use “sudo apt --fix-broken install” and boom- Problem solved far more often than not. IF that does not solve it-- Go back to check if the package is up to date and maintained. A lot of users assume that there are hoops to jump through or special handling for all these packages- There are not. If you add a repo and then “sudo apt update” yields a 404 error on that repo, it may be unmaintained and outdated.
Use the website pkgs.org:
If you want a package this is offered by Canaonical (Ubuntu) as a Snap, but do not want Snap, or if a package dependency is missing that you need and you cannot find it in a repo… check pkgs.org. Search by the package name (such as one displayed as a needed dependency in terminal) and then navigate to the bottom of the list to Ubuntu 18.04 for Zorin 15 and Ubuntu 20.04 for Zorin 16. Select the package from the list as the architecture and build- a .deb package and navigate to its download page. At the download portion of the page, it gives a terminal installation instruction or a download link. Open the link and save the .deb file. I recommend… the Terminal for installing it. If there is a problem, Gdebi or Software will only say “dependency problems. Leaving unconfigured.” Us right click, open terminal here or open a terminal and cd to the directory holding the .deb file, and “sudo dpkg -i ____” with ____ being the package name.

The above will get most users through the vast majority of installations easily and knowledgeably. There are some special case installations- but in those cases, Flatpack and Snap would be of no help, at all, anyway. Those special case builds would not be included in Snap or Flatpack because they are not high demand common packages. It keeps Free Open source and allows the user fuller control over their system and machine and the installations.

Thanks for the post @Aravisian - lots of good advice there. Fully agree that the Software Store and Snap Store are conveniences; I’m more of a command line / Terminal fan, but do appreciate a clean UI. Too bad they’re tracking me as a oogle at the pretty graphics and organization.

On the learning curve, yes, and it is fun. Few things are more gratifying than figuring out a seemingly arcane and impossibly vexing problem. Especially with helpful folks such as yourselves for really tough pickles. On the backups/restore, fully agree: I try to be prepared at any moment to flatten the machine… that said, I have Zorin right where I like it… don’t… want… to… reinstall…

BUT – I think I’ve figured it out:
Somehow the Software Store was launching with lower privilege, as in, not as sudo gnome-software. As such, with its inability to get install permissions, Software Store fell back to “supply your account/password” but instead of asking for my sudo-capable username/pw, it fell back to Snap (don’t know why - maybe the Zorin folks could fix that).

I actually removed/reinstalled prior, no luck. I tried installing Snap Store too (knowing I could remove) and saw something catch my eye about not having sudo permission. Hmmm. So… applying that to the Zorin-native Software Store, I launched it from the terminal using:

sudo gnome-software

And viola, It works - I can install software, so on. AND, the other hint? Now, the splash screen for Software Store no longer just shows that “Amazon EKS” as a featured application. So it’s like my inadvertent installation of a Snap (or snap store, who knows) somehow commandeered the Software Store (which it shouldn’t have) and, without elevated permissions, got (me) stuck. If you go look at the Snap Store in a browser now… its Featured Software is Amazon EKS. As they say on the Incredibles, “Coincidence? I think NOT!”

So I still need to figure out how, using the Zorin menu, to make it launch using sudo, but at least I’m no longer stuck, and other folks who run into this won’t be either. I’ll try fiddling with remove / reinstall too, maybe I chose a bad selection during the process to have it install without sudo permissions. Regardless, it’s working!

Thanks again for your help, hope this helps someone else too.

1 Like

I say this every time… Usually a week before wiping and reloading.
O_o

Well… yeah. I totally said that. “pkexec” opens the gui in Elevated Permissions. Sadly, that command did not work. I know that in the odler days of “gksudo” it worked. Pkexec is fairly new as a replacement to gksudo.
Generally, it is best avoided to open a GUI from terminal with “sudo”. Sudo is a cli, not a graphical command. It usually will work… but can lead to errors later on down the line.

True…

Ah… Are you using Zorin Core or Zorin Lite?
In Zorin Lite, we can create a custom launcher using the proper command.
In Gnome, i am not so sure. I ditched Gnome and never looked back.

I’m using Zorin Ultimate (liked its look and feel so much, wanted to pay for it). In the Main Menu app/utility, I selected Properties and tried to put sudo gnome-software in the Command section, but it didn’t work for me. It still just launched as before:

Launcher-Properties

I’ll keep messing with it. If nothing else, maybe I’ll put a little Terminal script on my desktop, and launch that to open the Software app with enough privilege to add/remove programs. In part, so I force myself to learn that too.

@davidi Did you ever find a solution. I now have similar problem: Windows App Support no longer listed in Software Store