Windows App Support no longer listed in Software Store

I have searched for “Windows App Support” in the Software Store today and cannot find it listed there anymore. Where has it gone?

As ZorinOS is particularly aimed at Windows refugees then surely this is an important and unexplained omission.

You can still find reference to Zorin-Windows-App-Support if you use Synaptic package manager, but newbies will expect to see it in the Software Store, like where I first found it.

Maybe a temporary glitch? I see it on mine:

This is what I get (screenshot).

Also Software opens with Amazon EKS featured. Is that the same with you @carmar ?

No, not for me. Yours sounds like what happened here: Software Store - authentication not working
(Amazon EKS part)

1 Like

Great minds think alike :smiley: I also remembered that from the past. Did a search for Amazon EKS and got to this also:

Did that and Amazon EKS gone, also search for “windows app support” now finds it in Software Store.

1 Like

Well that was temporary. Back as was again with Amazon EKS advert and no WAS listing from search.
I don’t want to have to go into terminal and do sudo gnome-software everytime I want Software Store to display properly.
I have to pack it in now. If anyone has a permanent fix, I will have another go tomorrow.

You don’t use Synaptic?

I do use synaptic, but out of convenience also like to use Software Store whist avoiding Snaps that may appear there.
The backdrop to my original query was to indicate to someone posting on here that Windows App Support is listed and can be installed direct from Software Store. Good for newbies. So I was shocked not to find it there.
I hope there is a simple solution to the authentication issue affecting the Software Store, that I can try on my Zorin rig tomorrow. I have to go now.

I ran the update yesterday. I never use Software so… I have no frame of reference to compare today vs. yesterday against. However, I just opened Software and Amazon EKS at the top…
Searching Windows App Support yields … nothing?

Do do doooo… lalala dotty…
Ok, Just installed App Support by clicking on some random .exe (Which pretty much did nothing and did not open, btw…)
and Windows App Support now shows listed as installed, if I Scroll All The Way to the Bottom.

Update:

Search “zorin windows app support” in Software.

Yup me too. Consider this:
“zorin windows app support” renders nothing listed in Software Store.
“zorin windows app” renders Windows App Support listed in Software Store.
That was after system boot, when Amazon EKS advert is displayed in Software Store.

Opened terminal and did: sudo gnome-software
Got this:
sudo gnome-software

But then Software opens with Weather advert not Amazon EKS.
Also:
search for “windows app support” correctly displays … Windows App Support software listing.

So there remains a problem with Software Store displaying correctly consistently on my machine. Doing sudo gnome-software command seems just a work-round until I find a proper solution.

Have you checked your sourceslist?
Also your keys:

sudo apt-key list

e.g.

E4F1 620C ____ ____ ____ F4E6 010E ____ ____
uid [ unknown] Zorin OS (ISO Signing Key) os@zoringroup.com
sub rsa4096 2019-03-03

Software source = Main Server, if that is what you mean.
Keys looked OK similar to that you illustrated, but I have since Reset them to Default for good measure
Whilst I was looking at those in the Software & Updates “Authentication” settings, I had a popup warning that Apps List was out of date or similar (no screenshot) and it was updating the Cache.
Since all that did reboot, but no change. Still get Amazon EKS advert etc.

No, I mean in

/etc/apt/sources.list

and

/etc/apt/sources.list.d

This happens anytime you make any adjustments or changes in the GUI App, it says it must Reload the Information or something like that. It’s normal and will happen every time you check or uncheck something.

The Amazon EKS may just be a Software Channel advertisement and nothing more than that…

I wonder if Zorin 16 is dropping Zorin Windows App Support.

Well that is same as looking at Software & Updates “Authentication” settings which I did before.

Not sure what I should be looking for there, but nothing there looks weird or wrong.

Last night I found this item https://www.maketecheasier.com/ubuntu-software-center-not-working-fixes/

I first tried:

sudo apt clean

then:

sudo apt update

No change resulted.

then:

sudo apt-get update && sudo apt-get upgrade

Reboot for good measure.

Opened Software Store and it looked same again for the “All” software tab.
But then noticed the down arrow under Categories list. That expanded the list to include Utilities. I then found “Windows App Support” listed in that category, correctly showing ticked as installed. Bit more comfortable with that.

Opening the “Installed” software tab. I do not see “Windows App Support”, only the components “Play on Linux” and “Winetricks” are listed. Looking back at my screenshots I use as record my installed app’s, that is the same.

So it is all there. Just have to remember now to search for “zorin windows app” not “windows app support” or even “zorin windows app support” in Software Store. How weird is that!
I still don’t know why @carmar can search for “windows app support” and I cannot.

Long live Synaptic is all I can say. On there it is listed as “zorin-windows-app-support”

1 Like

I suspect it is the Amazon EKS stuff that is messing things up. I still don’t have that thing on my store page. I find app support whether I use “windows app support” or “zorin windows app support”. I think that is how it should be since the search for the former should be the superset for the search for the latter.

I suspect that: Amazon EKS == Software (app) permissions issue. So it loads, but with insufficient permissions to do much, and displays the splash (Amazon EKS) that the install came with, rather than going online to see the most recent. I have the Software icon/launcher in my taskbar, but it simply won’t launch from there - I have to go into Terminal and type sudo gnome-software for it to launch. Each time I do that, I get the recent splash (not Amazon EKS) and it works fine… but there are other conveniences (like launching a .deb by double-clicking) that don’t seem to work because of this issue.

Is there a way to bring this to the Zorin bugfix/issues team or process? I’d be happy to explain it in detail, share logs with them or whatever, for fix purposes. Seems like a pretty significant stumbling block for folks moving from Windows (or Mac) > Zorin. I’m technical enough and persistent enough, but lots of folks are not. I’m a convert, but at this point would be pressed to become an evangelist and tell my friends/employees to switch, just because of this. Any advice on how to get Zorin’s attention would be appreciated.

@davidi I understand the Software Store issue has been passed to devs, i.e. @AZorin.

2 Likes

Ah, great! Thanks for letting me know @zabadabadoo. Hopefully they’ll follow on this thread with whatever the fix is. It’s also affecting automatic Software Update, I think - I get prompted, say okay, then get prompted for the same updates the following day.

@AZorin - if I can help with any logs or further information, just let me know.

2 Likes