[Solved] Steam- Age Of Empires 4 - Problems

Hello guys

I have a steam in zorin 16, play football manager without any issues.

Now i get Age of empires4 and cant play, even open the game. The screen get black and no image.

Already search from web and im not very expert in this, so if anyone have similar issue that can help?


I change graphichs (prime extension) to nvidia no sound, nvidia on demand, sound.

But boths no image.

I think our Steam specialist volunteers might have some idea.
@Michel @StarTreker

I hope so :slight_smile:

In your screenshot where you see PROTON Experimental. Change that to PROTON version 6.3. Now try. If the game fails to load again, then go to the next version down. You just keep doing that until the game launches and plays right.

I am going to assume you have selected your proprietary Nvidia driver in additional drivers?

Please make sure your on this one...

Or! Update to this new Nvidia driver...

Make certain you are not using an Nvidia driver that has the word TESTED in it, because it causes nothing but problems for most that use it, including me.

Regarding sound, you have to choose the output that works for your setup, I have no idea what that is, since its not my computer or setup, only you know that. But, if you would like an easy way to change your output sound from the taskbar, here is a nifty tool.

Sound INPUT/OUTPUT Device Changer...

Do you ever feel like your computer never listens to you? I do everyday and I swear its causing me to have a complex! With this nifty extension, I am able to select the audio output device, its quicker then going into Pulse Audio and doing it there.

1 Like


I will try, i have this driver isntalled

I cant remember if i test with 460 driver. Tested no lucky

Proton only experimental open the game (black screen) the other ones not even open.

Just an FYI, if the OS can't interface with the hardware because of a bad driver, then Steam also can't launch a 3D game. As that requires 3D acceleration. You are using the wrong driver IMO, as it has TESTED in the name, and its most certainly causing you issues.

460 PROPRIETARY should run fine on your older GPU without issues. It does however look like your list has not been updated in awhile. Have you installed any updates recently for your OS, including driver updates?

I ask, because I find it odd that 495 is not listed in there. Anyways, I put much effort into my last post, because I knew that I was going to be going to bed, and wanted to try and cover all basis at once.

1 Like

I install a fresh zorin 16, and do the updates.

How can i force to update the nvidia drivers?

Thanks for your response mate

Zorin comes with an updater. Updates will often be found in the software store.

Night :milky_way:

1 Like

I would suggest using a custom proton -> GloriousEggroll is creating Coding, Linux guides, and Live Streaming | Patreon

Here is alot of reading stuff. How to install a custom proton is posted in post 2 -> [How-To] How to get Windows Apps / Games working in Zorin OS 16


I dont see any update....i will test with 495

no lucky black screen

I change this option in the steam

Same results this is need for play?

Thanks for this links, i have everything in steam configure right...

I really dont understand how i use a custom proton.

You are already on the 495 driver. For steam delete the steam flatpak and download the .deb file from the steam website.

1 Like

Well cant get steam load the proton folder.
EDIT: Got it thanks will test if i can play

1 Like

Well with Proton-6.21-GE-2 not working.

What i realize, dont know why if i change in prime (extesions) to Nvidia on demand they open the black screen, if only nvidia dont.

I have no idea how dual gpu work, normally i would think the intel gpu would use for normal tasks and nvidia for heavy tasks.

What proton did steam install when you installed the game through steam ?

@Michel Yes that is correct with my M6700.

I just checked ProtonDB and this game has the status silver


Maybe you can try this -> Age of Empires IV (1466860) · Issue #5258 · ValveSoftware/Proton · GitHub

You should download this proton for the fix above -> https://www.patreon.com/posts/proton-6-20-ge-1-57825497

I upload the proton and select proton for the game - Do the same result (black screen, with audio and mousse)


I did not test this script, but i read all the people do this not solve.

For the patch, i dont know if the GE version 2 already have this patch.

I will try proton GE 1 and patch to see if it's works.

Only "works" (mean black screen,sound and mousse no image) with proton GE 2 and proton experimental.

All other with patchs not working :frowning: