Some characters need to be pressed twice

Hello beautiful people.
Whenever I hit some special characters, like ^ or `, I have to do it twice for them to appear in (some) editors, and in some other it underlines them and when I press any other key, it puts a strange letter in, like ẁ or à.
How can I make it put the special character when I first hit the key?
thanks in advance

edit: I think my question causes some confusion. I want it to enter ` or ^ as soon as I hit the key, without any extra key press.

1 Like

Those special characters are part of the part of the extension to the ASCII and are meant to supplement other characters (the previous one to be precise) such that combined they form letters like á, â, ä, etc. As far as I'm aware you won't be able to write them by themselves with a single keystroke, but you can type them once entering the state of "waiting for the following" character, and then press the right arrow key which would drop them into place.

If you need to use them as part of some script then you'd have to resort to a key combination using the exact code representation.

For reference:

1 Like

I think my question causes some confusion. I want it to enter ` or ^ as soon as I hit the key, without any extra key press.

I would think it is because this special characters are made to belong to Letters. So, when You type that it waits for the Letter. When you want have it without a Letter you need to push the Spacebar for example that it knows that there don't come a Letter.

1 Like

That's the thing, those characters are meant to be used in conjunction with other characters. The behavior also varies from one OS to the next, for example in Windows pressing the ´ character twice in a row inputs that character twice. On Linux, it seems that it only adds one.
I'm not aware of any way to modify this, other than perhaps creating custom mapping to one of your keys for that explicit purpose.

1 Like

No issue here, and this is in respect of LibreOffice Writer 7.6.4.1 and TextMaker 2018 in a VM of Zorin 17. I am suspecting some sort of keyboard issue rather than OS/Software issue:

On a side note, when I was working preparing Braille for students with no vision, our supplier of Duxbury Braille Translation software advised of holding on to old keyboards as the 'chipset' on new, cheap keyboards, meant that 'six-key' entry was no longer possible, and I am talking at least 10 years ago. If you want to manually edit a Braille document, you had to use the 'six-key' entry emulation of a Perkins Brailler, the keys being sdf and jkl. In Braille you compose a letter with a combination of dots, so the letter P would be comprised of dots 1234 - for the keyboard example this would be fds j - the three keys to the left of the Perkins 'space bar key' are 3,2,1 - 1 being nearest to the space bar. I had issues with my Cherry keyboard - it generally worked with Braille Blaster, but sometimes it was a struggle and I had to revert to my old Trust keyboard for six-key entry which never hiccoughed!

Maybe I did misunderstood the question... if you are asking specifically about those two characters, then there are key mappings for those. Which mapping will depend on the layout and language.

the keyboard is german. this is the standard behaviour of such keyboards. I remember disabling this on windows and I know that I didn't have this "problem" in linux till now.

Luckily the Tuxedo laptop that I have came with German keyboard, but even after switching everything to German including layout and locale, I still get the same behavior. I can write both the ^ and ´ with a quick succession of the same key but a single press holds on until I add something else that it may modify. However other keys that would require the use of such special characters in other languages, but that are part of the language and have dedicated keys for them, such as ö, work normally with a single keystroke.

As far as I can tell this is in all desktop environments (tried Debian 12 XFCE and Linux Mint 21.2, Cinnamon), and everywhere I've looked it's mentioned the need for the Compose key. I'm afraid at this point I'm not sure of whether there's even a setting for this :confused:

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.