Speakers don't work in Zorin OS 16 Core Dual Boot with Win 11

I installed ZorinOS Core 16 to my PC laptop which contains Windows 11. The speakers work when using Win 11 but don't work when using Zorin. When increasing or decreasing the volume the popup volume display writes "Dummy Output". Does anyone know how to solve this? Thanks in advance.

1 Like

You might try:

sudo apt remove --purge timidity-daemon

sudo apt-get install --reinstall alsa-base pulseaudio pavucontrol

sudo alsa force-reload

Reboot - test sound.

If still no good, please run in terminal:

sudo lshw -C multimedia

and post that output here.

Had the same issues when I dual-booted my ZenBook with Zorin / Win11. Do a complete full shutdown in Windows and try again. The newer sound hardware is being held hostage by Win services on a reboot; full shutdown solves that. There isn't anything right now that's been updated to fix this - also might want to disable the 'quick startup' option in Win advanced power options. When I do use my Win partition - I shutdown, and then boot into Zorin. No problems, just weird!

Hope that helps!!

Thanks for your reply. I disabled “quick startup” option in Win11. However, I still have the issue.

Your other advice “Do a complete full shutdown in Windows and try again”: I turn off Win11 using the menu. Isn’t this a complete full shutdown in Win11? Please let me know if there is any other way to fully shutdown Win11, which I may not know. Thank you.

I did all the commands which you wrote and then did a reboot.

It didn't work.

Here is the output of "sudo lshw -C multimedia":

description: Video
product: ov9734_techfront_camera
vendor: Quanta
physical id: 6
bus info: usb@1:6
version: 0.03
serial: 0001
capabilities: usb-2.01
configuration: driver=uvcvideo maxpower=500mA speed=480Mbit/s
description: Multimedia audio controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 1f.3
bus info: pci@0000:00:1f.3
version: 20
width: 64 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list
configuration: driver=sof-audio-pci-intel-tgl latency=32
resources: iomemory:600-5ff iomemory:600-5ff irq:146 memory:6001120000-6001123fff memory:6001000000-60010fffff

Is it still showing as Dummy Output?


Some others suggest that using the grub parameter snd_hda_intel.dmic_detect=0 to disable mic detection will get the speakers working.

That it is showing the Driver (above) is suggestive. It appears your firmware is installed. Changing the kernel for the built in drivers may help this issue.
Kernel is not my first suspect though, as you should already be on 5.15.0-76

Did a websearch using "sof-audio-pci dummy output sound ubuntu 20.04"
There are a number of hits including:

I don't know if that is any help or not as I have not examined that link fully myself. You will find a number of hits you may see from that search, as "Dummy Output" is a common sound issue.

Is it still showing as Dummy Output?


I will check out the link. Thanks.
There are so many variables which might be causing the issue.
It's really not that easy to find a solution.

Just to try, enter pulseaudio -k on terminal to see if then when you adjust volume you don't read Dummy Output again. Note that it's a simple one-time fix, doesn't fix the problem definitively, pulseaudio will be killed and then it will soon restart.

I entered pulseaudio -k in terminal and I still get the text "Dummy Output" when increasing or decreasing volume. I don't think pulseaudio -k is working.

What device are you installing on? I had to run some commands to get my sound working with my Gateway GWTC116 'netbook', thing.. Ubuntu MATE 23.04 though:

            amixer cset name='Speaker Switch' on 
		amixer cset name='Headphone Playback Volume' 3,3
		amixer cset name='Right Headphone Mixer Right DAC Switch' on
		amixer cset name='Left Headphone Mixer Left DAC Switch' on 
		amixer cset name='DAC Playback Volume' 999,999 
		amixer cset name='Headphone Mixer Volume' 999,999

Those are the commands the brought my Intel SST card alive. If you ask me, it's DUMB sound, not smart sound LOL

And shutdown from the menu - yeah, that's it.. weird.. Do you have Secure Boot enabled or disabled? Just wondering - I know with my Zorin/Win11 setup, when I do restricted driver installs it asks for a password, then reboot, password again, then boot, and it's installed. Only my Nvidia driver though.. But, I do have SB enabled..

Also - the newer kernels (mostly) have Intel SST support. I noticed that with 6.x.x kernels on the Gateway, no tplg install or meddling - just those commands above. With 5.x.x kernels I have to uninstall the bundled SOF driver, install the custom essx8336 driver, then run the commands, and it works, even updates the driver and stays alive.. and only once, I don't have to do anything else after that. I boost volume with alsamixer but, that's not related. BTW, Zorin16.2 would not let me get my intel SST card working with the Gateway - only Mint / Ubuntu MATE flavors.. Not such a big deal, I'm a MATE fan anyway. Buuuut - I haven't yet tried any new kernels with Zorin.. don't wanna break it haha

What do you get if you issue 'sudo dmesg | grep -i sof' - or 'sudo dmesg | grep -i audio'?

Thank you for your help. I deleted the whole system and then had to reinstall Win11. Now I only have Win11. It was a nightmare. I even lost grub. Everything was lost. I am now afraid to make bold moves.
Yes there is secure boot and it was enabled, which I didn't know until after I had issues and started my research to save my device.

I plan to start from the beginning and create a new topic. I am going to write all the information about my device and try to find an expert who can write each step or even connect Zoom to help me convert my device from Win11 to Zorin or any other Linux. Because this is not just speakers issue. There is something on the way to create issues installing anything other than Windows on the device. For example, the finger print reader doesn't work. mic doesn't work. etc.. There is a dark force behind all which only lets Windows to use these.

1 Like

Before re-installing, maybe have a look at this useful pre-installation advice (if you have not looked at it before). Before you install

This post states for Win 10. Are the procedure the same for Win 11?
It looks useful. Thanks

I do not have Win11, but should be a check-box setting under Power Options in Win11 like Win10.
If you do a websearch for "disable fast startup Win11" you will get answers e.g. How to enable or disable fast startup on Windows 11 | Windows Central

Thank you. Sure I will check online.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.