Strange issue with USB-C Ethernet cable

Dear all,

I have a strange issue with my USB-C Ethernet cable. When I boot my laptop with Zorin OS 17 and my USB-C Ethernet cable plugged in, I can see the Wired connection in Network and everything works fine.
But if I unplug it and plug it back, I don't get the Wired Ethernet connection anymore and my only option to get it back is to reboot. I've tried an other USB-C Ethernet cable and I can reproduce the same issue.
Any idea of what is going on?
Thank you

On my searches, found that if wifi is on, this can cause issues. Could not find anything similar to your issues:

Thank you, I have the same issue when wifi is turned off.

An old thread, but the network command via Terminal may be needed in the answer given here:

1 Like

I found this other thread with a similar approach, in case the one doesn't do it.

1 Like

Thank you, I've tried that but it didn't work for me.

Have you tried zenzen's posting?

Sorry not yet, I was trying to sort out my failed kernel issue first.

Thanks a lot @zenzen, this thread solved the issue for me.
I wasn't the ifconfig command at the end of the post that solved it but running the following:

 sudo lshw -C network

This seems to refresh the network and then my Ethernet connection is detected again.

1 Like

That's interesting, that just by trying to read the network information it would start working again :confused:

Probably best to mark your post as the solution so that anyone looking into this can follow this suggestion as well.

1 Like

Just to correct the command it should be a capital C.

sudo lshw -C network
1 Like

It is strange indeed. It also don't pick up my USB-C Ethernet cable first time, I sometimes need to re-run the command multiple times until I see a small earth with three dots icon appearing in my menu bar.

Thanks for the clarification. Yes, you are right, -C is the correct flag. I have edited my post above to reflect this. Thanks a lot

1 Like

It may be a race condition: the hardware information is read after wake up but the adapter hasn't initialized properly. But it's just a guess.

1 Like

A post was split to a new topic: Zorin OS 17 Fresh install no Ethernet

Hello @zenzen,
Hmm, I think my issue is not only with this USB-C Ethernet cable but with any USB3 devices connected via USB-C. I had some External drives that I could not see from Zorin OS. Turned out that after running the following command they showed up:

sudo lshw -C storage

Not a problem with USB2 via USB-C Hard drives, these mount as soon as connected. Any idea what could be going on?
It could also be a MacbookPro 14,1 specific issue since I also have other hardware issues under Zorin like sounds and camera not working out of the box...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.