System with Nvidia card randomly freezing (and crashing)

I've been using Zorin OS for the past little while as my primary OS. Unfortunately around three times a day my system will freeze (everything, can't alt tab, can't open a terminal) and after around a minute will crash and reboot. So far I've been lucky and haven't lost anything but I also haven't found the cause.

I suspect that nvidia is involved somehow as I first encountered the crash while changing display scaling. Beyond that I am not sure. I think that my integrated card and my 1070 are causing issues with each other. Should I try disabling my integrated graphics?

The crash has also occurred at seemingly random times, but at the time I was doing some heavy lifting resizing and formatting things in gparted. (and moving things from ntfs to ext4)

So those are my ideas, either a disk issue or an nvidia issue. Thoughts?

Are you using Fractional Scaling?

Are you logged into Wayland?

I have the same card! what driver do you use ?

I would have disabled the onboard graphics in BIOS before installing Zorin (or any other OS for that matter) as it could potentially cause IRQ clashes.

Also see this thread to find out what is causing the issue:

I am aware it is not always the best option for all users but I have had the least issues with using GNU/Linux Nouveau drivers rather than using proprietary blobs.

I am not using fractional scaling on that device, as for wayland, unfortunately I don't know what that is.

*Looked into wayland, I'll have to double check that it is disabled

I did consider switching to nouveau drivers instead of nvidia, but was concerned about compatibility with games etc. Thank you for the link!

I have been using the proprietary tested driver from nvidia, do you know of a more stable one?

Yo Matt

Sooooooo, I haven't seen a screenshot of your Additional Drivers APP yet, and as such, I do not know which specific Nvidia driver you are using.

What I can tell you is, if you are using an Nvidia driver with TESTED in the name, your gonna have issues like you are describing.

What you want to do, is use only a PROPRIETARY driver, weather it be 460, 470, or 495. For illustrative purposes, please see my screenshot of the driver I am using.

Use the 495 driver

There have been reported problems with the 470 driver, ttry see if you can get the latest or use an older driver.

I got an impression that it is an issue for those who have integrated GPU aside from NVidia. I never had an issue with .470 on my 2 desktops with NVidia GPU - none of them got an integrated graphics.

1 Like

Yes, a lot of notebook computers today, including gaming machines, have dual GPU's. My last gaming notebook had dual GPU's, and so does my new one. Whenever you have dual GPU's, it can invite problems.

Some issues can be solved with those by just going into the BIOS's, and telling your machine to use Nvidia online, or integrated only. Some machines like my new computer, have what is called a MUX switch, which is just a hardware level version of that switching.

Now, I wanted to tell you guys something, it is well known, if you have both GPU's enabled, the signal has to pass through the integrated, before it goes to your discreet GPU, causing a 10% difference, as in 10% reduction of total performance.

If you set your machine to Nvidia only, it bypasses the integrated GPU, and you gain a 10% increase in total gaming performance. However, something I noticed, when I tried to disable my integrated GPU in my computers BIOS, I noticed that my OS was acting graphically buggy.

When I got to the login screen, everything was just all wackydoodle and completely off. I discovered, that Linux wasn't going to let me completely disable the integrated GPU, because it obviously needed it, even if I had no intention on using it.

So I re-enabled the integrated GPU just to get Linux to straighten up and fly right. And thats when I later discovered the extension Nvidia Prime Indicator, which I use on the software level, to force use only the Nvidia GPU.

Its a win win. Linux is happy to see my integrated GPU, and I am happy, cause I get to use my Nvidia GPU only. I know, so weird, but Linux is weird people. What can I say? Anyways, thats my story.

1 Like

I will have to look into this, as I couldn't disable the integrated gpu without the same issues you described. I have it set to prioritize the nvidia card but couldn't force it to be used 100% of the time.

This is what I was using, who would've thought the tested ones are less reliable lmao. I'll switch to 495 I think

1 Like

Bad news, I have been continuing to have these crashes. Most commonly when loading in various games, but also when just using the desktop.

I'm not sure if this will give anyone a hint but the audio loops during the freeze up until the crash occurs. The last ~1/2 second of audio will loop.

I tried adding nvidia prime indicator but was unable to get it to work on my system. The drivers I am now running are the 495 proprietary drivers.

This sounds a lot like:

1 Like

Wish I could say I magically found a solution but unfortunately I have not. Sometimes a system update helps smooth things out for a day, but then I'm usually right back to the crashes. I checked the link @Aravisian provided to a similar issue but the solutions there didn't work for me either :sob: although they did make me think to mention that I am running a vpn on my system (windscribe)

I have tried all the available nvidia drivers, and the opensource ones too but they caused compatibility issues. The problem appears nonetheless with any of those settings.

I have tried prime indicator, but it does not prevent the crashes.

I am convinced that it is something to do with graphics as the crashes happen at an elevated rate when in games. (5-10 crashes per hour when in games)

This is a very frustrating experience as apart from these crashes I love zorin. :broken_heart:

Is there any chance to test your system with a different OS?

If the symptom disappear, it is a OS issue.
If the symptom persists, then it is a hardware issue.

If windows counts then the system is stable in win 10?
I'm hesitant to install more OS's as this is my main machine with all my data

1 Like

USB live session?
No installation require.


Well I have since tested with PopOS and the error happened there too. What would cause this instability hardware wise?